Введение

I love Ukraine

Введение

Слава Україні! Героям слава!

Привет пользователь, измученный Автокадом Электрикалом! :-)

Настоящая программа (в дальнейшем: мулька, софтинка, программулина, программулька, прожка, утилитка, тулза и т.д. и т.п.) создана для облегчения выполнения некоторых операций при создании проектов и распечатки оных, нарисованных в AutoCAD Electrical (в дальнейшем: АЭ, кад, акад, афтокал, autocad и т.д. и т.п.).

Создана программка была не от хорошей жизни, а исключительно по необходимости. И позволила реально снизить объем рутинных операций и получать приемлемые результаты в повседневной работе. Чего и Вам желаю :-)

Общее описание

Что нового

Created with the Personal Edition of HelpNDoc: Streamline Your Documentation Creation with a Help Authoring Tool

Project12 – Utilities v28.49 Copyright © 2011–2025 Kirill Home Enterprise. All rights reserved. >>> Слава Україні! Героям Слава! <<<


Общее описание предыстории создания

Слава Україні! Героям слава!

Те кто работает в AutoCAD Electrical (АЭ) сталкивается, думаю сталкивается (я так сталкиваюсь постоянно) с тем, что проект не "прозрачен". Эта "непрозрачность" выражается в том, что на "толстых" проектах (количеством чертежей от 100 и более) тяжело отследить неправильные связи, лишние элементы, всякие ошибки с клеммами и прочие ошибки/опечатки. Да, конечно в АЭ есть немало штатных инструментов для контроля чертежей. Но поработав с ними остается ощущение что попал в прошлый век, во времена DOS 3.11. Подходы и производительность этого инструментария - иногда просто вызывает слезы. Хочется рвать и метать.

Отдельно хочется отметить встроенный в AutoCAD Electrical редактор клеммных колодок и "удобную" работу с клеммами, отсутствие нормального визуального редактора клеммных колодок. Было дело собирался посмотреть клеммник одного шкафа РЗА в проекте большой ПС (созданного в AutoCAD Electrical 2012) - он честно запустился на исполнение... и задумался... надолго... Я успел кофейку накатить, потрещать с сотоварищами и побродить по коридору. На сборку клеммников и отображение на ноуте DELL (проц i5 с 8 гег памяти и терабайтным винтом) у него ушло около 15 минут... сказать что я был в шоке - ничего не сказать. (UPD. С тех пор прошло много времени и компы стали мощнее, да и надо отдать должное - разработчики AutoCAD Electrical допилили острые углы в новых версиях. И теперь эта функция работает гораздо шустрее)

Помучившись так какое-то время, я в 2011м психанул и склепал эту «электронную лупу», при помощи которой можно оперативно просмотреть содержимое проекта – связи, кабели, клеммники, шкафы и прочее. Идея была проста как веник – считать базу данных проекта, отсортировать и разложить по полочкам/табличкам эту кашу, вывести в удобоваримом виде, в виде деревьев и таблиц. Как оказалось впоследствии это достаточно эффективный инструмент. Со временем, по мере появления новых идей, функционал программы наращивался и появилось много "побочных", но лично для меня весьма полезных, функций. (UPD. Сейчас программа похожа на ёжика - инструментов в нее напхано огромное количество)

Далее на базе этого всего считанного и причесанного программа позволяет проконтролировать состояние кабельных связей (чтобы все жилы шли в одном направлении, перегрузка типа кабеля по количеству жил, итд ), клемников (визуально рассмотреть что получилось, подвигать клеммы, перенумероваь, переместить между клемниками одного шкафа итд), автоматически построить всякие выходные документы по ГОСТ, которые не в состоянии без дополнительных танцев с бубном сгенерировать АЭ: схемы внешних кабельных связей и подключений, рассчитать длины кабелей, нарисовать кабельный журнал и заготовку для спецификации, схемы внешних кабельных проводок, клеммники, схемы внешних подключений и т.д. Так же для удобства есть возможность заменить в выходных документах проектные условные обозначения шкафов на полные названия, например: «QS1-Т1» на «Разъединитель 110 кВ QS1-Т1» и т.д.

Мулька содержит кучку различных дополнительных утилиток. Особенно мне нравится автопечать проекта - она может автоматически распечатать в PDF весь проект с автоматическим подбором размера листа. Так же может нарисовать и откорректировать существующие форматные рамки по ГОСТ/ДСТУ, распечатать несколько форматных рамок с листа на котором нет блоков форматных рамок, растиражировать рамки с одного чертежа в отдельные файлы (для подключения к проекту АЭ), перенумеровать штампы и листы, "причесать" (привести в гостовский вид) автоматически сгенерированны АЭ перечень элементов (ВОМ), расставить выделенные блоки на чертеже в форматные листы и.т.д. При распечатке корректно обрабатываются листы с дополнительным форматом (типа А4х3 и т.д.). Правда, при условии специальной настройки АЕ (не сложно и автоматизированно). В виде бонуса есть инструмент создания "почищенной" копии проекта для передачи ЗаказчеГу.

Софтинка изначально была написана под AutoCad 2012. По мере выхода новых версий AutoCAD Electrical пробовалась с АЕ 2014, 2016, 2017, 2018, 2019, 2020, 2021, 2022 и вроде работает достаточно стабильно. Однако чудес не бывает и время от времени пользователи находят различные недоработки и баги. Естественно все найденные баги и глюки я оперативно рихтую. И заодно реализую многие хотелки пользователей.

Все пожелания принимаются на мейл: des501@ukr.net

Небольшое лирическое отступление.

Работая с AutoCAD Electrical нужно чётко представлять что он таки может, а что чистый маркетинг. AutoCAD Electrical это просто набор макросов засунутый в обычный Автокад. То есть, алгоритмы заложенные в этот набор макросов исполняет движок Автокада для выполнения всех операций и функций AutoCAD Electrical.

В виду того что АЭ это фактически "нашлёпка" над Автокадом, набор макросов которые крутит его внутренний движок, то работает вся эта экибана не совсем быстро. Вернее совсем не быстро. Вернее окуенно медленно. В дополнение ко всему проект организован в виде кучки фалов, каждый из которых представляет один чертеж. Это добавляет тормозов к выполнению операций со всем проектом. (Распечатка в PDF проекта в 400 листов программой в автоматическом режиме заняла около 40 минут на стационарном компе с i3, 8 гегами памяти и SSD, и несколько часов по из каталога по сети.)

Но даже такая автоматизация работы позволяет сильно сократить время разработки проекта. (Распечатка вручную в PDF похожего проекта на около 1000 листов у ребят на другой фирме потребовала порядка 3 дней). Не считая таких нюансов как безошибочный учет клемм и кабелей, связей между шкафами и т.д. Так что стоит им пользоваться - однозначно. Плохой всё лифт лучше шикарной лестницы. :)

Логика работы АЭ обратная нормальной CAD системе. Если сравнить с епланом или екубом (полноценными кад системами) в глаза бросается основное отличие (ИМХО): логика построения системы не соответствует правильной структуре.

В моем понимании ПРОЕКТ - это база данных (не суть важно в каком формате), в которой должно храниться всё: перечень элементов схем с их параметрами, связи между элементами, их изображения (УГО), организацией выходных документов, схем и прочего. Между базой данных и разработчиком находится движок CAD системы, который и выполняет все функции CAD системы, принимает команды от пользователя и ведет менеджмент базы данных. Такая структура позволяет делать "живой" работу с проектом - поменял что либо в БД проекта и сразу изменения отобразились во ВСЕХ выходных документах. Изменения вносятся не в выходные документы, а вносятся в базу данных и на базе этих изменений меняются и представления - схемы, клеммники, перечни элементов и т.д... АЭ это не доступно в принципе: мы с начала рихтуем чертежи - выходные документы, потом набор макросов собирает изменения и вносит в базу данных (этакую записную книжку) и далее позволяет осуществлять ограниченный набор действий с проектом.

При открытии проекта АЭ создает временную базу данных (записную книжку) в которую вносит все что считывает из чертежей входящих в проект. Удаление этой БД не приводит ни к каким катастрофическим результатам. Мало того это полезно при обнаружении различных удивительных глюков, которые не лечатся ничем - обновление БД не устраняет эти глюки. Просто в случае отсутствия БД он ее создаст заново. Отсутствие ошибок в БД это основа нормальной работы в АЭ.

Поэтому работая с AutoCAD Electrical надо учитывать эту специфику.

Последовательность действий такая:

1) изменение чертежей

2) обновление базы данных АЭ

3) считывание базы данных этой программой

4) анализ считанного, рихтовка, внесение изменений в чертежи и снова к пункту 2.

И так по кругу до полного искоренения ошибок.

Более подробно описано тут .

Любое изменение в чертежах приводит к изменению базы данных. Поэтому для просмотра актуальных и корректных значений необходимо перед считыванием базы данных обновлять ее.

Кнопка выглядит так:

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Что нового

СЛАВА УКРАЇНІ !!! ГЕРОЯМ СЛАВА!!!

Нового много, обновления сыпятся как из рога изобилия, следите за новыми релизами.

Этот хэлп можно скачать в форматах: ".chm" , ".docx" , "epub" и ".pdf" .

---- Version 28.49, Release 9493, Build 29112 (х32) ----------------

---- Version 28.49, Release 9493, Build 29146 (х64) ----------------

  • На закладке "Утилиты всякие" немного поправил расположение кнопок.

  • Добавил закладку "Утилиты всякие/Всякое-2", не влазят новые кнопки.

  • Добавил возможность скруглять углы у полилинии и пар отрезков. Выбираете полилинию или два (ровно два) отрезка и тыцкаем в кнопку "Скруглить углы". В результате у полилинии будет добавлен сегмент круга на месте угла а для отрезков будет добавлен сегмент соединяющий концы отрезков. Сегмент будет иметь заданный радиус. Но есть нюанс для отрезков: если расчетная точка центра круга лежит дальше концов отрезков, то она будет как бы весеть в воздухе - удлинять придется самому. Функция достаточно сложная потому в каких-то крайних случаях может не срабатывать, еще допиливается.

  • При создании схем подключения кабелей (закладка "Кабели/Утилиты кабелей") добавил создание блока "Карандаш" для сортировки чертежей при разбивке на листы. Функцию можно отключить переключателем в настройках функции.

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

Архив описаний предыдущих обновлений находится тут

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Архивы обновлений

---- Version 28.48, Release 9456, Build 33766 (х32) ----------------

---- Version 28.48, Release 9456, Build 33791 (х64) ----------------

  • Важно. Поправил функцию сборки чертежей на один лист. При определенных условиях листы "накапливались" на одном листе. В общем хрень полная получалась. Сейчас всё ок, опробовал на своем огромном проекте - шарашит как наше ПВО по ёбаным шахедам из фашистского заболотья.

  • Добавил кнопку перевод текста на закладке "Утилиты всякие". Столкнулся с тем что при переделке старых совковых проектов необходимо много переводить много текста описаний с рос суржика на українську мову. Реально задалбывает и тратится много времени. Сделал перевод содержимого ТЕХТ и МТЕХТ при помощи Гугля. Теперь можно легко переводить просто тыкая в экран, ну и конечно после подправляя "пекельні борошна".
    Алгоритм простой как веник - считанное текстовое поле оформляется в запрос на перевод и отправляется по НТТР прямиком в Гугль, что вернулось заменяет содержимое тектосвого поля. И понятно что без интернета эта функция работать не будет.
    Есть несколько вариантов обработки чертежа: по очереди тыкать в нужное текстовое поле или обработать весь чертеж.

  • Добавил возможность прерывания длииииных операций с файлами. Например распечатка, сборка/разборка на отдельные файлы итд. Появляется волшебная кнопка "Прервать операцию" и при нажатии заканчивается текущая операция. Некоторые операции с чертежами невозможно прервать так как Автокад вызывается в блокирующем режиме. Потому заканчивается текущая обработка чертежа и как только появляется возможность программа прерывает работу.

  • Добавил возможность отключения меню выбора ранее открытых проектов - если в настройках выставить равным нулю количество старых проектов отображаемых в списке меню, то меню вообще не будет отображаться. (всплывающее меню - правой кнопкой мыши на кнопке "Открыть проект").

  • Добавил спорную кнопку "Разделить МТекст" на закладке "Утилиты всякие - Всякое". Она нужна лично мне, но может быть полезна. После импорта чертежа из ПДФ на текущий лист часто появляются артефакты такого плана - рядом стоящие символы и цифры объединяются в одно текстовое поле. Но содержимое разделено пробелом. Разделять их то еще наказание. Потому теперь это делает машина. Она считывает содержимое текстового поля, разделяет по пробелу на кусочки и вместо одного текстового поля создает несколько (по количеству отдельных элементов) ТЕХТ и располагает их последовательно. Обрабатывает любое текстовое поле - МТЕХТ или ТЕХТ.

  • Подрихтовал формирование редактируемого формата проекта "Подготовка для Заказчега". Бывает что на чертеже остается техническая информация. Теперь делается копия оригинального файла, из него выкусывается только рамка с содержимым внутри неё, и далее обрабатывается.

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.47, Release 9436, Build 26021 (х32) ----------------

---- Version 28.47, Release 9436, Build 25984 (х64) ----------------

  • Поправил сборку чертежей на один лист. Часто при сборке старых чертежей попадаются "артефакты" типа линий с нулевой длиной, пустые блоки и Техт/МТехт с пустым содержимым. Они сбивали копирование. Теперь такие артефакты просто отсеиваются/игнорируются.

  • Добавил сборку чертежей проекта на один лист. Закладка "Файлы проекта - Сборка/разборка".
    Основная идея в том, что проект (или часть его - выбранные в списке чертежи) собирается на один лист с расстановкой "карандашей" (блоков указывающих где расположены файлы чертежей и их обозначения в дереве проекта). То есть, теперь весь проект можно "свернуть" на один лист, и потом так же без потерь развернуть как он был в исходном состоянии.
    Польза в том что допустим есть старый проект, который надо немного поправить. За давностью нюансы уже могут быть забыты. Скакать по отдельным листам утомительно. А теперь можно увидеть все чертежи на одном листе одновременно, откорректировать при необходимости, а потом снова развернуть в полноценный проект. Подробное описание тут .

  • Немного почистил код и навел красоту.
    - На закладке "Перечень элементов"-"Перечень чертежей для выбранного шкафа" добавил кнопки поиска чертежа с выбранной в дереве деталью и детали на чертеже.
    - Добавил красивые иконки по разным кнопкам. Получилось нарядно.

  • Поправил функцию формирования таблицы перечня элементов из таблицы ВОМ. На закладке "Утилиты" кнопка "Причесать" перечень элементов (ВОМ)". Ранее не распознавалась первая строка, название таблицы.

  • Исправил опечатку при выравнивании текста в прямоугольник. Теперь корректно выравнивает в повернутый МТЕХТ.

  • Добавил рисование стрелок на чертеже. Полезная для меня утилита, облегчает работу при создании всяких функционалок и т.д. Подробно описано тут: "Рисование стрелок".

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.46, Release 9408, Build 26798 (х32) ----------------

---- Version 28.46, Release 9408, Build 26773 (х64) ----------------

  • Доработал создание подключенных кабелей из таблицы Экселя в текущий проект АЭ.
    Если в таблице задавать фиксированную длину кабеля, то получалась накладка. Длины новых (добавленных из экселя) кабелей сохранялись в проекте, в специальный файл проекта Но сами кабели на этот момент еще не были в проекте и в программе. Поэтому при пересчитывании проекта или закрытии программы, этот файл проекта обновлялся текущими данными, то есть без учета этих новых кабелей. То есть записанные ранее значения длин и признаки фиксированной длины пропадали. Сейчас создании схемы в программе создаются соответствующие временные "виртуальные" кабели и она считает что они есть в проекте и корректно сохраняет их длину и фиксацию. Понятно что этот механизм работает только при считанном программой проекте.

  • Доработал выравнивание блоков штампов в форматных рамках. Ранее просматривался весь чертеж и это занимало время. Сейчас просматривается только список рамок и штампов, а потому они выравниваются на порядок быстрее.

  • Доработал копирование файлов при сборке нескольких чертежей на один чертеж. были нюансы при наличии на чертеже "артефактов" с нулевыми размерами. Проверил что получилось на одном большом проекте - собрал из старого проекта почти 400 файлов в режиме "копировать всё". Рамки там были, но просто нарисованные, не в виде блока. Пришлось копировать всё ибо перебирать 400 файлов подбирая рамки та еще работка. Пыхтело на ноуте долго, более получаса.

  • Добавил замену текста в текущем чертеже. Инструмент исключительно для меня, думаю в большинстве случаев никому оно не надо. Но вдруг кому-то пригодится. Подробное описание тут .
    Идея была такая: попался очень старый проект (довоенных времен) который я переделываю. Ессно он выполнен на кацапском суржике. И надо было всю эту туеву кучу текста перевести на солов'їну мову. Вручную перепахать более 200 листов та еще работёнка, куча времени и скорее всего что-то пропустишь. Да, в АЭ есть встроенный инструмент. Но что-то не сложилось с ним у меня, наверное руки кривые, не очень работает. Я хз, времени нет разбираться, проще было свое накропать.
    Алгоритм такой - создаю свой словарик и прогоняю его по всем чертежам. Набиваю в экселе, а потом перетаскиваю в программу. Есть нюанс - в начале самые длинные выражения из многих слов, и далее по уменьшению - от длинных фраз к коротким одиночным словам. Иначе из-за склонений может не найти или наковырять фигни.
    Производительность поиска поменьше чем встроенным в Автокад поиском, но работает. На чертже перепахало 181527 элементов за 25 минут.

    !!!Осторожно с переключателем "в блоках" - молча, без предупреждения, пересматриваем все блоки в чертеже и меняет содержимое в статических ТЕХТ и МТЕХТ и значениях Атрибутов. Так что могут быть сюрпризы. По умолчанию этот переключатель отключен.

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.45, Release 9387, Build 31938 (х32) ----------------

---- Version 28.45, Release 9387, Build 31943 (х64) ----------------

  • Добавил выравнивание выбранных элементов по краям/центрам. Идея проста - выбираете какие-то элементы, линии, блоки итд, нажимаете соответствующую кнопку и вуаля - блоки выстраиваются вдоль края, выравниваются. Стандартная функция которая может и есть где-то в недрах автокада, но наверное настолько глубоко спрятана что я не нашел.

  • Добавил то что давно хотел - переход с предварительного просмотра кабеля/шкафа к детали на чертеже. То есть, дважды кликаете на изображении клеммы, точки подключения кабеля и автоматом открывается нужный чертеж и позиционируется на выбранном элементе. Удобненько, реально экономит время.

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.44, Release 9342, Build 34495 (х32) ----------------

---- Version 28.44, Release 9342, Build 34515 (х64) ----------------

  • Добавил кнопку "Перенос маркировки клеммы" . Как неожиданно оказалась вельми полезная утила. Идея в следующем: клемма на чертеже обозначается блоком со специальным именем в котором есть два атрибута определяющих номер клеммы и наименование клеммника (клеммного ряда). Для красоты я добавил еще один атрибут в котором хранится двоеточие которое разделяет наим клеммника и номер, получается так: "ХТ:12". Когда рисуешь схему иногда нужно подвинуть обозначение клеммы. И приходится по старинке удерживая контрол выбирать эти атрибуты, что иногда муторно и в насыщенной схеме достаточно сложно (особенно если зрение уже ахти). Теперь все происходит проще: тыцкаем в кнопку, на запрос выбираем кучку клемм, на запрос показываем куда перенести обозначение и машина сама сделает все остальное. Подробнее описано тут .

  • Добавил в центрирование текста в рамку (закладка "Утилиты всякие") возможность выбирать несколько текстовых объектов. При выборе объектов нет возможности выбирать точку вставки внутри рамки. Вернее замахаешься пыль глотать указывая для каждого текста куда его переносить. Поэтому сделано проще - вы выбираете кучу тестовых элементов (ТЕХТ или МТЕХТ) и программа вычисляет для каждого текстового элемента точку вставки. Для этого определяются крайние точки занимаемого текстом прямоугольника и вычисляется его середина. Это и будет точка вставки в рамку. То есть, от этой точки будут искаться вправо-влево и вверх-вниз всякие линии/полилинии и по ним определяться куда и как вписывать текст, то есть вычисляться окружающий прямоугольник. То есть есть определенные ограничения - текстовые элементы должны быть серединой уже внутри рамки. Это отлично подходит если надо просто поправить, слегка подравнять "сползшие" тексты в таблицах. Например описание фрагментов схемы в виде таблицы. Выделил все и оно само отрихтовало текстовые элементы красиво в серединку.

  • Поправил алгоритм сборки чертежей на один лист. Допустим нужно собрать кучу чертежей на один лист. И в списке чертежей для сборки есть и текущий открытый чертеж. То есть нужно скопировать самого себя в эту группу. Получается коллизия.
    А посему теперь это работает так: Проверяется список чертежей для сборки. Если текущий открытый чертеж (на который и производится сборка) есть в этом списке, то он закрывается с сохранением. Далее создается временный пустой лист и на него в указанную точку собираются все чертежи из списка. Далее открывается тот чертеж, на который надо было собрать все чертежи, и на него переносится все из временного чертежа. Временный файл удаляется.

  • Немного всяких мелких улучшений в коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.43, Release 9317, Build 23073 (х32) ----------------

---- Version 28.43, Release 9317, Build 23109 (х64) ----------------

  • На панель "утилиты всякие" добавил кнопку, архиважную и мегаполезную лично для меня - подравнять блоки штампов (основной надписи) в блок форматной рамки. Многие пользуются совмещенным блоком форматной рамки, в котором нарисован штамп и вставлены атрибуты штампа. им тэта кнопка не нужна. Я же пользуюсь двумя отдельными блоками - форматной рамки и штампа. Мне так удобнее. Но бывает что не замечаю и они сползают. Эта кнопочка поправляет и перетаскивает блок штампа в положенное место. Но есть условие - у блока штампа точка вставки должна быть в левом верхнем углу. И действует эта кнопка на текущий открытый чертеж.
    Так же добавил такую же кнопку на закладку "Файлы проекта - Полезности". Но эта кнопка действует на выбранные в списке проекта файлы. То есть, можно перед печатью запустить по всему проекту чтобы она просмотрела и поправила все штампы.

  • Переделал закладку "Утилиты всякие". Пообщавшись с пользователями я сделал вывод что логи штука полезная исключительно для меня, никто больше на тот список событий практически и не смотрит. Плюс места для новых кнопок на панельке не хватает. Удалять логи не стал, а сделал для логов и кнопочек отдельные панельки. Удобненько.

  • Добавил кнопку "Вписать ТЕХТ или МТЕХТ в рамку". Идея проста - есть какой-то текстовый элемент который нужно всунуть четко в рамку. У меня на схемах это как правило описание цепи, название шкафа/блока итд. И при правке обычно надписи сползают. Потом отровнять их не проблема, но нудно и утомительно. А посему - тыцкаем в кнопку, выбираем на текущем чертеже текст и тыцкаем там, где должен быть этот элемент - внутри прямоугольника. Программа от этой точки смотрит вверх, вниз, влево, вправо и ищет линии, полилинии. Далее из этой кучи вычисляются наиболее близкие линии и по ним определяются стороны прямоугольника в который вписывается текст. А посему следите куда указываете точку будущего размещения текста.

  • Подрихтовал функцию разбивки чертежа по форматным рамкам. Обнаружил что если выбрать несколько чертежей в списке чертежей проекта и указать раскладку по разным папкам, то получившиеся новые файлы, увы, все скидываются в папку первого файла. Пофиксил, сейчас раскладывает по папкам корректно.

  • Переработал функцию перевода списка кабелей из экселя в проект. Добавил колонку "Длина". Идея в том, что часто приносят список кабелей которые не нужно просчитывать, они уже проложены, длина известна и нужно просто оформить исполнительный КЖ. Теперь указав в таблице длины кабелей они будут добавлены к кабелям как фиксированная длина.

  • На закладке "Форматные рамки" добавил (думаю полезную) кнопку. Идея в том что часто приходится подбирать форматную рамку, которая охватывала бы нарисованную группу элементов. То есть выбрал элементы, прожка посчитала границы и по ним подобрала и нарисовала форматную рамку. Экономит время. Если поставить галочку в переключателе "по точкам", то нужно будет саомму выбрать две точки по диагонали, по которым прожка подберет форматку.

  • Немного всяких мелких улучшений коде и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.42, Release 9290, Build 24252 (х32) ----------------

---- Version 28.42, Release 9290, Build 24294 (х64) ----------------

  • Где-то в 12м году искал документацию на оборудование. Гуглевский поисковик среди прочего показал ссылку на фтп сервер СибМЭС. Там было куча всего, в том числе и проекты на разные ПС. Я не долго думая поставил на выкачку. Отбирал только то, что мне было интересно, но даже с этим получается около 60-70 гег всякого. Ну и сейчас расшарил эту папку с проектами Сибирских МЭС (это ссылка) . Может кому-то будет полезно как примеры (или куда дроны запускать бггг).
    ЗЫ, Сервер мой домашний очень слабенький, на OrangePi Lite. Так что скорее всего тормозить при скачивании будет нещадно, как на модеме 2400. Но то такое, зато есть.

  • Добавил рисование вертикальных форматных листов и вывод их на печать. Такое себе, спорное, решение. Часто на ПС аборигены не сильно заморачиваются с ГОСТами и прочими чертежными нормами и просто рисуют как им удобно. Получается например А4х4 вертикально. А чем мы хуже? Сделал переключатель "Вертикально" на страничке создания форматных рамок "Форматки". Может будет полезно. Но следите за результатами распечатки дополнительных форматов.

  • На закладке "Утилиты всякие" добавил кнопку "Удалить дубликаты линий". Смысл простой - отбирает на текущем чертеже все линии и среди них ищет те, которые дублируются - лежат одна на одной и имеют идентичные размеры. Дело в том что при экспорте чертежей из pdf в Автокад часто появляется странный дубляж - одна линия состоит из кучи отрезков. Как правило такое появляется при экспорте чертежей которые были сделаны в "Компасе" и распечатаны в пдф. В общем штука полезная и сильно мне помогла.

  • Добавил на закладке "Исходные" для удобства кнопочку "Распечатать выбранный файл". Иногда бывает необходимо выдать в pdf только один чертеж. Удобно делать это не переходя на закладку "Файлы проекта"-"Вывод на печать", а просто выбрать в дереве и щелкнуть по кнопке. Настройки печати будут по умолчанию: все в один файл, перезапись существующего, монохром.

  • Немного причесал предварительный просмотр кабеля - не отображались оборванные (не подключенные) жилы кабеля. Так же не копировалось на картинку (в буфер) изображение названия кабеля, тип и длина. Мелочь но надо было поправить.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.41, Release 9238, Build 26265 (х32) ----------------

---- Version 28.41, Release 9238, Build 26292 (х64) ----------------

  • Добавил возможность, при разделении файла по форматным рамкам, обозначать отдельные группы рамок при помощи специального блока. В самом блоке указываются базовое имя для группы файлов, наименование каталога в дереве проекта, описание чертежа в дереве проекта (OPIS2). Более подробно по ссылке Так же снял видео где попытался как мог показать процесс деления https://youtu.be/applEhYvcQc

  • Добавил контроль количества блоков форматных рамок и блоков штампа в чертежах. На одном чертеже должно быть одна форматная рамка и один штамп. Если количество отличается - возле файла появляется красная иконка.

Возле кнопки выводится текущее количество форматных рамок и штампов.

  • На закладке "Связи между шкафами", на предварительном просмотре можно выводить схему предварительного просмотра в автокад. Но если схема подключения большая, то она не помещается в один столбец. Сделал "упаковку" в форматные листы А3.

Но тут процесс еще не закончен - бывает что между основным шкафом и вторым шкафом, к которому рисуются кабели, подключено так много кабелей что они не помещаются в А3 боком. Потому еще доделываю разбивку и упаковку этого большого блока.

  • Доработал перенумерацию обозначений кабелей. Например, если выбрать кучку кабелей начиная с "АТ2-165" и до "АТ2-204", как на картинке ниже:

и задать начальное значение "АТ2-165" [image] , то в зависимости от состояния переключателя "Пропускать существующие" перенумерация будет идти по разному:

- Если установлен переключатель, то, если в списке выделенных для перенумерации уже есть кабель с таким обозначением (например видим что "АТ2-165" уже есть в списке), этот кабель будет пропущен, вернее его существующее обозначение останется как есть. Если такое обозначение уже есть в общем списке кабелей и отсутствует в списке выделенных для перенумерации, то порядковый номер в обозначении будет пропущен и вычислен следующий. И так будет продолжаться поиск незанятых обозначений. В нашем случае если нумерация начинается со 165, то выделенные кабели будут обозначены как АТ2-165, АТ2-166, ..., АТ2-172 - то есть кабели АТ2-201... АТ2-204 будут переобозначены как АТ2-167... АТ2-172.

Однако если начальное стартовое обозначение будет "АТ2-205" (обозначение уже есть в общем списке кабелей и не должно быть изменено), то обозначение кабеля "АТ2-165" будет изменено на "АТ2-244".

Если стартовое обозначение кабеля есть в списке на перенумерацию, например выбраны кабели "AT2-201, AT2-202, AT2-203, AT2-204, AT2-205" и стартовое обозначение "AT2-201", то наименования кабелей не изменятся совсем если их текущие обозначения идут последовательно.

Если например выбраны кабели "AT2-201, AT2-202, AT2-303, AT2-304, AT2-305" и стартовое обозначение "AT2-201", то наименования кабелей будут такими: "AT2-201, AT2-202, AT2-203, AT2-204, AT2-205", то есть последовательность номеров будет выровнена.

- Если не установлен переключатель, то если такое обозначение кабеля уже есть в общем списке кабелей, им будет дано такое же обозначение, однако с добавлением дополнительного нумератора "_copy_001". Счетчик нумератора будет возрастать если уже есть такое обозначение кабеля, например: AT2-220_copy_001, AT2-220_copy_002 итд.

То есть упрощая: если включен переключатель, то перебирается счетчик (Ni+1 = Ni + 1) и ищется первое попавшееся "свободное место", незанятое обозначение, и туда впихивается текущий кабель. Если переключатель не включен, то вычисляется новое обозначение и назначается если оно незанятое, или если оно занято, то оно назначается с добавлением нумератора обеспечивающее уникальность кабеля.

  • Немного поправил назначение монтажных единиц кабелям. Стало чуть удобнее при перетаскивании.

  • Изменил изменение подписи клемме (маркировочная табличка над клеммой). Сделал чтобы можно было назначать подпись сразу группе клемм. Столкнулся с тем, что при создании схемы не заметив копировал клеммы вместе с подписями ( строка в DESC3). Открыв в редакторе клеммный ряд офигел - туева куча табличек подписей, и клемм немеряно - поштучно чистить та еще нудная работка. Клеммы раскиданы на разных чертежах. В общем теперь можно выбрать группу клемм и дать им пустую подпись очистив их. Или на оборот - заполнить одинаковой подписью выбранные клеммы.

  • Исправил формирование имени блока. Поправил логику создания имени, двойная " не обрабатывалась и из-за этого "Паук" мог не рисоваться, пропускать шкаф с именем содержащим такой знак: " .

  • Доработал вывод "Паука", схемы внешних кабельных проводок:

- Сделал общий "Паук" от нескольких вторичных шкафов к основному. Удобно показывать связи от от фазных ИТТ к общему клеммному шкафу ШЗТС. Но рисуется только если выбраны "дочерние" шкафы в дереве - иначе непонятно какой шкаф общий, их может быть несколько.

- Сделал сигнализацию если выбраны несколько первичных шкафов - такое пока запрещено в виду неоднозначности - непонятно кто общий шкаф и что рисовать.

  • Добавил фенечку - если в предпросмотре клеммного ряда щелкнуть по перемычке, то будет выделена сначала верхняя клемма, а при повторном щелчке будет выделена и показана, если вне окна, другая клемма перемычки. Удобненько.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.40, Release 9196, Build 33415 (х32) ----------------

---- Version 28.40, Release 9196, Build 33409 (х64) ----------------

  • Исправил ошибку при "причесывании" перечня элементов ВОМ - на закладке "Утилиты всякие". Там иногда неправильно сворачивались перечни элементов, если они стоят последовательно. Не менялось количество или тип, но описание "KL1-KL23" иногда выглядело как "KL1, KL23". Теперь ок.

  • Добавил полезность - при распечатке проекта путь к выбранному каталогу сохраняется в настройках проекта и выбирается при следующей печати. То есть, у каждого проекта свой путь к папке с выходными документами. Я обычно дела папку "PDF" и туда вывожу разделы проекта.

  • Добавил еще полезность - упаковку в "красивый квадратик" можно выполнять не только клемм из проекта, но и для любых блоков клемм, или вообще с любыми блоками.

более подробно описано в хелпе, тут

  • Добавил в предпросмотре клеммников фильтрацию перемычек по маркам цепей. Это позволяет игнорировать перемычки и делать менее захламленный клеммник на стадии разработки схем.

В общем работал с клеммником на 400+ клемм и часть их них была с заземлением. В схемах естественно назначил их соединение с "заземлителем" (УГО "земля") и дал марку провода GND. А таких клемм было огромное количество и в разнобой. В результате клеммник выглядел так:

До фильтрации: | После фильтрации:

Как видно ушли перемычки GND. Так можно отфильтровать любое количество марок цепей.

Более подробно описал тут

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.39, Release 9177, Build 27679 (х32) ----------------

---- Version 28.39, Release 9177, Build 27641 (х64) ----------------

  • Обнаружил странную недоработку в АЭ. Спешу поделиться: https://project12-utilites.blogspot.com/2025/02/blog-post.html

  • Исправил ошибку возникавшую при попытке просмотреть параметры блоков ссылок если блоки расположены на листе у которого еще нет номера.

  • Переделал сборку общих данных. Изменилась логика подбора форматки для варианта "А4х". Алгоритм более подробно описан в хелпе на закладе "Общие данные"

  • Добавил полезную мелочь (давно надо было сделать) - открытие из списка прошлых проектов. Список сохраняется в обычном текстовом файле в каталоге пользователя Виндоус.
    Чтобы открыть список щелкаем правой кнопкой мЫши по кнопке открытия проекта.
    Первый запуск будет пустой список о чем программа радостно сообщит.

  • Немного переработал интерфейс создания каб журнала из экселевской таблицы. Добавил сохранение профилей настроек, иногда полезно.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.38, Release 9066, Build 22372 (х32) ----------------

---- Version 28.38, Release 9066, Build 22348 (х64) ----------------

  • Не до конца отключалось сигнализация когда был выбран режим тишины. Пофиксил. Теперь бибикание можно полностью отключить кроме двух случаев - если есть ошибка и окончание выполнения какой-то операции (например печать и прорисовка паука итд).

  • Немного переделал интерфейс закладки "Связи между шкафами". На функционал никак не влияет, но, как по мне, стало немного интуитивнее. Все настройки рисования находятся сверху и общие для всех утилит на этой закладке.

  • Добавил рисование на пред просмотрах шкафов и кабелей. Иногда удобно использовать предпросмотр как записную книжку и черкать по ней. Зажимаем клавишу и водим мышкой. Рисуется не по всей области, а только по самому рисунку. Мелочь, а удобно.

Чтобы очистить есть сверху кнопка "Обновить". Чтобы скопировать в буфер(clipboard) есть кнопка "В буфер".

  • Переработал парсер WDP файла. При сохранении изменений описаний файла в проекте иногда вылетали лишние переводы строк и WDP файл становился некорректным, файл "исчезал" - слетали все настройки описаний и т.д. Пофиксил.

  • Отремонтировал вызов онлайнового хэлпа. Если по каким-то причинам не найден рядом с программой файл с хэлпом CHM, то делается попытка его вытащить из инета. Если инет отсутствует или еще какой-нибудь негаразд, то открывается нужная страничка в браузере.

  • Сильно переработал рисование "Паука" (схемы внешних кабельных соединений). Сама суть пока что не поменялась, но теперь есть вписывание таблицы и паука в форматные рамки. По умолчанию вписывается в А3 или в А4 (выбирается переключателями рядом с кнопкой запуска рисования). При невозможности вписать в указанные форматы начинается перебор форматов с попыткой упаковать нарисованное. Всего форматов 28 штук, но попыток будет 27 - формат А4 горизонтальный не используется. Процесс создания подробно описан тут

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.37, Release 9021, Build 14111 (х32) ----------------

---- Version 28.37, Release 9021, Build 14131 (х64) ----------------

  • Доработал обновление ссылок в проекте (раздел "Файлы проекта", закладка "Полезности", кнопка "Обновление ссылок"). Теперь обрабатываются не все чертежи в проекте, а только выделенные и только те, в которых есть ссылки. Если ни один чертеж не выделен, то обрабатывается весь проект

  • Добавил сохранение настроек печати для каждого листа. Ранее во время печати файл открывался на чтение, теперь отрывается для записи. Выбирается галочкой. Штука полезная - если потом надо отпечатать какой-то один лист то он уже готов к печати.

  • Оживил перезапись при печати в pdf и сборке листов в один pdf файл. Когда выполняется печать и в целевой папке существует файл с таким же именем, то в зависимости от установленного переключателя "перезаписывать существующие" или создается новый файл с уникальным именем, или существующий перезатирается (вернее удаляется и создается новый с таким же именем). Так же и разбивка по форматам или перезатирает существующие файлы, или создается новая папка с именем аналогичным основному файлу pdf.

  • Переработал печать и сборку в один файл pdf.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.36, Release 9003, Build 27267 (х32) ----------------

---- Version 28.36, Release 9003, Build 27247 (х64) ----------------

  • При создании таблицы перечня чертежей добавил отступ (поля) в ячейки.

  • Доработал сортировку клемм "по старинке" (в окне "Редактировать клеммник"). Теперь клеммы могут сортироваться все (как было) или выбранная группа клемм. При этом выделенные клеммы сортируются, переносятся и располагаются после самой первой выделенной.

  • Добавил кнопку "Выровнять на нулевой слой" все линии и блоки на расчетном плане. В общем ежели очень много линий на трассах и планы в 2D, то есть шанс что блоки и линии окажутся на разных уровнях по координате Z. А значит не будет пересечения и не будет найден путь для прокладки кабеля. Нужно вернуть их на один уровень, на ноль по высоте. Перебирать вручную муторно - нехай это делает машина. Тыцкаем в кнопку и на текущем чертеже будут выбраны все линии на слоях трасс, на слое перемычек, блоки перемычек, блоки шкафов и все это шобло будет перенесено на уровень 0. Удобненько.

  • Добавил в дереве шкафов вывод зоны (Inst) в названии шкафа если имя шкафа совпадает с именем шкафа верхнего уровня. То есть, если в проекте есть шкафы с одинаковой зоной то в дереве будет выглядеть как соединение самого с собой, хотя это другой шкаф с таким же именем но с другой зоной.

  • Убрал навязчивые открытия окон в браузере при невозможности найти новую версию программы. Дело в том что при старте осуществляется проверка наличия новой версии программы, посылается запрос на три сервера обновления. И если по каким-то причинам с ними связаться не удалось, прошел какой-то сбой или сеть отсутствует, то предпринималась попытка дать возможность проверить вручную - открывались веб страницы серверов. Видать хотелось как лучше, но получилось как всегда. В общем пофиксил.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.35, Release 8966, Build 25273 (х32) ----------------

---- Version 28.35, Release 8966, Build 25421 (х64) ----------------

  • До полировал переименование файла в проекте, выскакивали лишние сообщения. На закладке "Исходные" -> "Чертежи проекта" -> кнопка "Изменить имя файла".

  • Добавил выделение кабеля в окне пред просмотра клеммника. Когда много кабелей трудно отследить куда и как они цепляются. Двойной клик - последовательное выделение и снятие выделения.

  • Немного причесал утилиту "Упорядочивание клемм в красивый квадратик". Более подробно тут .

  • Сделал маленькую но полезную утилиту - рисование заготовок ссылок между цепями. В принципе такой механизм есть. Но я заебался создавать каждый раз свою стрелку. Сначала сделал просто - на отдельном чертеже с заготовками нарисовал все возможные варианты. Вау, крюто. Но опять же не шикарно, немного рутины осталось. И подумал - а какого сама машина не хочет помочь мне? Вот и склепал. Описание тут.

  • Наткнулся на такую штуку - в дереве элементов у совсем обычного и правильного элемента/детали ни с того ни с сего стали появляться дополнительные базовые блоки. Хотя на чертеже все ок. Оказалось, что если создать сборку, то дополнительные детали, входящие в сборку, оформляются тоже как базовый блок, но с отдельным признаком. Я это дело пофиксил и теперь в дереве всегда корректное количество базовых и дочерних блоков у деталей. Что делать со сборкой пока не придумал.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.34, Release 8894, Build 26553 (х32) ----------------

---- Version 28.34, Release 8894, Build 26530 (х64) ----------------

  • Исправил ошибку, при изменении типа кабеля заполнялся атрибут DESC1 только в базовом блоке . Но если блоки обозначения кабеля находились на разных чертежах, то в дочерних блоках оставался старый тип. То есть, если на чертеже был показан кабель с отображением типа кабеля, то значение не менялось и появлялась ошибка, которую необходимо было исправлять вручную. Теперь обновляются атрибуты во всех блоках кабеля.

  • Переработал раздел подготовки для "Заказчега". Теперь есть два варианта - быстрый и медленный. Быстрый использует скрипты на Лисп, которые я нашел на различных форумах, и которые значительно ускоряют работу с примитивами чертежа. Медленный использует для каждого действия обращение к Автокаду через COM и потому работает очень медленно. Во всех случаях такой производительности вполне достаточно, однако при переработке множества чертежей и изменения множества элементов на чертеже производительность удручающе низкая. Однако есть свои плюсы. Выбор за вами.

  • Исправил ошибку - на закладке "Чертежи проекта" не работал фильтр по форматным рамкам и блокам штампа, не отфильтровывались.

  • Переработал прорисовку клеммников - поправил вывод ссылок на детали внутри шкафа. Алгоритм простой: сначала ищутся проводники к деталям внутрь шкафа, потом ищутся проводники к клемникам внутри шкафа, потом ищутся перемычки в своем клеммнике, потом ищутся "короткие" перемычки (между соседними клеммами) вверх, потом короткие вниз. Если ничего не нашли - выводим пробел.

  • Добавил кнопки вывода на пред просмотре клеммника куда идет клемма.Выглядит так:

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.33, Release 8871, Build 37881 (х32) ----------------

---- Version 28.33, Release 8871, Build 37905 (х64) ----------------

  • Исправил ошибку при открытии файла для редактирования, если он уже был открыт в Автокаде. Блокировались функции поиска элементов на чертеже и другие, связанные с открытие чертежа.

  • Подправил вывод кабельного журнала в Автокад - если осуществлялся вывод с разбивкой по монтажным единицам, и с колонкой под монтажную единицу, то самый последний кабель в списке последний кабель всегда относился к предыдущей монтажной единице. Так же сползали подписи монтажных единиц в середине таблицы. Пофиксил.

  • Поправил кнопочки хэлпа, не на те пункты хэлпа указывали.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.32, Release 8866, Build 33892 (х32) ----------------

---- Version 28.32, Release 8866, Build 33909 (х64) ----------------

  • Изменил формирование имен блоков клеммников - проскакивал запрещенный символ и создание блока блокировал Автокад. Теперь запрещенные символы и пробелы заменяются на знак подчеркивания. К сожалению блоки созданные предыдущими версиями не будут поддерживаться в этой программе, их придется пересоздать заново. Увы, но обратную поддержку старых имен не буду делать.

  • Немного перелохматил интерфейс. Большое количество кнопок разделов не помещались сверху. Растягивать окно программы задолбало. Тогда были перенесены кнопки разделов "по модному, как в десятке" - влево под иконку "гамбургер" [image] .
    То есть, если нажать на "гамбургер", то разворачивается панелька с пиктограммами разделов и видны длинные наименования разделов. При выборе раздела открывается соответствующая панель и меню сворачивается. Для выбора раздела не важно развернута менюшка или нет. Так же восстановил двойной щелчок по файлу - файл открывается в автокаде.

Вид свернутой панельки: и вид развернутой панельки:

Цвета пиктограмм на кнопках немного аляповатые и еще будут меняться в следующих обновлениях. Хотя на работу программы это никак не влияет

  • Доработал вывод в Excel кабельного журнала /перечня кабелей. Ранее выводились только все в проекте кабели. Теперь выводятся по выбору - или все, или те что в таблице предпросмотра на закладке "кабельный журнал".

  • Исправил ошибку при переходе в дереве шкафов - при выборе во всплывающем меню пункта "перейти к шкафу ...", переход не выполнялся, оставался как есть.

  • Добавил на панель свойств чертежа две кнопки для перемещения и переименования файла чертежа в проекте. Штатно такие штуки как бы поддерживаются, но работает это все грустно. Если чертеж, который вы хотите переместить/переименовать, открыт в Автокаде или существует уже - программа замучает вас запросами что делать. Открытые файлы предлагается закрыть принудительно с сохранением или подождать пока юзверь сам не закроет чертеж в Автокаде.

Внимание!

- После каждой такой операции производится принудительное обновление базы данных проекта и пере открытие проекта в программе. Иначе есть риск рассинхронизации между программой и проектом.

- Если файл открыт в автокаде, то он закрывается с сохранением и переоткрывается заново после модернизации.

  • Добавил возможность переименовывать/переносить файлы проекта не только по одному, а выбирать несколько и обрабатывать кучу. Работает аналогично вышеописанным кнопкам. Но воздействует как на один, так и на кучу выбранных в таблице файлов. При нажатии на кнопку открывается отдельное окно в котором расположена таблица с выбранными файлами (один или все сразу - пофик) и соответствующими кнопками для обработки.

Внешний вид окна утилиты:

  • Добавил запрос на выполнение смены типа кабеля/кабелей. Будет немного задалбывать, но техника безопасности на первом месте. Просто уже обпёкся и переделывал. :)

  • Добавил проверку и сообщение при попытке изменить тип кабеля при отсутствии базового блока. Будет сообщение и операция прервется.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.31, Release 8811, Build 29498 (х32) ----------------

---- Version 28.31, Release 8811, Build 29473 (х64) ----------------

  • Доработал прорисовку внешних подключений клеммников. Был отказ при сборке нескольких клеммников в один и не работала сортировка клемм.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.30, Release 8810, Build 37596 (х32) ----------------

---- Version 28.30, Release 8810, Build 37559 (х64) ----------------

  • Доработал сборку файлов на один лист. Были глюки при наличии на чертеже определенных элементов.

  • Доработал интерфейс "Перечень элементов"->"Перечень чертежей для выбранного шкафа".

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.29, Release 8804, Build 37001 (х32) ----------------

---- Version 28.29, Release 8804, Build 36977 (х64) ----------------

  • Добавил удобную возможность на лету менять название кабеля, его тип и фиксированную длину. На предпросмотре нужно просто щелкнуть мышкой (двойной клик) по надписям кабеля и будут открываться окна с запросом новых значений.

  • Добавил волшебную кнопку "Создать каталоги под проектик РЗА". Идея в том что каждый раз леньки создавать кучу каталогов и проектов. Автоматизировал все это. Подробное описание тут.

  • Добавил масштабирование блока при группировке обозначений кабелей в "квадратик" (закладка "Утилиты всякие").

Идея в следующем: При группировке блоков обозначений кабелей перетянутых с отмаштабированного расчетного плана, удобно сразу настраивать им масштаб. Просто ставите галочку и нужный масштаб. Мелочь, но сохранила мен очень много времени при создании планов прокладки кабельных трасс в проекте.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.28, Release 8771, Build 20547 (х32) ----------------

---- Version 28.28, Release 8771, Build 20505 (х64) ----------------

  • Исправил ошибку при выводе кабельного журнала после расчета. Выводилась только результирующая таблица.

  • Более подробно описал коэффициент пересчета в метры. Читать в этом хэлпе тут (очень рекомендую)

  • Подправил ввод коэффициент пересчета в метры

  • "Оживил" кнопку хэлпа над полем ввода коэффициента пересчета в метры

  • Уменьшил подписи участков на расчетном плане кабельных трасс

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.27, Release 8765, Build 15809 (х32) ----------------

---- Version 28.27, Release 8765, Build 15788 (х64) ----------------

  • Добавил сортировку в табличку предварительного просмотра потребности кабеля (закладка "Кабельный журнал"=>"Предварительный просмотр кабельного журнала"). Добавил всплывающее меню для оперативной фильтрации кабелей выбранного типа.

В принципе там все понятно из названия пунктов меню.

  • Добавил вывод только сводной таблицы кабельного журнала.

Недавно полировал кабельный журнал на 40 страниц и после очередных изменений каждый раз его распечатывал чтобы получить сводную таблицу для сметчиков. В общем задолбался ждать пока он целиком будет нарисован. Сделал кнопку ускоритель. Правда потом сметчики передумали и им больше понравилась табличка в экселе. Но удалять обратно не стал - нехай буде.

  • Добавил прорисовку только куска клеммника.

То есть - выделяешь произвольные клеммы на предпросмотре клеммника и тыкаешь в кнопочку. Иногда полезно получить кусок клеммника.

  • Добавил выбор клемм в редакторе клеммных колодок по марке клеммы.

Смысл в том, что иногда нужно собрать группу клемм разбросанных по клеммному ряду в одну кучку. Тогда делаем так: на принципиальных схемах даем клеммам любую необычную маркировку, например "БББ001, БББ002" и т.д. Обновляем проект, открываем редактор клемника и набираем "БББ" в поле фильтра (на рисунке слева от выделенной кнопки). Автоматически будет сброшен текущий выбор клемм (если был) и по ходу набора маски, будут выделяться клеммы, у которых в имени есть "БББ", то есть "БББ001, БББ002" и т.д.
Далее хватаем любую выделенную клемму и тащим мышкой куды нить в другое нужное место. При перетаскивании они соберутся в кучку. Далее их "причесываем" - корректируем расположение, подписи, номера и т.д.

  • Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.26, Release 8760, Build 21358 (х32) ----------------

---- Version 28.26, Release 8760, Build 21340 (х64) ----------------

- Исправил ошибку при прорисовке клеммников. Была отключена сортировка клемм по их месторасположению. В общем при выводе в Автокад был полный бардак с расположением и перемычками.

- Поправил сортировку перечня элементов (например KL1, KL2...) при "причёсывании" ВОМ (в утилитах).

Алгоритм сворачивания наименований деталей типа "KL1, KL2..., KL99" в "KL1 - KL99" имел "шероховатость". Он не распознавал обозначения типа "KL1" и "KL01" - для него это было KL с номером 1 и потому результирующая строка разбивалась на два кусочка "KL1 - KL09, KL10 - KL99". Пофиксил. Теперь сворачивается как положено.

- Добавил выбор масштабирования при расчете кабельного журнала.

Идея в том что теперь можно брать чертеж с любым масштабом и указывать его перед началом расчета.

Аксиома: внутри программы все размеры приводятся к метрам.

То есть, по любому перед началом расчета нужно указать программе коэффициент пересчета в метры или масштаб - сколько единиц чертежа находится в одном метре. Обычно рисуют в миллиметрах, и потому подразумевалось что одна единица чертежа равна одному миллиметру.

Ранее масштаб по умолчанию всегда был 1:1000. И потому приходилось рисовать планы приводя 1 ед. к 1мм. Теперь при создании проекта по умолчанию со старта стоит 1:1000, но есть возможность указать свой собственный масштаб. Масштаб применяется ко всему плану.

- Поправил округление измеренных длин трасс кабелей при расчете кабельного журнала. Теперь не округляются длины линий (отрезков на плане), а округляются сектора.

Дело в том, что отрезков на реальном плане как правило очень много и округление длины каждого отрезка приводит к появлению небольшой добавки к длине каждого отрезка. Округление всегда идет в большую сторону, то есть от 0 до 0,1м. Сектор состоит из одного или нескольких однотипных отрезков. В результате он становится длиннее на сумму "добавок" своих отрезков. Добавка будет от 0 метров до 1...2 метров. Как бы для моих целей супер точность, но может кому-то нужно абсолютно точно. Тогда округление можно вообще выключить задав ноль.

Например, на картинке ниже видно, что длина сектора с округлением отрезков больше, чем с округлением длины самого сектора (суммарной длины отрезков). Для трассы кабеля минимальный участок - сектор. Таким образом не имеет смысла округлять отрезки, лучше округлять сектора.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.25, Release 8713, Build 37237 (х32) ----------------

---- Version 28.25, Release 8713, Build 37260 (х64) ----------------

- Изменил алгоритм расчет длины кабеля.

Проблема была в том, что при выводе в кабельный журнал длины кабелей округляются до метра (или до 0,1 метра). И при этом происходит округление длин участков прокладки кабелей и длин кабелей.

Округление всегда производится ВВЕРХ. То есть если рассчитанная длина, например, равна 100.123456789 метров, то после округления будет 101 метр или 100.1

Как бы ничего, но в результате длина кабеля может оказаться меньше чем сумма длин участков трассы прокладки кабеля. Появляется "нестыковка" которая будет или в плюс, или в минус по длине. Она может быть как микроскопическая, так и достигать единиц метров (зависит от количества участков). При этом программа выводила знаки вопроса в поле участков трассы кабеля.

Это происходило только при выводе на чертеж! "Внутри" программы все идеально совпадает - там нет никакого округления и длины хранятся с максимально возможной точностью.

Вот поэтому пришлось оперативно подкорректировать алгоритм расчета округления. Для того чтобы длины участков и кабеля совпадали добавкой "растягивается" и округляется как длина кабеля, так и длина участков - иначе не сойдется расчет.

Ссылка на формулу расчета длины кабеля .

Ранее было так:

[длина кабеля] = ( [рассчитанная длина] + [добавка в метрах] ) * ( 1 + [добавка в процентах] / 100 )

[длина кабеля] = Округление до метра или до 0,1м ( [длина кабеля] )

Это изменение приводит к тому, что рассчитанные ранее (предыдущими версиями программы) кабельные журналы по длинам не будут совпадать с нынешним расчетом на какие-то небольшие кусочки, единицы и доли метров. Не во всех кабелях, но во многих со сложной прокладкой. Длина кабеля теперь уменьшится.

По результатам экспериментов - пересчитал на старых проектах снижение суммарной длины по типам от нуля до 10 метров (для 30-50 кабелей). При установке "добавки" в ноль, и процент и "на разделку", расчет идеально совпадает со всеми старыми версиями. То есть все изменения касаются ТОЛЬКО "добавок" к длине кабеля.

Выходов два: пересчитать новой версией программы, или использовать предыдущую/раннюю версию программы.

- Добавил переключатель - вывод длины кабеля с округлением до 0,1 м. Оказалось очень полезный инструмент. Ранее длина кабеля округлялась до одного метра. Теперь можно выбирать в настройках. Это касается всего, где выводится на печать кабель/каб. журнал, и в предпросмотре кабельного журнала.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.23, Release 8700, Build 34386 (х32) ----------------

---- Version 28.23, Release 8700, Build 34409 (х64) ----------------

- Добавил открытие файла pdf после печати и в утилиты печати, и в печать проекта.

- Добавил в утилиты печати открытие папки с pdf после печати проекта.

- Добавил возможность расставлять в форматные рамки схемы внешних подключений клеммников при рисовании их не только в блоки, но и в пространстве модели.

- В редакторе клеммных колодок поправил изменение номера выбранной клеммы. Так же добавил на панель кнопку закрывать с сохранением или без сохранения файлы чертежей после корректировки клеммника.

- В редакторе клеммных колодок изменил выбор клеммника в который переносятся клеммы. Теперь это визуальное меню, не нужно барабанить пальцами. Мышкой выбирается клеммник. Более подробно описано тут .

- Исправил прорисовку клеммника в форматку А3 для задания заводу - он задумывался надолго при перерисовке части клеммника если тот не влазил в рамку.

- Добавил прорисовку любых выбранных в дереве клеммников. Теперь можно выделить группу любых шкафов и клеммников на закладке "Клеммники" и выдать на печать. Сначала будут нарисованы шкафы, потом кучей отдельные клеммники из других шкафов. Полезная фича.

- Изменил прорисовку нескольких клеммников в виде одного. Теперь если клеммник состоит из нескольких суб клеммников, то создаются "шапки" этих суб клеммников. На примере вижно что в приводе разъединителя есть замок YQS и блок-контакты QS

- Оживил кнопку позволяющую нарисовать в Автокаде (не обязательно в Электрикале) схемку подключения кабелей между шкафами. Находится на закладке: "Связи между шкафами" => "Графика". При нажатии на кнопку "Нарисовать в акаде схему" откроется панель настроек и там кнопка запускает процесс. Все просто и очевидно.

В результате на чертеже будет нарисована схема как и на экране:

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.22, Release 8663, Build 15937 (х32) ----------------

---- Version 28.22, Release 8663, Build 15958 (х64) ----------------

- Исправил мелкую опечатку - нулевая/пустая монтажная единица кабеля вызывала ошибку.

- Перевел из разряда ошибок в информационные сообщение о невозможности подобрать цвет в Автокаде. Если выбранный цвет для покраски клеммника не попадает в сетку стандартных цветов Автокада (номера 0-7-255), то цвет назначается как TrueColor. Сообщение в логах ошибочно показывалось как ошибка и забивало лог (всяких элементов в клеммнике дофига и больше).

- Исправил настройку слоя defpoint при делении файла по рамкам.

- Добавил открытие папки с pdf после печати проекта, удобненько.

- Натолкнулся на неприятную неточность, в очень определенных случаях в клеммник не выводилась марка. Идея в том что сработали одновременно два правила при прорисовке клеммника:

1. если две рядом стоящие клеммы имеют одинаковую марку, то марка выводится в первой

2. если от клеммы не отходит жила кабеля, то клемма считается "пустой" и марка не выводится

В данном случае кабель подключен ко второй клемме и программа стёрла марку во второй клемме (1е правило) и от первой не отходит жила кабеля (2е правило). В результате получил по голове от наладчиков и монтажников. Выводы сделаны - теперь есть третье правило:

3. если жила кабеля подключена, то марка выводится всегда, независимо от "соседей".

а должно быть так:

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.21, Release 8649, Build 35495 (х32) ----------------

---- Version 28.21, Release 8649, Build 35519 (х64) ----------------

- При расчете кабельного журнала слетала назначенная вручную длина. Пришлось переосмыслить логику длин кабелей.

Поясню. Длина кабеля может быть получена из двух источников: из результатов расчета кабельного журнала и/или назначена вручную. Если кабельный журнал не рассчитан и не назначена вручную длина, то будет отображаться нулевая длина кабеля. После расчета КЖ длины выбираются по результатам расчета. Если происходят изменения в схемах (исчезают/появляются новые кабели, шкафы, участки и т.д.), то кабельный журнал считается не легитимным, нужно пересчитывать.

Назначение длины вручную имеет приоритет. То есть, назначенная длина сохраняется вне зависимости от результатов расчета КЖ. Но и не "вытирает" рассчитанную длину. Есть возможность в любой момент вернутся к рассчитанному значению. Правда введенное вручную - пропадает.

- Добавил сбор и отображение ссылок в проекте. Описание тут . Хочу обратить внимание что идеология еще продумывается и пока что это просто гляделка за ссылками.

- Реализовал архи полезную функцию. В общем, когда ...надцать человек разрабатывают свои разделы и потом объединяют в один проект, оказывается что у всех разные стили текста! А если и один, то с разными настройками. В общем добавил кнопочку - перемолотить весь проект с текущими проектными настройками стиля текста. То есть выбрал весь проект, запустил программу и оно само открывает каждый файл, настраивает все текстовые примитивы на выбранный стиль текста. Вуаля. Более подробно здесь

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.20, Release 8624, Build 31414 (х32) ----------------

---- Version 28.20, Release 8624, Build 31389 (х64) ----------------

- Поправил разбивку файла на отдельные чертежи, ускорил процесс.

- Сделал видимым на кнопке переключение между режимами обмена номерами клемм, удобно.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.19, Release 8617, Build 12726 (х32) ----------------

---- Version 28.19, Release 8617, Build 12730 (х64) ----------------

- Поправил прорисовку "Паука". Таблица перечня кабелей "наползала" на схему.

- Добавил раскраску кабелей в схеме внешних подключений. Полезно для отслеживания отдельных проводов среди кучи проводников подходящих к клеммнику. Более подробно описано тут

- Добавил кнопочку перемещения от клеммника к шкафу клеммника в дереве шкафов на закладке "Связи между шкафами"

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.18, Release 8610, Build 17608 (х32) ----------------

---- Version 28.18, Release 8610, Build 17635 (х64) ----------------

- Поправил прорисовку "Паука" - шкафы вылазили за форматную рамку:

- Поправил прорисовку подключения кабелей к клеммнику - сделал сортировку что бы линии жил к клеме не накладывались (вылазил треугольничек входа жилы в кабель на другую жилу от другого кабеля).

Теперь они всегда рисуются ступенькой вот так:

- Поправил утилиту переноса списка кабелей в проект

- при обработке строки неправильно отмечалась ячейка

- не сохранялась одна настройка в реестре

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.17, Release 8603, Build 26011 (х32) ----------------

---- Version 28.17, Release 8603, Build 26016 (х64) ----------------

- Добавил инструмент для расчёта длин кабелей из экселя.

Идея проста как веник: допустим выдали экселевский файл со списком кабелей. Мы его "причёсываем", что бы формат поняла программа, потом натравливаем программу - она считывает построчно записи, пережовывает их, а потом в автокаде, на текущем листе проекта, создает простенькую электрическую схемку, цепочку "шкаф1-провод-кабель-провод-шкаф2". И далее рассчитываем длины как обычно на закладке "Кабельный журнал". Более подробно описано тут

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.16, Release 8597, Build 18459 (х32) ----------------

---- Version 28.16, Release 8597, Build 18449 (х64) ----------------

- Добавил возможность сортировать блоки обозначений кабеля на плане кабельных трасс. Подробно описано тут.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.15, Release 8591, Build 33720 (х32) ----------------

---- Version 28.15, Release 8591, Build 33724 (х64) ----------------

- Изменил просчет соединений в "Пауке": Столкнулся с такой проблемой - на старом совковом разъединителе есть два привода - главные ножи и заземлитель,то есть два ящика с приводами установленные вплотную друг к другу. И к ним идет ОДИН контрольный кабель на 27 жил. Он разделан под ящиками и жилки расходятся каждая в свой ящик к своим контактам КСА. Но Электрикал такого порно не понимает. У него каждый конец кабеля (начинается и заканчивается) в ОДНОМ шкафу. Заменить кабель на два новых - по ряду причин не вариант. А посему я на схеме проложил кабель от шкафа к приводу основных ножей, базовая жила идет к приводу QS. То есть подключение к приводу ножей заземления QSG вызывает ошибку - кабель раздваивается на два разных шкафа. И при прорисовке "Паука" программа просто "не видит" подключений к второму приводу/шкафу и соответственно не выводит изображение. Подкорректировал. Теперь кабель определяется не только по базовой жиле, но и по проводникам. И ессно показывается подключение ко всем шкафам/ящикам. Контроль за ошибкой не убрал - анализ и реагирование остается на проектировщике.

- Подкорректировал прорисовку "Паука", полочка под обозначения кабелей к шкафу теперь имеет размеры по строке. Мелочь, а приятно.

- Добавил возможность оформлять перечень кабелей в "Пауке" в блок. Удобно перетаскивать при форматировании. Инструмент "Паук" создает заготовку, которую при желании можно "утрамбовать" в любой другой формат.

- Исправил ошибку - при обновлении блока клеммника содержимое блока не окрашивалось в выбранный цвет.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.14, Release 8570, Build 36171 (х32) ----------------

---- Version 28.14, Release 8570, Build 36166 (х64) ----------------

- Исправил вывод странички для спецификации по кабельному журналу, опечатка и вылетала ошибка.

- При выводе каб журнала кабели с нулевой длиной ранее обозначались как непросчитанные/ошибочные. Однако бывают ситуации, когда реально необходимо чтобы и кабель был, и не входил в КЖ. В этом случае кабелю задается вручную нулевая длина. Например: идет реконструкция и нужно добавить новые кабели, при этом показав в кабельном журнале существующие. Что бы длина существующих кабелей не учитывались, им назначается вручную нулевая длина. И как-бы они есть в каб журнале, и в тоже время они не учитываются в спецификации

- Добавил возможность сохранять и восстанавливать настройки вывода КЖ. Более подробно описано тут

- Исправил неприятную ошибку при прорисовке клеммников в блок - не рисовала зараза. Теперь рисует. )))

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.12, Release 8539, Build 20554 (х32) ----------------

---- Version 28.12, Release 8539, Build 20558 (х64) ----------------

- Добавил возможность перенумерации выбранных на чертеже рамок и штампов. Закладка "Утилиты", кнопка "Перенумерация листов и штампов". Описание тут .

- Переработал полезную утилиту по прорисовке блоков обозначений кабеля. Расположена на закладке "Кабельный журнал" -> "Расчет длин кабелей и выбор трасс для прокладки кабелей" -> "Нарисовать обозначения кабелей". Описано тут .

- Изменил прорисовку обозначений кабеля (блоков) при выводе результатов расчета кабельного журнала. Часто бывает так, что название кабеля вылазит слишком длинное и вылазит за рамку с размерами по умолчанию (3 х 12 ед. чертежа). Сейчас сделал по другому. Перед любым выводом блоков обозначения кабеля, производится вычисление максимально необходимых размеров рамки. Перебираются все кабели проекта и выбирается наиболее длинное название. На текущем чертеже указанным шрифтом создается тестовый блок, измеряются его размеры и блок удаляется. По полученным размерам прикидывается необходимый размер прямоугольника и корректируется текущий блок обозначения кабеля. Таким образом гарантируется что ВСЕ наименования кабелей влезут и будут в одинаковых прямоугольниках.

Однако у Автокада есть специфика - иногда трудно определить действительные размеры атрибута с учетом выбранного шрифта и его размеров. Часто Автокад просто врёт про размеры. А потому при использовании какого-то необычного шрифта могут быть варианты с выходом надписи за границы рамки. Чуть-чуть, но не приятно. Однако по любому это удобнее чем подбирать вручную.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

---- Version 28.11, Release 8527, Build 36087 (х32) ----------------

---- Version 28.11, Release 8527, Build 36169 (х64) ----------------

- Поправил прорисовку клеммников - сползали перемычки при разном количестве столбцов и подключении кабелей справа. Они были завязаны на жесткое количество столбцов. Когда менялось количество столбцов или расположение столбца с номерами клемм, они "уезжали" на "старое" фиксированное место в третий центральный столбец, который содержит нумерацию клемм. Сейчас количество столбцов с номерами клемм не ограничено - перемычки будут нарисованы для каждого столбца содержащего нумерацию клемм.

- Чуть подправил упаковку клемм в красивый квадратик.

- Поправил перетаскивание кабелей между монтажными единицами, теперь можно выделить пачку и тащить.

- Добавил такую штуку как рисование нескольких клеммников как один. Описание тут . Понятно, что это первая версия и не лишена недостатков, но алгоритм и интерфейс я "допиливаю" с целью сформировать универсальную штуку которой можно будет делать какие-то стандартные заготовки оформления - типа клеммников ИТТ.

- Немного всяких мелких улучшений по интерфейсу и удаление найденных мелких шероховатостей в интерфейсе.

- Модифицировал закладку "Клеммники". Панелька инструментов клеммника занимала слишком много места и муляла глаз. Теперь она по умолчанию скрыта, выплывает когда наведешь мышку на розовую полоску и закрывается если щелкнуть по розовой полоске.

---- Version 28.10, Release 8505, Build 34545 (х32) ----------------

---- Version 28.10, Release 8505, Build 34559 (х64) ----------------

-= Очень важное обновление =-

- В общем нашел шероховатость в расчете кабельного журнала - иногда не находило очевидные пути и тянуло кабели через Африку. Лишний кабель как бы не плохо, но и не нужно. Сие было подправлено и расчет кабеля почти идеальный. Но рекомендую обкатать на каком нибудь старом расчетном плане и сравнить с предыдущими результатами.

- Добавил настройки "Зоны захвата". Подробное описание приведено тут .

- Для облегчения поиска ошибок при создании кабельных трасс на расчетной схеме, добавил инструмент трассировки. Реально полезная штука, позволила мне найти нестыковки на достаточно сложном чертеже. Подробное описание приведено тут .

---- Version 28.9, Release 8503, Build 33798 (х32) ----------------

---- Version 28.9, Release 8503, Build 33794 (х64) ----------------

- Добавил к драг-энд-дроп перетаскиванию клемм в редакторе клеммного ряда сохранение порядка нумерации. То есть теперь, если включить кнопочку обмен, будут перетаскиваться пачки клемм, но последовательность номеров не будет меняться.

- Поправил вывод названий монтажных единиц в кабельном журнале - они съезжали от центра. Так же поправил вывод без доп колонки. Теперь если не выбран переключатель (галка не поставлена) "Колонка названия монт. ед.", то название монтажной единицы будет расположено в строке, в начале группы кабелей относящихся к монтажной единице.

- Поправил сортировку кабелей в каб журнале и в дереве кабелей.

---- Version 28.8, Release 8499, Build 19451 (х32) ----------------

---- Version 28.8, Release 8499, Build 19444 (х64) ----------------

- Поправил вывод кабельного журнала в Эксель. Добавил колонку вывода марок жил для каждого кабеля и немного настроил форматирование.

- Переделал фильтр кабелей на закладке "Кабельный журнал", сплывающая менюшка фильтров. Теперь кабели выбранные по фильтру "откуда - куда" будут стараться расположится искомым шкафом слева. Но это не всегда срабатывает.

- На панельку редактора клеммного ряда добавил иконку переключателя обмена номеров клемм при перемещении. Если он выключен - клемма при перемещении не меняет свой номер. Если выключен - клемма обменивается номером с клеммой, в чью позицию она сдвигается. Это ранее было в меню и это было не удобно и не очевидно, теперь переключатель есть на панели инструментов.

- Убрал запрос шага приращения клемм при нумерации клемм, если выбрана только ОДНА клемма. Реально задалбывало.

- Добавил не сильно востребованную функцию - группировка "клемм в квадратик". Идея описана тут

- Добавил модное и удобное драг-энд-дроп перетаскивание кабеля в дереве кабелей "Закладка "Кабели"). Работает когда включена группировка по монтажным единицам.

- Добавил модное и удобное драг-энд-дроп перетаскивание клемм в редакторе клеммного ряда. Теперь можно мышкой перетащить одну или пачку клемм в позицию другой клеммы. Та, другая клемма, сдвинется вместе с остальными ниже вниз по дереву. То есть, это как вставка в позицию другой клеммы, расталкивание и вставка.
Перетаскивание включается не сразу, а через одну секунду после нажатия на левую кнопку мыши над выбранной для перетаскивания клеммой. Работает просто зашибись. Если кликнуть или отпустить кнопку раньше чем 1 секунда, то будет просто выделение клеммы как раньше.
Более подробно описано тут. И есть маленькое видео про сам процесс.

---- Version 28.7, Release 8491, Build 31818 (х32) ----------------

---- Version 28.7, Release 8491, Build 31811 (х64) ----------------

- Добавил нестандартную форму кабельного журнала. Не по ДБН/ГОСТ но очень полезно монтажникам/наладчикам. Описание смотреть здесь

- Поправил вывод кабельного журнала при использовании листов с малым штампом - "съедались" строчки, то есть выводил на меньшее количество строк чем позволяет свободное место.

---- Version 28.6, Release 8488, Build 18866 (х32) ----------------

---- Version 28.6, Release 8488, Build 18872 (х64) ----------------

- Нашел и исправил неприятную ошибку при сборке файлов проекта на один лист. Теперь работает как надо.

- Исправил ошибку при прорисовке клеммника для задания заводу.

- Убрал автозаполнение в фильтрах клеммников - реально задолбало.

- Добавил кнопку перейти к кабелю в дереве кабелей. Ранее было в контекстном меню, но с кнопкой удобнее.

- Мелкие улучшения по коду.

---- Version 28.5, Release 8477, Build 21905 (х32) ----------------

---- Version 28.5, Release 8477, Build 21910 (х64) ----------------

- В окне редактора клеммного ряда сделал маааленький фильтр отбора клем по марке провода - набираешь (только не быстро на больших клеммниках) и отмечаются только те клеммы у которых марка подходящего провода содержит набранную комбинацию букавок.

- Исправил маленькую ошибку, которая вылетала при выборе НЕ клеммы в дереве клеммников и нажатии на поиск клеммы. Мелочь, а неприятно.

- Добавил механизм подсчета количества гермовводов для шкафов. Результаты выводятся в Автокад в виде таблички. Очень полезно для задания заводу. Однако таблица изначально пустая и ее нужно будет своими значениями наполнить. Кое что я сделал - скачиваем из "облака" (там кнопка есть). Подробно описано тут . Однако графическая часть - чертеж монтажных отверстий под гермовводы еще не сделано. А может и нах не нужно?

---- Version 28.4, Release 8471, Build 20401 (х32) ----------------

---- Version 28.4, Release 8471, Build 20409 (х64) ----------------

- изменил схему рисования клеммника. Добавил возможность выбирать колонки и прочие параметры рисования - под конкретные нужды можно создать стиль клеммника и пользоваться. Более подробно тут

- поправил ошибку в фильтре шкафов на закладке "связи между шкафами"

- поправил вывод предпросмотра соединений между шкафами

- перенес кнопку "Создать ярлык на рабочем столе" в настройки программы

- добавил кнопочку "Отключить звук" - иногда куча бибиканий задалбывает. Удобнее при работе ночью без бибикания.

- давно просили и наконец сподобился - добавил цвет жилы кабеля. Оказывается многие пользуются. Значение цвета жилы кабеля хранится в атрибуте блока "RAITING1". В предпросмотре кабеля, в таблице проводников кабеля и при создании схемы подключения кабеля в чертеже AutoCAD Electrical теперь выводится цвет жилы. При прорисовке схемы подключения кабеля есть возможность отключить вывод цвета жилы. Добавлена возможность на лету менять из программы цвет жилы - из контекстного меню и кнопкой. Соответствующая кнопка появляется только при выделении жилы в дереве кабелей, при выделении блока обозначающего жилу кабеля.

- убрал из таблицы колонку "длина" и добавил колонку "цвет жилы"

- в настройках рисования подключения кабеля заменил переключатель "рисовать на отдельных листах" на "показывать цвет жилы"

Более подробно про цвет жил кабеля тут

- оставил прорисовку кабеля от одной клеммы к другой клемме одного клеммного ряда

---- Version 28.3, Release 8160, Build 27207 (х32) ----------------

---- Version 28.3, Release 8160, Build 27211 (х64) ----------------

- Исправил ошибку с перенумеровкой штампов и листов. Зависала после первого листа/штампа.

- Добавил переключатель для "сборки" чертежей по вертикали

- добавил в в этот Хэлп раздел "Вопрос-Ответ" . С удивлением обнаружил что за время полировки программы я довольно много общался с пользователями и пояснял некоторые моменты. В общем выделю самые интересные вопросы и сведу их в табличку.

---- Version 28.2, Release 8126, Build 34853 (х32) ----------------

---- Version 28.2, Release 8126, Build 34862 (х64) ----------------

- Сделал визуализацию внешних соединений между шкафами. Визуальное представление легче воспринимается чем табличное. Хотя табличное более информативно. Однако при контроле ошибок "на лету" рисунок быстрее обрабатывается головой. Пока не интерактивная штука - просто рисунок. Со временем присобачу контекстное меню и вывод в автокад "что вижу - то и рисую".
Более подробно описано тут

---- Version 28.1, Release 8112, Build 4108 (х32) ----------------

---- Version 28.1, Release 8112, Build 4079 (х64) ----------------

- Покуда работы нет: много сотрудников уехали в более спокойные места, фирма практически не работает, по подстанции которую мы реконструировали в Харькове попала кацапская ракета и расхуярила ОРУ. А потому я сижу в бомбоубежище и, пока меня не убили фашисты, дописываю программку.

- Добавил предварительный просмотр подключения кабеля. На закладке кабели есть страничка "Предварительный просмотр". На ней выводится рисунок как и куда подключаются жилы кабеля. Должно быть удобно для контроля кабелей. Пока не интерактивная штука - просто рисунок. Со временем присобачу контекстное меню.

---- Version 28.0, Release 8109, Build 6910 (х32) ----------------

---- Version 28.0, Release 8109, Build 7010 (х64) ----------------

- Поправил неожиданную ошибку - если в таблице связей отфильтровать связи по кабелю, а потом снова выбрать все - появляется новая жила в кабеле, которой физически нет, и при этом она назначается далее по схеме внутрь шкафа... капец чудеса.

- Оживил кнопку обновления схем подключения кабелей. Программа подключается к текущему чертежу в Акаде, просматривает все блоки что есть на чертеже, находит блоки кабельных связей и обновляет их. Если блок соответствует кабелю, который был удален из проекта - он не удаляется и не рихтуется.

- Добавил кнопку вывода в Эксель перечня связей с закладки "Связи между элементами". Выводится только то, что есть в таблице, отфильтрованный или нет список.

- Внес существенные изменения в расчет кабельного журнала. Теперь можно указать кабели которые являются резервом друг к другу. При расчете учитывается наличие признака взаимо-резервируемых кабелей и эти кабели будут проложены по возможности по разным трассам.

- Добавил группировку кабелей по метке взаимо-резервирования - описано тут .

- Переработал хэлп в разделах "Кабели" и "Кабельный журнал" - рекомендую перечитать, я старался )))

- Чуть причесал код и подрихтовал интерфейс.

- Видео с нововведениями смотреть тут

---- Version 27.55, Release 8074, Build 29376 (х32) ----------------

---- Version 27.55, Release 8074, Build 29371 (х64) ----------------

- При расчете каб журнала вылетала ошибка, которую по недомотру сам и допустил в предыдущей версии. Пофиксил.

- Чуть причесал код.

- Видео с нововведениями смотреть тут

---- Version 27.54, Release 8072, Build 34603 (х32) ----------------

---- Version 27.54, Release 8072, Build 34613 (х64) ----------------

- Поправил интересную ошибку: если нет файла шрифтов WWCADE(не установлен в АКАДе), то происходил сбой при прорисовке блоков обозначения шкафов при подготовке к расчету кабельного журнала. Выход простой - создать свой стиль и выбрать его по умолчанию Однако такие ситуации возможны и я поправил их обработку.

- Переделал менюшку на закладке "предварительный просмотр кабельного журнала". Чисто навел марафет. Может будет немного не удобно, но мне больше места для всяких настроек.

- Добавил плавающие панели для фильтра кабелей и для рисования кабельного журнала. Благодаря фильтру можно отобрать часть кабелей и создать КЖ только для них. Более подробно читать тут.

- Добавил возможность переименовывания кабелей выбирая на экране, как инструмент перенумерации клемм тыкая в них на экране. Более подробно читайте тут.

- Добавил на закладку "Кабели" фильтр кабелей по "монтажной единице" и кнопку сворачивания дерева до уровня монт. ед.

- Добавил на закладку "Утилиты кабелей" выбор списка кабелей для обработки. Можно выбрать весь проект, или только отфильтрованные (все что есть в дереве), или только выделенные с Shift.

- Поправил иногда появлявшийся сбой и прерывание процесса при расстановке в рамки блоков подключения кабелей. Автокад отказывался обрабатывать некоторые команды, пришлось "уговаривать".

---- Version 27.53, Release 8054, Build 49753 (х32) ----------------

---- Version 27.53, Release 8054, Build 49744 (х64) ----------------

- Поправил ошибку при обновлении хэлпа с сервера - если на каком-то сервере останется старая версия, то она "передавливала" новые версии при выборе. Источников три - и потому есть выбор наисвежайшей. И получались качели - каждый раз скачивалась при запуске другая версия. Насос блин.

- Добавил в хэлп описание популярной ошибки при расчете кабельного журнала и привел метод ее оперативного решения. Читать тут .

- Добавил в расстановку блоков в форматные рамки (закладка "Утилиты всякие") возможность отбирать из списка выбранных элементов только блоки. То есть обвели скопом, выбрали вместе с нужными блоками всякое нарисованное, и потом обработали только блоки.

- Перенес в утилиты кабелей инструмент замены Inst и Loc, добавил чекбокс выбора Inst и Loc - можно менять по отдельности. Так же теперь обрабатывается не весь проект, а выбранная в дереве группа кабелей

- Добавил выбор разбивки кабелей при создании схем подключения кабелей. Теперь блоки/схемы/форматные рамки будут выстроены в ряды по горизонтали с разбивкой по монтажной ед., по Inst, по Inst-Loc итак далее.

- Поправил ошибку при создании атрибута в версии х64. Были серьезные нестыковки с Автокадом в версии х64 из-за чего не рисовало (по крайней мере на моих машинах) и не настраивало стили текста. Версия 32х работает без этих заморочек. В общем поправил.

---- Version 27.52, Release 8046, Build 4223 (х32) ----------------

---- Version 27.52, Release 8046, Build 4215 (х64) ----------------

- Поправил ошибку при открытии чертежа. Сам поломал и сам починил :)
Больше на сегодня обновлений не будет ))))

Видео пояснений нововведений в версии 27.50-27.52 на ютубе

---- Version 27.51, Release 8046, Build 46367 (х32) ----------------

---- Version 27.51, Release 8046, Build 46361 (х64) ----------------

- Поправил "задумчивость" при расчете кабельного журнала. АЭ оказывается очень трепетно относится к количеству наборов в одном сеансе.

- Исправил ошибку при расчете каб журнала с использование зоны захвата - блок то захватывал, а при расчете не учитывал и кабель все равно оставался без длинны. А это блокировало нормальное сохранение/считывание результатов расчета каб журнала.

- Добавил "исправление" положение блока маркера шкафа на расчетном плане - при анализе определяется куда его "присобачить" и туда перемещается блок. Можно отключить. Более подробно тут. Очень рекомендую прочитать заново этот раздел хэлпа

- Исправил ошибку с блокировкой расчета КЖ в 64 разрядной версии. Расчет то производился, но при рисовании КЖ в автокаде вылетала ошибка.

---- Version 27.50, Release 8044, Build 63349 (х32) ----------------

---- Version 27.50, Release 8044, Build 63339 (х64) ----------------

- Добавил разбивку кабелей по монтажным единицам. Хранится в DESC3 базового блока кабеля. Настраивается на закладке "Кабели". Так же добавил в вывод КЖ возможность разбивки по монтажным единицам и с дополнительной колонкой.

- Переделал закладку "Кабели" - разделил на две странички - "Параметры кабеля" и "Утилиты". На вторую страничку перенес всякие инструменты.

- Переделал окно "Распечатка отдельных чертежей" из меню "Утилиты всякие". Разделил сваленные в кучу инструменты на две группы на двух закладках - настройка печати + распечатка с активного листа, и распечатка списка выбранных файлов. К выбору отдельных файлов добавил выбор папки с файлами. То есть сначала создаем список файлов для печати, сортируем его, чистим и потом выдаем на печать.

- Добавил кнопку "Переименовать кабелей выбирая на чертеже" - то есть тыкаете по очереди в блоки обозначения кабелей на чертеже и по окончании выбора весь список в этом порядке будет перенумерован. Типа как перенумерация клемм выбором.

- Добавил поле "зоны захвата". В этом поле задается предельное расстояние от блока обозначающего шкаф на расчетной схеме и ближайшей крайней точкой отрезка кабельной трассы. Расстояние задается в единицах чертежа. По умолчанию - 0,001мм. Как показала практика это маловато. Часто при размещении на чертеже блоков шкафов промахиваются и оставляют зазор, что приводит к ошибке при расчете. Теперь можно щелкнуть по полю и задать новое значение. Значение зоны захвата сохраняется в проекте. Действует только на шкафы.

- Поправил сортировку в перечнях кабелей/шкафов/клемников - что бы после "KL1" шло "KL2", а не "KL10" при количестве элементов более 10. Сортировалось ранее по буквам И получалось что KL1 и KL10 идут последовательно.

---- Version 27.40, Release 7918, Build 65411 (х32) ----------------

---- Version 27.40, Release 7918, Build 65442 (х64) ----------------

- Много лет в статусной строке (Status Bar) название пункта меню было "Abaut". В ютубе пользователи заметили, подсказали и я поправил ошибку на правильное аглицкое "About". :-)

- Добавил индивидуальную панельку для сборки и разбивки чертежей на отдельные файлы (закладка "Чертежи проекта"). Не помещались чекбоксы и кнопки для настройки. Да и инструмент достаточно востребованный, поэтому теперь имеет отдельную панельку.

- Доработал алгоритм парсинга ВОМ - "причесывание" перечня элементов который создает AutoCAD Electrical. Теперь программа корректно распознает и сортирует позиционные обозначения элементов типа KL1 и KL001. Ранее это превращалось в один элемент KL1, хотя и в двух экземплярах. (более подробно тут ).

- При запуске программа проверяет наличие новой версии и нового хэлпа, стучится по очереди на три сервера. Однако иногда бывает что сервера, с которых происходит обновление, недоступны. И программа "зависает" на секунд 15-20. Хотя на экране это никак не отражалось, но потоки которые осуществляли опрос, не давали закрыть программу. То есть, если запустили программу и тут же ее захотели закрыть, а сервера "лежат" или нет интернета, то закрыть программу сразу не получится, пока не пройдет таймаут. В общем выглядит не очень. Я уменьшил таймауты до 3 сек на соединение. По идее должно уменьшить время "зависания", хотя хз.

В общем рекомендую не закрывать программу сразу, а по возможности подождать пару минут. Но если закрыть сразу тоже ничего страшного - просто она повисит в памяти и сама закроется.

- Немного "причесал" закладку "Файлы проекта", типа пыль смахнул.

- Добавил в разбивку файлов выбор "обрабатывать файл с одной рамкой". Идея в следующем: при разбивке файлов содержащих в каждом много форматных рамок, среди них могут попасться файлы содержащих только одну рамку. И тут два варианта: 1) просто пропускаем файл, ничего не делаем; 2) считываем название чертежа из штампа и вносим в настройки проекта. Считаю что опция достаточно опасная - будьте внимательны.

- Добавил кнопку очищения (не обнуления) счетчика листов (правый верхний угол). Говорят бывает полезно, если нужно проставить номера вручную после перевода в pdf

- Поправил имя блока форматной рамки при условии заполнения штампа в отдельном блоке. Ранее было "двойное имя".

---- Version 27.36, Release 7869, Build 57834 (х32) ----------------

---- Version 27.36, Release 7869, Build 57842 (х64) ----------------

- Добавил настройку вывода названия шкафа для клеммника. Теперь можно выбрать вид подписи или вообще не подписывать клеммник. Чуть подробнее тут

- Поменял внешний вид панели рисования клеммника

- Напоминаю, при запуске программы сразу запускается проверка версии хэлпа (этого файла) Если на сервере будет обнаружена новая версия, то тут же запускается процесс скачивания (в фоне). И время скачивания зависит от размеров хэлпа и толщины вашего канала. То есть если открыть программу и сразу закрыть - она не закроется пока идет скачивание хэлпа, она как бы "подвиснет" в памяти ожидая пока процесс скачивания не закончится, а уж потом нормально закроется.

- Добавил кнопочку "Показать связанные проводники" на закладке "Связи между элементами". Идея была в том, чтобы видеть конкретные связи внутри шкафа. То есть клеммы/контакты приборов, по которым пробегает какой-то выбранный провод. В таблице связей выбираете строчку (это какой-то провод между двумя точками) и отфильтровываем все проводники которые "касаются" его.

- Обновил систему обновления - добавил третий сервер. "Бесплатные" сервера в инете стоят денег если нужно чуть больше чего нить, потому озаботился и купил апельсинку - OrangePi. Теперь халявный сайт лежит у меня дома в туалете на стене. И в случае если что-то произойдет с теми "бесплатными" страницами - обновления будут скачиваться с третьего моего домашнего сервера.

---- Version 27.35, Release 7848, Build 35053 (х32) ----------------

---- Version 27.35, Release 7848, Build 35092 (х64) ----------------

- Добавил всплывающее окно настройки рисования клеммников - перенес в него все настройки. Насколько удачно получилось посмотрим.

- Переделал кнопки в "Файлы проекта"-"Полезности".

- Добавил обновление блоков клеммников на текущем чертеже и в текущем проекте.

- Сделал скрытые атрибуты в клеммниках для последующего опознания. При выполнении обновления клеммников программа должна как-то узнать какие клеммники есть в чертеже и параметры, с которыми они рисовались. Имя блока клеммника по умолчанию несет INST-LOC-TAG, однако это не гарантирует 100% опознания. Всегда есть риск что юзер переименует блок. Поэтому теперь при создании клеммника в него вставляются около десяти атрибутов, в которых прописано кто это, каким цветом и как его рисовали. При обновлении блоков эта информация является исходной. Атрибуты сохраняются только в блоках! Клеммники, которые нарисованы не в блоке, никак обновить невозможно, увы.

- Сделал проверки количества "списков выбранных элементов" - SelectionSet в чертеже и удаление всех SelectionSet перед созданием нового.

Пояснение: оказывается, что количество SelectionSet на чертеже ограничено в 128 штук. SelectionSet сохраняются в файле чертежа. То есть, когда программа в сотый раз ищет на чертеже клеммники/детали или рисует что-то - происходит создание и сохранение очередного SelectionSet. В конце концов это может привести к переполнению и отказу в обслуживании. На 99% этого количества вполне хватает. Но, если был сбой или рисуются/обновляются ВСЕ клеммники в проекте - может быть переполнение.

- Исправил механизм обновления - старая программа зависала в памяти и не давала запуститься новой. То есть обновления проходили нормально, программа обновлялась, однако были нюансы и иногда происходило зависание - пофиксил.

- Сделал отложенный на 2 сек запуск проверки новой версии. То есть теперь запуск проверки новой версии через две-три секунды после запуска программы.

---- Version 27.32, Release 7838, Build 14801 (х32) ----------------

---- Version 27.32, Release 7838, Build 14817 (х64) ----------------

- Сделал более толковое распознавание областей для печати - блоков форматных рамок. Теперь можно выводить на печать увеличенную в масштабе рамку. Например первичники нарисовали чертеж и сделали ,как они любят, форматную рамку А3 с масштабом 1:500 или более. Теперь можно увеличить вручную форматную рамку или сгенерировать новую рамку с масштабированием (меню утилиты, для распечатки отдельных листов), расположить рамки в нужном месте и программа сама определит что собсно нужно печатать. При необходимости сменит масштаб "1:1" на "вписать в область печати". Подробнее тут

---- Version 27.30, Release 7837, Build 48300 (х32) ----------------

---- Version 27.30, Release 7837, Build 48345 (х64) ----------------

- Сделал сохранение "длинных" названий шкафов в файле проекта - объединил два ини файла. Ранее для сохранения описаний шкафов ("длинных названий") использовался отдельный файл "<Имя проекта>_FullNameBox.txt". Теперь я его упразднил и перенес в общий файл настроек "<Имя проекта>.wdkir". Не волнуйтесь, старые заполненные файлы обнаруживаются и переносятся корректно в новое место хранения, заново не придется перебивать "длинные" наименования.

- Добавил экспорт "длинных" названий шкафов в Эксель и считывание обратно. В программке все мелко и неудобно рихтовать. Проще сделать это в Экселе. Делаем просто - считываем проект, тыкаем в пимпочку, список оказывается в Экселе. Рихтуем названия в Экселе (не меняя столбцы!). Тыцаем в другую пимпочку и программа считывает обратно "длинные" названия.

- Сделал назначение текстового стиля при рисовании в AutoCAD. Это самый цимес - это то, что надо было сделать изначально. Но программу я начал создавать очень давно и рассчитывал только на себя, а пользовался я стилем WWCADE. Симпатичный шрифт, но внутрифирменные стандарты у всех разные, у всех разные стили для оформления проекта. Теперь можно создавать выходные документы выбранным стилем, создавать его, настраивать и т.д. Выбранный стиль сохраняется в настройках проекта и "вспоминается" при открытии проекта. Так же его можно сохранить в реестре, типа временный и использовать для рисования рамок без открытия проекта. Если стили уже настроены на листах - можно выбрать использование текущего стиля в DWG.
Подробнее тут: читать

- Поправил пакетную настройку слоёв (для группы файлов или для всего проекта) - из-за сбоев связи с акадом процесс прерывался с ошибкой. Пофиксил, теперь молотит до посинения як скажэный.

- Добавил распознавание AutoCAD 2022.

- Поправил термометр, который "зависал" после поиска элемента из контекстного меню.

- Подкорректировал показ хэлпа при первом запуске после обновления программы.

---- Version 27.20, Release 7813, Build 37464 (х32) ----------------

---- Version 27.20, Release 7813, Build 37448 (х64) ----------------

- Добавил блоки-перемычки при расчете кабельного журнала. То есть вместо линий перемычек добавляем блоки-перемычки и указываем код (для связи). При анализе блоки с одинаковыми кодами будут рассматриваться как одна точка, типа шины. Между ними создаются виртуальные перемычки. Не рекомендуется (но можно) делать более 50 блоков-перемычек - тормозить будет нещадно. Сделал 500 блоков - "думало" 40 минут и в конце-концов в компе кончилась память. Со временем сделаю так что бы снять и ограничение. Но количество групп блоков-перемычек с разными кодами не ограничено - можете делать хоть мульён групп по 50 штук.
Более подробно можно почитать в хэлпе

- Подрихтовал отрицательную длину "труб", которые не назначены какому ни будь пути (на складе лежат). Однако они учитываются в спецификации.

- Сделал распознавание слоёв для кабельного журнала по префиксу в имени. Можно задать дефолтный префикс или задать свой. То есть можете делать свои слои пачкой и не описывать их в табличке слоёв - главное что бы в имени была "метка", например "My_LabelLayerCabShedule" или "ЭтоСлойКабТрассы". Однако если не описать слои в табличке программа не догадается как описывать их в кабельном журнале. В случае если используются "трубы" для прокладки, то и не надо. Типа удобно получается.

- Подчистил общение с Акадом - по идее теперь должно побыстрее заработать, но хз как будет в конкретном случае.

- Сделал сохранение и считывание фиксированных длин кабелей, отдельно от кабельного журнала. Это нужно при ручном заполнении длин кабелей.

- Сделал отдельное сохранение "добавки" к длине кабеля. Эти параметры не зависят от кабельного журнала - если длины кабелей заданы вручную, то "добавки" к длине должны работать.

- Добавил кнопку "Фиксировать длины всех кабелей" - перевод в ручной режим всех кабелей - накуя и сам не знаю. По этой кнопке ВСЕ кабели считаются что им вручную задали длины.

- Очень много всего почистил в коде и в интерфейсе.

---- Version 27.19, Release 7806, Build 53485 (х32) ----------------

---- Version 27.19, Release 7806, Build 53464 (х64) ----------------

Переработал кабельный журнал - оживил работу с типами прокладки:

- Довел до ума работу с типами прокладки кабеля - с "трубами"

- Оживил на экране таблицу потребности "труб"

- Сделал вывод в кабельный журнал перечня участков трассы в объявленных трубах и потребность "труб"

- Добавил проверку "трубы" на корректность при растягивании на экране

- Добавил контроль и коррекцию перечня кабелей проложенных в этой "трубе" при растягивании/изменении трассы. Теперь если программа определяет конфликт появляется запрос подтверждения действий

- Добавил контроль и коррекцию перечня кабелей в "трубе" при считывании кабельного журнала

- Поправил ошибку при растягивании "трубы" на перемычку

---- Version 27.15, Release 7796, Build 52513 (х32) ----------------

---- Version 27.15, Release 7796, Build 52538 (х64) ----------------

- Поправил еще раз редактирование списка слоёв для кабельного журнала

- Добавил сохранение состояния кабельных труб при пересчете кабельного журнала

- Причесал хэлп, добавил пару разделов

- Всякие мелкие улучшения по всей программе

---- Version 27.10, Release 7792, Build 57716 (х32) ----------------

---- Version 27.10, Release 7792, Build 57696 (х64) ----------------

- Добавил выделение "неправильного" кабеля в кабельном журнале. Если длина кабеля превышает разумные пределы, то есть путь прокладки кабеля не найден, этот кабель будет выделен цветом и напротив будет маркер.

- Поправил редактирование списка слоёв/типов прокладки для кабельного журнала.

- Полностью работает отображение и работа с "трубами" для прокладки кабелей. Но в кабельный журнал еще не выводится. То есть для себя список можно cделать, вывести в эксель, считать из экселя, назначить и т.д.

- Добавил в таблицу файлов две чек-кнопки - показывать длину и показывать описание слоя

- Добавил возможность изменять длину кабеля. Есть нюансы, читайте тут.

- Добавил возможность изменять тип кабеля.

- Переделал сохранение и считывание каб журнала - теперь запоминает вручную заданную длину кабеля

- Откорректировал сборку чертежей на один лист, теперь нормально обрабатывает и повернутые листы.

- Добавил перенос на нулевой слой в подготовке проекта для заказчика.

- Полирнул код, сильно полирнул.

---- Version 27.5, Release 7770, Build 47977 (х32) ----------------

---- Version 27.5, Release 7770, Build 47961 (х64) ----------------

- Изменил алгоритм разбивки файлов на отдельные рамки

- Изменил функцию открытия папки с mdb файлами, теперь она открывает автокадовскую папку без открытия проекта - это удобно когда нудно удалить mdb базу данных проекта

- Добавил прорисовку отдельного блока штампа для рамки

- Переделал внешний вид закладки "Файлы проекта" - получилось симпатично

- Добавил возможность поиска файла в списке по части имени

- Добавил возможность фильтрации файлов в списке по части имени

- Разбивку файлов теперь можно применить к выделенным отдельным чертежам проекта

- Почистил немного код

---- Version 27.2, Release 7753, Build 61894 (х32) ----------------

---- Version 27.2, Release 7753, Build 61900 (х64) ----------------

- Устранил проблему с заполнением малого штампа в форматной рамке (ну тот что стоит вертикально у левой стороны рамки). Там текст не поворачивался на 90гр в версии 64х. Вроде подрихтовал, но если у кого-то будет вылазить снова - напишите мне пожалуйста.

- Накрылась медным тазом почта bigmir.net - она как бы работает, но тааак медленно, что чтение превращается в пытку. На отправку вообще глюки. Поэтому пишите на почту des501@ukr.net. Но если хотите пишите и на бигмир, просто я её проверяю реже.

- Подчистил код, подготавливаю к многоязычию - можно будет выбрать один из трех языков.

---- Version 27.1, Release 7751, Build 65233 (х32) ----------------

---- Version 27.1, Release 7751, Build 65239 (х64) ----------------

- Изменил рисование форматных рамок. Теперь можно создать:

  • пустую форматную рамку
  • форматную рамку с заполненными полями главной надписи (заполненный штамп), который является частью блока форматной рамки
  • форматную рамку и заполненный штамп в виде отдельных блоков
  • только блок штампа

- Полностью "перелохматил" программное общение с AutoCAD, что должно позволить более стабильно получать результаты и уменьшить (теоретически до нуля) количество отказов AutoCAD

- Полностью "перелохматил" тиражирование чертежа с несколькими форматными рамками в отдельные файлы чертежей с одной форматной рамкой "на борту" - были случаи сбоев в процессе тиражирования (отказ в обслуживании от AutoCAD)

---- Version 26.17, Release 7747, Build 51569 (х32) ----------------

---- Version 26.17, Release 7747, Build 51712 (х64) ----------------

- Нашел опечатку в коде - было заблокировано рисование форматных рамок, подкорректировал

---- Version 26.17, Release 7747, Build 43015 (х32) ----------------

---- Version 26.17, Release 7747, Build 43088 (х64) ----------------

- На закладке "Файлы проекта" оживил кнопку "Взорвать чертежи". Теперь можно выбрать один или несколько чертежей, и превратить их в просто рисунок AutoCAD, то есть взорвать все блоки и удалить атрибуты. Аналогично кнопке "" самого AutoCAD Electrical. Понимая что кнопка очень опасная, сделал два подтверждения для начала операции. Бэкапа нет! То есть, в случае если прощелкали, то откатиться назад не получится - только поднимать локальные баки.

- Подправил рисование рамки - атрибут многострочный теперь OPIS

- Добавил новую строку в wdl файл по умолчанию "OPIS = DWGDESC"

- Добавил поворот текстового описания точки назначения кабеля в схеме подключения кабеля. Теперь если на меню "Нарисовать клеммник" поставить галочку "Повернуть на 90гр" - нарисованный клеммник будет повернут "на бок" и соответственно подписи будут повернуты в горизонтальное положение.

- Всякие мелкие улучшения по всей программе типа почистил код и тд

---- Version 26.16, Release 7738, Build 12595 (х32) ----------------

---- Version 26.16, Release 7738, Build 12628 (х64) ----------------

- Обнаружена интересная ошибка. При тиражировании файла (ну когда несколько рамок на одном чертеже и необходимо разделить на несколько отдельных чертежей с одной рамкой и добавить в проект) происходило добавление названия чертежа во вторую строку описания. Была накладка - в блоке присутствовали и однострочные атрибуты описания и один многострочный. Программа путалась и лепила кашу. После автокад разбирая ее творение, загонял описание чертежа во второй атрибут OPIS2. Выглядело как будто название чертежа сдвигалось.

Теперь я ввел жесткое правило - если используете в блоке основной надписи многострочный атрибут (его имя жестко задано - OPIS), то все остальные однострочные атрибуты типа OPIS1 и т.д. просто игнорируются.

То есть выбирайте что-то одно - или выполнять описание чертежа в виде МТЕХТ при помощи многострочного атрибута OPIS, или в виде нескольких строк с именами OPIS1...OPIS20.

читать подробнее тут

---- Version 26.15, Release 7737, Build 37521 (х32) ----------------

---- Version 26.15, Release 7737, Build 37452 (х64) ----------------

- С 8 марта девочек, с праздником весны всех остальных )))

- Поправил сбор файлов на один лист - была ошибка при отказе автокада обслуживать запрос и процесс прерывался. Желательно всегда указывать начальную точку сбора вдалеке от (0,0,0).

- В расчет каб журнала сделал сообщение, что обнаружены новые слои - что бы было понятно почему в каб журнале выводятся наименование слоёв, а не описание путей прокладки кабеля. Если не найдено в списке имя слоя трассы, то выводится просто имя слоя. Иначе выводится описание (если есть).

- Всякие мелкие улучшения по всей программе

---- Version 26.14, Release 7721, Build 62691 (х32) ----------------

---- Version 26.14, Release 7721, Build 62700 (х64) ----------------

- Поправил ошибку при поиске файла чертежа в списке файлов

- Поправил ошибку при вызове функции обновления базы данных проекта - иногда не срабатывала

- Всякие мелкие улучшения по всей программе

---- Version 26.12, Release 7716, Build 16117 ----------------

- Расчет каб журнала (длин кабелей) не изменился. Выбор типов прокладок еще в процессе разработки.

- Переделал определение версии Автокада - были прецеденты когда после кривой установки Акада он не определялся.

- Переделал "причесывание" ВОМ - переработал интерфейс и добавил вариант с 6м столбцом для релейщиков.

- Добавил наброс процентов и длины при выводе схемы подключения кабелей - в каб журнале длины выводились с коррекцией, в схемах подключения нет. Так же теперь сохраняются в настройках проекта значения наброса

- Убрал анахронизм сохранения длин кабелей в отдельном файле. Теперь логика простая: посчитал каб журнал - получил длины кабелей. Вручную теперь поштучно корректировать нельзя. Длина кабеля теперь зависит от пути по которому он проложен. Остальное описание см хэпп

- Немножко почистил код

- Всякие мелкие улучшения по всей программе

---- Version 26.11, Release 7504, Build 57759 ----------------

- Немного причесал утилиту подготовки к передаче заказчику. Добавил варианты сохранения имен файлов и имен каталогов.

- Всякие мелкие улучшения по всей программе

---- Version 26.10, Release 7476, Build 2358 ----------------

- Поправил странное поведение кнопок ◄ ► на вкладке "настройки проекта". Давняя фигня, которую я несколько раз пытался победить. В общем там компонент виндовый написан через жопу. Поправил, теперь работает как надо. Хотя внутренняя логика писателей того компонента мне непостижима.

- Всякие мелкие улучшения по всей программе

---- Version 26.9, Release 7471, Build 13643 ----------------

- Откорректовал ошибку при рисовании форматной рамки (один из прямоугольников бокового штампа) был 20мм вместо 25мм.

- Добавил выбор имени слоя и выбор цвета слоя для форматной рамки. Мелочь а приятно.

- Всякие мелкие улучшения по всей программе

---- Version 26.8, Release 764, Build 1280 ----------------

- Выпустил впервые версию 64х. Хз, как она работать будет - пробуйте, если что пишите мне на мыло - буду фиксить баги. И делайте бэкапы проектов :)

Только с сайта пока не скачивается - вот ссылка (фиг кто это читает, так что фиг кто скачает :) )

---- Version 26.7, Release 764, Build 1280 ----------------

- Поправил ошибку при обновлении LinkTerm - спасибо за подсказку :)

- Из-за небольшого изменения внутренней логики аж год назад выплыл баг только сегодня.

- Вот тема на форуме которая обьясняет зачем нужна кнопка обнуления LinkTerm

https://forums.autodesk.com/t5/semeystvo-autocad-russkiy/autocad-electrical-2020-problem-s-podschetom-klemm-v-perechne/td-p/9557000

- Всякие мелкие улучшения по всей программе, причесал немного код.

---- Version 26.5, Release 762, Build 1262 ----------------

- Благодаря подсказке пользователя исправил вывод в кабельном журнале обозначения импортных кабелей типа "OLFLEX CLASSIC 110 SY 3G1"

- Поправил механизм сообщений о новых версиях и исправлениях - теперь поддержка UTF-8

---- Version 26.4, Release 761, Build 1246 ----------------

- Добавил распознавание забугорного кабеля типа "OLFLEX CLASSIC 110 SY 3G1"

- Переделал сортировку кабелей в каб журнале

- Добавил поддержку UTF-8 при выводе клеммника в ClipProgect - иначе ClipProgect не считывал файл

- Добавил в таблице файлов проекта отфильтровку по имени блока форматной рамки и/или имени блока основной надписи

- Всякие мелкие улучшения по всей программе

---- Version 26.1, Release 755, Build 1240 ----------------

С наступившим 2020м НГ всех! :)

- Перевел программу на новый движок. Пока 32х разрядный, но вскоре будет 64х разрядный. Заложил кучу возможностей которые буду реализовывать постепенно. Исправил кучу багов и нестыковок. Они не влияли на результат, но теперь чуть ускорилась работа программы

Поэтому настоятельно рекомендую СОХРАНИТЬ предыдущую версию программы дабы обезопасить себя. Скорее всего это лишнее, но береженого бог бережет.

- Зафиксировал размеры полей в таблице списка файлов проекта.

- Добавил считывание из базы данных проекта имен и хэндлов блоков рамок и штампов.

- Добавил поля штамп и рамка в таблицу файлов проекта, добавил комбобоксы выбора рамок и штампов - при выборе конкретного имени блока подсвечиваются соответсвующие поля в таблице. Теперь можно контролировать на каком чертеже какие блоки штампов и рамок.

- Добавил поле редактирования для выбора маски имени блока штампа (главной надписи проекта) и связал с WDT файлом.

- Исправил взаимное редактирование таблицы настроек и файлов WDP, WDT, WDL.

- При старте проверяется на корректность шаблон блока штампа WDT и при необходимости корректируется и сохраняется.

- Добавил в панель редактирования клеммника "термометр" для индикации прогресса.

- Исправил переименование клеммника.

- Добавил чекбокс в контроль исправности кабеля.

- Добавил панельку настройки параметров программы.

- Всякие мелкие улучшения по всей программе

- Обнаружил интересный глюк. Описал его здесь: https://project12-utilites.blogspot.com/2019/11/blog-post.html

---- Version 25.49, Release 755, Build 1208 ----------------

- Изменил алгоритм подключения к автокаду - была фигня какая-то с подключением к АЭ2020 если нет админских прав

- Поправил - при прорисовке клеммников не выводилось слева описание подключения для транзитной клеммы без подключенного кабеля (в режиме "по-бразильски").

- Добавил возможность перезаписи существующих pdf при распечатке. Ранее, если уже был pdf файл с таким же именем, новому файлу в имя добавлялось случайное число, что обеспечивало сохранность существующего файла.

- Перенес скачивание chm файла хэлпа в процедуру обновления, теперь скачиваются и принудительно обновляются одновременно - и хэлп и сама программа. Убирается торможение/задумчивость при первом запуске.

- Немножко изменил на закладке "Файлы проекта" - при вводе маски поиска нажатие энтер вызывает немедленный поиск без необходимости нажимать клавишу "Найти в таблице чертеж"

- Всякие мелкие улучшения по всей программе

---- Version 25.49, Release 658, Build 1195 ----------------

- При построении дерева на закладке "Связи между шкафами" программа игнорировала верхний и нижний регистры. В таком случае если в проекте находились шкафы и/или места с одним именем, но набранных в разных регистрах программа их "сливала" в одну позицию что приводило к искажению отображаемой информации. Например: "КРПЗ 10 КВ" и "КРПЗ 10 кВ" - ошибка практически незаметная, однако для Автокада электрикала это разные названия и разные объекты.

- При экспорте клеммного ряда в XML для передачи в Clip Project нарушалась сортировка клемм. Исправил.

- Вывод заголовка таблицы перечня клемм был только на украинском. Добавил русский язык.

- Вывод заголовка раздела в спецификации кабелей был только на украинском. Добавил русский язык.

- При открытии проекта расположенного на сервере в сети появлялись двойные ссылки на файлы проекта

- Добавил кнопку на блог - буду там делиться своими "гениальными" мыслями про АЭ.

- Добавил поиск страницы в перечне чертежей на закладке - искать конкретный лист в перечне из 500-600 листов не очень удобно.

- Добавил кнопку хэлпа на закладку "Наименования"

- Всякие мелкие улучшения по всей программе

---- Version 25.47, Release 655, Build 1182 ----------------

- Исправил сбой в программе при расчете кабельного журнала. В случае использования отрезка на слое "перемычка" - участок трассы который всегда с нулевой длинной участка - происходило попытка нарисовать на плане текст (номер участка) с нулевой высотой на что автокад законно ругался. Исправил, уже не ругается. Спасибо внимательным коллегам. :)

- Всякие мелкие улучшения по всей программе

---- Version 25.47, Release 648, Build 1177 ----------------

- Исправил досадную опечатку при прорисовке внешних подключений к клемникам. При использовании режима заполнения полей клемника "По бразильски (не ГОСТ)" в поля должны были выводиться ссылки на точку подключения другого конеца проводника, указываться контакт прибора или номер клемы. Из-за опечатки в некоторых случаях проскакивала ссылка на свой конец проводника, на свою клему. Исправил. Спасибо внимательным коллегам. :)

- Всякие мелкие улучшения по всей программе

---- Version 25.47, Release 645, Build 1176 ----------------

- Наконец доделал расчёт длин кабелей по плану в 3Д. То есть пути прокладки создаём из отрезков, но располагаем уже не в плоскости, а в объёме. Как считает показал тут: https://youtu.be/JgnbjYpcXlE

- Исправил появляющееся сообщение после переименовывания поштучно кабелей. Ничего опасного, кабели переименовывались корректно, чисто механическая ошибка/опечатка в коде при отображении нового имени кабеля.

- Всякие мелкие улучшения по всей программе

---- Version 25.45, Release 642, Build 1167 ----------------

- Проверил работу с АЭ 2020. Работает, глюков замечено не было. Однако словил такую особенность: при установке АЭ 2020 неправильно в реестре себя регистрирует. Если перед установкой будет очищен реестр любым чистильщиком, то автозапуск АЭ не происходит - программа не может его найти по универсальному имени. Необходимо точно знать какой автокад установлен. Исправил. Теперь программа вычисляет какой версии установлен Автокад и запускает его. Если установлены несколько разных версий запускается наиболее старший.

- Переделал работу с таблицей описания проекта. Теперь можно указывать два атрибута для одной лини/строки описания. Они вводятся через точку с запятой. Например "А1;А11" - обозначают два атрибута А1 и А11 в блоке штампа. Все изменения в таблице сразу вносятся в закладки "Файл WDL", "Файл WDP", "Файл WDT" - можно не сушить голову что и как, а просто редактировать одну общую таблицу. Если же отредактировать содержимое закладок "Файл WDL", "Файл WDP", "Файл WDT", то все изменения сразу вносятся в таблицу. Запись в физические файлы проекта выполняется отдельной кнопкой "Сохранить изменения".

- Добавил возможность выбора цвета при рисовании "паука"- схемы внешних кабельных проводок. Удобно когда обновляешь старые чертежи - видно где что-то поменял.

- Не до конца окрашивались кабели при прорисовке клемника с нарезкой в А3. Исправил.

- Всякие мелкие улучшения по всей программе

---- Version 25.42, Release 640, Build 1157 ----------------

- Исправил неточность в назначении типов клем, иногда сбоило, теперь все хорошо.

- Всякие мелкие улучшения по всей программе

---- Version 25.42, Release 639, Build 1154 ----------------

- исправил ошибку при прорисовке подключения кабеля - если кабель идет "в никуда", то в имени блока кабеля были знаки вопросов и акад выдавал ошибку

- поправил сортировку в таблице жил кабеля - если кабель не подключён или подключён к другому шкафу частью жил, то происходил сбой

- изменил сортировку при прорисовке подключения кабеля - теперь последовательность клемм соответствует как в редакторе, ранее они сортировались по порядку

- поправил прорисовку низа шкафа при прорисовке подключения кабеля - если есть следующий шкаф, то обрезался низ. Хотя это явная ошибка - жилы кабеля должны идти только в один шкаф (Loc).

- Добавил "разбивку" чертежей по рамкам в отдельные файлы и автоподключение в проект для всех чертежей проекта

- Всякие мелкие улучшения по всей программе

---- Version 25.40, Release 636, Build 1126 ----------------

- исправил ошибку: если в проекте был "неправильный" кабель, с ошибками, то проверка "штанов" вызывала сбой

- добавил в схемы подключения кабелей тип и длину

- поправил сортировку в таблице кабелей

---- Version 25.40, Release 635, Build 1120 ----------------

- основное и самое важное изменение - полностью переписал ядро программы, изменил логику представления данных получаемых из автокада. Это позволило исправить некоторые ошибки и немного замедлило процесс считывания проекта ибо информации стало считываться гораздо больше :(

- исправил ошибку: не переключался язык при форматировании таблицы ВОМ и "шапка" всегда была на украинском языке.

- исправил ошибку: если блок элемента содержал несколько точек подключения, то при прорисовке подключения кабеля и в таблице соединений указывалась только одна точка подключения, остальные "терялись".

- создал закладку с перечнем элементов - заготовка готова, но пока думаю что с ней делать.

- добавил фильтры в дерево клеммников, "причесал" существующие

- добавил выбор условий по которым производится контроль "плохого" кабеля

- изменил закладку "Утилиты" добавил кнопки вызова утилит. Теперь по нажатию на кнопку открывается соответствующая панелька.

- использовал другой менеджер памяти... должно быть чуток побыстрее.

Желательно сохранить предыдущую версию - если вдруг вылезут ошибки в новой версии :)

---- Version 20.37, Release 381, Build 1020 ----------------

- Переработал функции очистки чертежей в разделе "Подготовка для заказчика". Полностью переработал алгоритм взрыва блоков и заливки цветом. Теперь есть два варианта: взрывать при помощи lisp программы (по умолчнию, очень быстро) и взрывать старым методом, перебирая блоки из программы (очень медленно).

На тестовом файле с 30 тыс элементов новый метод показал скорость 20 сек, старый 3 минуты 37 сек.

Небольшое описание можно посмотреть здесь

---- Version 20.36, Release 380, Build 1010 ----------------

- Добавил кнопку "Сортировка по номерам". Думаю очень полезная кнопка.

Допустим есть старый проект, в котором клеммы отсортированы по номерам. В текущей и последующих версиях программы при просмотре этого проекта в клеммниках (вполне возможно) будет каша и придется заново сортировать каждый клеммник. Это затруднительно, если клеммников много - может занять значительное время.

Эта кнопка назначает сортирует и назначает порядок по старинке, по номерам клем. Она будет открывать по очереди каждый выбранный клеммник и сортировать по номерам все клеммы. После такой обработки старые проекты будут открываться и смотреться нормально в текущей и последующих версиях программы.

Видео как использовать: https://youtu.be/DYRjT7_HJiY

- Изменил прорисовку клеммников из выбранной группы шкафов.

- Всякие мелкие улучшения по всей программе

---- Version 20.35, Release 380, Build 1003 ----------------

- Поправил вывод клемника в автокад. На экране все прекрасно работало, но при прорисовке в автокад клемник все равно сортировало по старому. Поправил.

- Обнаружил сбой при заполнении фильтров в дереве кабелей. Если кабель был без начала или конца (проводник с обозначением кабеля начинается на элементе, но не касается другой стороной какого либо элемента) то в фильтр он не попадал. "Правильные" кабели поадают в список нормально. Ни на что более не влияло.

- Всякие мелкие улучшения по всей программе

---- Version 20.35, Release 380, Build 1000 ----------------

- Полное обновление работы с клемником - теперь идет сортировка не по номерам клемм, а по внутренним номерам, как сделано в Автокаде. Очень настоятельно рекомендую сначала прочитать ХЭЛП в разделе "философия клеммника" - там не много читать, но убережет от многих ошибок. Очень рекомендую посмотреть в хэлпе описание , как мог подробно делал.

Так же сделал маленькое видео о том как обновлять клемники - рекомендую ознакомиться

- Всякие мелкие улучшения по всей программе

---- Version 20.28, Release 380, Build 986 ----------------

Поправил редактирование клеммников

Немножко причесал функции и добавил удобства:

- добавил сортировку потребности кабелей

- добавил сортировку полей "от" и "до" в кж - что бы всегда было одинаково привыводе на печать - удобно сравнивать. Делаю так:

1. Беру старый КЖ, сгенерированный программой и делаю его желтым (ярким)

2. Устанавливаю по цвет умолчанию для чертежа - синий или темно-серый (главное - темный)

3. Создаю КЖ - он рисуется поверх старого и если есть разница - видна как на ладони.

- при старте вывода КЖ создал новый лист если нет ни одного активного

- ввел задержку 1,5 сек при наборе фильтра кабелей, шкафов и клемников.

То есть если надо отфильтровать кабели типа "1Т-" то набираем и ничего не происходит - программа ждет окончания ввода и ппосле ввода последнего фильтра срабатывает. Мелочь но удобно чертовски если много кабелей. Ранее срабатывала пересборка после каждого введенного символа.

- изменил алгоритм заполнения комбобоксов фильтра кабелей. Тут могут быть глюки. Я как бы проверил все и на возможных вариантах, но если найдете, то напишите.

- в дерево клемников ввел INST - были варианты когда два и более человеков рисуют проект и у одного зона одна (например ОРУ-ШКАФ1) а у другого похожее (например КРУ35-ШКАФ1) и тогда эта зараза складывает все клемники в один шкаф, хотя это разные. Поправил.

- добавил распечатку при выборе зоны в дереве клемников

- Всякие мелкие улучшения по всей программе

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Описание основных моментов

Для правильного и эффективного использования программы необходимо чётко уяснить себе как организована работа программы с AutoCAD Electrical.

Программа работает только с проектами настроенными в режим «Режим комбинированных поз. обозн. функц. группы/места».
Далее поясню что это значит (очень рекомендую дочитать до конца).

AutoCAD Electrical позволяет настроить в свойствах проекта два возможных режима: простой и с использованием кодов функциональной группы и места. Второй режим чуть сложнее, но позволяет гибко организовывать структуру и группировку элементов схем в проекте.

Например – вы создаёте схему какого-то одного шкафчика управления. Только «внутренности», без внешних связей и подключений. Тут удобно использовать простейший режим – все элементы имеют сквозную нумерацию в пределах проекта (KL1….KL32). Вам в принципе все равно как называется шкаф. Вы любым способом укажете что все элементы схем расположены внутри этого шкафа.

Или такой пример – вы создаёте какую-то схему управления оборудованием. То есть, у вас уже несколько шкафов. И в каждом шкафу может появится своё реле KL1. Но надо понимать, что AutoCAD Electrical не умеет как человек «два считаю - три в уме». Если вы нарисуете два реле KL1 то он воспримет это как ОДНО реле - имена то совпадают.

Вот для этих целей и существует режим с использованием кодов функциональной группы и места. В этом случае от вас потребуется указывать ещё два элемента в обозначении и реле KL1 будет называться так:

ЦЕХ №1 – Шкаф управления №1 - KL1

таким образом у вас в проекте уже может быть несколько реле KL1 с одинаковым именем и все будет хорошо, АЭ разберётся что они разные – у них в именовании будет указано разное расположение:

ЦЕХ №1 – Шкаф управления №1 - KL1

ЦЕХ №1 – Шкаф управления №2 - KL1

ЦЕХ №1 – Шкаф управления №3 - KL1

…. и т.д.

Эти свойства элемента сохраняются в атрибутах INST (Функц. группа) и LOC (Место) родительского/базового блока элемента на схеме.

В принципе AutoCAD Electrical глубоко глубоко фиолетово как вы используете эти поля.

Однако для работы с программой должно быть жёстко задано:

INST – любое обозначение зоны/группы расположения шкафа, любая группа шкафов. Например, «ОРУ 110 кВ» или «ЦЕХ дойки коров №1». Это на ваш выбор – как вы видите структуру проекта, так и делайте. ЖЕЛАТЕЛЬНО – не оставлять это поле пустым. Наберите там хоть что ни будь.

LOC – любое обозначение ШКАФА!!!!

Понятие «шкаф» вообще-то общее – это то место/коробка/ящик, где установлены все ваши клеммники, реле, лампочки, ключи, датчики (в общем вся хрень, составляющая внутренности шкафа). Это может быть как какая-то НКУ, так и сам прибор.

И, самое главное, «шкаф» это место где оканчиваются кабели. И эта программа контролирует если часть жил кабеля пошли «не туда».

Например – трансформатор тока 110 кВ. Он стоит сам, один одинешенек, на ОРУ и оборудован клеммной коробкой для подключения кабелей. Как его показать на схеме если у него нет шкафа? Делается это просто. Создается элемент с обозначением:

ОРУ110кВ – ТА1 – ТА1

Теперь на ОРУ есть «шкаф» с обозначением «ТА1» содержащий внутри себя элемент «ТА1». Такое решение позволяет приводит все возможные элементы к типовому представлению – то что подключается при помощи кабеля представляет из себя ШКАФ/ЯЩИК/КОРОБКУ.

При открытии проекта АЭ каждый раз создаёт временную базу данных (записную книжку) в которую вносит всю информацию, которую считывает из всех чертежей входящих в проект.

Удаление этой БД не приводит ни к каким катастрофическим результатам. Мало того это полезно при обнаружении различных глюков, которые не лечатся ничем - даже полное обновление БД или создание заново не устраняет эти глюки. Просто в случае отсутствия БД он её создаст заново. Отсутствие ошибок в БД это основа нормальной работы в АЭ.

Поэтому работая с АЭ надо учитывать эту специфику.

Последовательность действий такая:

Изменение чертежей -> Обновление базы данных АЭ -> Считывание базы данных программой -> Анализ считанного -> и в начало: Рихтовка, внесение изменений в чертежи и т.д.

И так по кругу до полного искоренения ошибок.

Любое изменение в чертежах приводит к изменению базы данных. Поэтому для просмотра актуальных и корректных значений необходимо перед считыванием базы данных обновлять её. Кнопка выглядит так:

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Алгоритм работы с программой

Дело в том, что многие пользователи имеют не полное представление, как организован внутри AutoCAD Electrical и из-за этого не представляют, как его эффективнее использовать, и, следовательно, как правильно пользоваться этой программой в связке с AutoCAD Electrical.

Поясню. AutoCAD Electrical - это не реал-тайм система. Совсем. Из-за специфики реализации она не сразу реагирует на изменения в чертеже. Что бы она что-то сделала её надо «пнуть». Например: вы поменяли марку провода на первом листе и провод через ссылку уходит на другой лист в продолжение схемы. Но на другом листе автоматически НИЧЕГО не поменяется. для этого необходимо запустить команду обновления ссылок.

Поэтому алгоритм такой:

Комментарии:

1) без работающего Автокада никакие манипуляции с чертежами не получатся

2) Для учёта в базе данных актуальных изменений и, соответственно, корректного отображения в программе проект должен быть активным

3) Обновление базы данных - залог корректных данных в программе, она оттуда считывает их

4) Открытие проекта описано тут

Тут начала бесконечного цикла "корректирую-смотрю что получилось" :)

5) Рассматриваем текущее состояние - связи, кабели, клеммники и т.д.

6) Под манипуляциями я понимаю все что меняет проект: редактирование/ создание/ удаление чертежей, изменение порядка чертежей, переименование, перенумерацию ит.д.

7) Это можно делать как из программы (например перенумерацию, создание/обновление клеммников и прочее) так и изменения чертежей в самом AutoCAD Electrical. Изменения при помощи программы все равно производятся через функции AutoCAD Electrical.

8) Пере открытие с обновлением - то есть нужно обновить базу данных проекта и считать заново её в программу

и снова в начало - рассматривать что получилось в результате рихтовки

Created with the Personal Edition of HelpNDoc: Make CHM Help File Creation a Breeze with HelpNDoc


Идеология работы с несколькими проектами

Если есть ОДИН проект, то у него ОДИН шифр проекта и соответственно ОДНО название. AutoCAD Electrical в принципе не умеет объединять несколько проектов в один проект, или учитывать связи между ними.

И исходя из этого есть два варианта:

- использование общих чертежей

- использование общего проекта

В первом варианте создается готовый чертеж или группа чертежей, со всеми рамками и т.д. (например схема привода выключателя, или схема типового ящика освещения, или еще какая-то типовая схема). Чертежи должны быть подготовлены к подключению в проект - все ссылки (приемники или источники) должны иметь уникальные номера. Все это хозяйство складывается в отдельную папку. Далее при разработке проекта, в проект подключаются эти чертежи БЕЗ ПЕРЕНОСА чертежей в папку проекта. Настраиваются ссылки в проекте - они должны браться из подключаемых чертежей. И вуаля - все работает. Перед печатью штамп должен быть обновлен и все номера проводов и ссылки должны быть обновлены.

Я делаю обычно так: есть в одной общей папке типовые схемы приводов. Я их оборудовал кучей ссылок (приёмники), с уникальными номерами ссылок, тщательно "причесал" схемы. Далее в проекте я подключаю файл БЕЗ ПЕРЕНОСА в каталог проекта. И привязываю к источникам ссылки, но номер ссылки беру из ПРИЕМНИКА, то есть с типового чертежа и этот номер загоняю в стрелку источник. Далее проверяю тип штампа (бывают в оформлении отклонения) перенумерую все листы, обновляю штампы, потом обновляю ссылки по всему проекту. Печатаю. Далее беру следующий проект и повторяю.

Во втором случае обычно стоит задача разработать один проект состоящий из трех и более подпроектов (для примера - один контракт на три разных объекта, но связанных между собой в один какой-то комплекс). И все эти подпроекты имеют разные шифры проекта, разные наименования и т.д. То есть должны быть ссылки между подпроектами.

Решить эту задачу можно только так:

- создается ТРИ подпроекта (или более) с разными рамками/штампами/названиями/шифрами

- создается ОДИН главный общий проект, в который подключаются просто копируем содержимое wdp файлов.

- разрабатывается последовательно все три подпроекта. При разработке создаются уникальные ссылки на другие проекты но которые в пределах подпроекта "висят в воздухе" - они сами свяжутся автоматически после в общем проекте. Понятно что номера в ссылках должны совпадать в разных проектах - за этим нужно следить вручную или переключаться на общий проект и связывать источники с приемниками. Необходимо следить чтобы номера ссылок в каждом проекте имели уникальную для этого проекта метку - чтобы не пересеклись с ссылками в других подпроектах. Например: SIG123456-ОБ01, SIG123456-ОБ02, SIG123456-ОБ03

- оформляем подпроекты и создаем локальные перечни чертежей.

- в общем проекте делаем обновление этих межпроектных ссылок. Ссылки должны быть необычные, с указанием кода проекта на который ссылаются (это можно сделать при помощи подстановочных символов)

- Нумеруем рамки сквозной нумерацией ЛИСТОВ (не штампов) в правом верхнем углу рамки (это же один проект, а не три разных).

- Оформляем перечни чертежей в общем проекте (локальные не трогаем). Печатаем.

Такой метод удобен и при разработке одного, но очень крупного проекта. Дело в том, что если количество листов переваливает за 300-500, то машина начинает не слабо тормозить - база данных проекта на движке mdb не шибко шустрая. Я бы даже сказал что очень не шустрая. Частично проблему скорости можно решить разместив проект на SSD диске. Но кардинально решается созданием отдельных микропроектов для отдельных частей основного проекта. Например делаем подстанцию и в ней несколько линий со своими защитами и т.д. Берем и создаем проектик для первой линии, еще один для второй, еще один для защит АТ и т.д. Эти маленькие проектики будут просто летать. Но в конце, когда все будет законченно, все равно придется работать с основным большим проектом - нумеровать, обновлять штампы, обновлять ссылки и т.д.

Created with the Personal Edition of HelpNDoc: Why Microsoft Word Isn't Cut Out for Documentation: The Benefits of a Help Authoring Tool


Начинаем

Для начала программу нужно скачать/скопировать из интернета к себе на жёсткий диск в какую ни будь папку (желательно куда нить в инструменты, хотя не принципиально) и просто запустить.

Какая-то особенная установка не требуется. Просто запускаем. Все необходимое - шрифты, настройки принтера и прочее программа несёт внутри себя и распаковывает при необходимости или по команде пользователя.

Программа при первом запуске дополнительно скачает этот файл хэлпа в формате CHM из интернета. Каких либо дополнительных настроек не требуется ввиду простоты и неприхотливости программы.

Есть вариант скачать хэлп в формате ".docx" , "epub" и ".pdf" .

Ссылки для скачивания:

  • Основной сервер
    (мой локальный и возможно не всегда доступный сервер на базе "апельсинки")
  • Резервный сервер
    (импортный, где-то в облаке, и всегда доступный сервер)
  • Autodesk Appstore
    (там еще старая версия, она захочет пару раз обновиться - обновляйтесь смело)
  • Резервный сервер №2
    (расположен в стране-оккупанте и там не обновляется, но сама программа обновится с других серверов)

Далее идем по шагам описанным в разделе "Быстрый старт"

Created with the Personal Edition of HelpNDoc: Easily convert your WinHelp HLP help files to CHM with HelpNDoc's step-by-step guide


Системные требования

Системные требования минимальны:

  • компьютер с монитором (желательно большим, а лучше два больших);
  • операционная система Windows ХР, 7, 10 или выше (любая, 32/64 разрядная);
  • установленный AutoCAD Electrical версий 2012 - 2025;
  • мышка (хвостатая или без - не принципиально);
  • соображалка и прямые руки желательно из плечей;
  • минимальные понимания как работать в AutoCAD Electrical;
  • стальные нервы, кофе/пиво по вкусу.

Created with the Personal Edition of HelpNDoc: Leave the tedious WinHelp HLP to CHM conversion process behind with HelpNDoc


Обновление программы

Обновление проходит в полностью автоматическом режиме. Но можно и вручную скачать с сервера новую версию. Обновления программы выкладываются на трех серверах:

  • Основной сервер (домашний)
  • резервный сервер №1 (облако)
  • резервный сервер №2 (на сервере страны оккупанта - мне он уже не доступен, сейчас там устаревшая версия, но можно скачать и при запуске программа обновится с других серверов)

Проверка наличия новых версий - полностью автоматический процесс.

При запуске программы через пару секунд в фоновом режиме (то есть не тормозит саму программу) осуществляется запрос на все сервера и проверяется наличие новой версии.

Если на каком-либо из серверов будет обнаружена более новая версия чем текущая, появится информационное окошко с описанием новой версии и запросом дальнейших действий:

Если выбрано обновление программы, основное окно программы закрывается и запускается процесс скачивания новой версии:

При удачном окончании процесса загрузки старая версия программы будет переименована в резервную копию с указанием номера версии. Скачанная новая версия будет иметь то же имя, что имела предыдущая версия.

Для принудительной проверки наличия новой версии предназначена кнопка: . Нажатие на неё инициирует выше приведенную последовательность обновления. При этом на время проверки новой версии кнопка исчезает - ее отсутствие есть признак процесса проверки. Если проверка закончилась неудачно (нет интернета, нет новой версии, сервер "лёг", провайдер обанкротился, хуйло застрелилось и все набухались от радости, и так далее), то кнопка снова появится. Это сделано для того что бы не было нескольких запросов на сервер когда юзверь нервно кликает по мышке.

Для скачивания вручную можно открыть в любом браузере сайт программы и скачать по ссылке. Для облегчения поиска сайтов обновления необходимо нажать на кнопку: . При этом откроется вот такая панелька:

Нажатие на кнопки приводит к запуску браузера и открытию HTML странички.

Так же на панельке есть кнопки со ссылками на мой канал на ютубе и на микроблог .

На канале Youtube есть достаточно большой список видеороликов по основным функциям.

В блоге я выкладываю свои мысли, их не очень много )))

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Техническая поддержка

Пишите мне на мейлы: des501@bigmir.net или Des501@ukr.net

Я почту читаю не сильно часто, могу и день два не смотреть, работа все таки сильно отвлекает от глупостей :-)

Мои мысли можно почитать в блоге - https://project12-utilites.blogspot.com

Сорри, но по скайпу/тимсу/вайберу не провожу обучения. Так как программа бесплатная (иначе и не будет), максимум - могу дать пояснения как работать с моей программой и AutoCAD Electrical, естественно в меру своих ограниченных знаний.

В инете и так полно ресурсов насыщенных информацией. Я не посещал никаких курсов, изучал методом "научного тыка" и осваивая хэлп к AutoCAD Electrical.

Created with the Personal Edition of HelpNDoc: Eliminate the Struggles of Documentation with a Help Authoring Tool


Быстрый старт

Для приведения в исходное состояние выполняем следующие шаги:

  • запустить AutoCAD Electrical
  • запустить программу "Project12 - Utilities"
  • в AutoCAD Electrical открыть любой/нужный проект
  • в AutoCAD Electrical обновить базу данных проекта (кнопка "Восстановить/обновить базу данных проекта")
  • в программе найти и считать файл проекта "имя_проекта.wdp"
  • дождаться загрузки базы данных проекта и сортировки считанной информации (на больших проектах, с кол-вом листов под 300-500, где деталей и связей просто немеряно, загрузка может длиться минуты две-три).
  • для распечатки проекта - настроить шрифты и принтер (на закладке "Файлы проекта" нажимаем кнопку "Настроить принтер..."

Рекомендую посмотреть обучающие видео.
Более подробно показано тут: Видео "Открытие проекта"

Далее можно выполнить следующие действия:

(список не полный, постоянно добавляются новые "фичи")

  • просмотреть дерево файлов проекта, управлять описанием и набором файлов в проекте, корректировать файл проекта вручную;
  • разбить выбранный файл с кучей форматных рамок на отдельные чертежи и автоматически подключить их в проект;
  • просмотреть существующие связи между шкафами, обнаружить связи находящиеся не в кабеле, обнаружить связи/кабели идущие "в никуда";
  • нарисовать схему внешних кабельных проводок ("Паука") для выбранного шкафа;
  • просмотреть список использованных кабелей в проекте, отобрать кабели по типу;
  • проконтролировать "правильность" кабелей в проекте (соответствие количества использованных жил выбранному кабелю и т.д);
  • нарисовать схему внешних подключений выбранного кабеля/ всех кабелей;
  • рассчитать в автоматическом режиме длины кабелей и составить кабельный журнал;
  • просмотреть перечень клеммников в проекте;
  • отредактировать клеммник (переместить, перенумеровать, удалить клеммы, назначить в другой клеммник и т. д.);
  • экспортировать перечень клемм в ClipProject для проверки редактирования клеммника и получения спецификации клеммника;
  • просмотреть список чертежей в проекте, проконтролировать нумерацию штампов и нумерацию листов в томе;
  • нарисовать общие данные для всех или для выбранной группы листов;
  • заполнить счетчик листов для всех или для выбранной группы листов;
  • вывести на печать в формате PDF с разбивкой на форматы или без;
  • обновить ссылки на цепи (принудительно вызвать внутреннюю функцию АЭ обновления ссылок для каждого листа);
  • почистить чертежи - purge;
  • собрать (скопировать содержимое) выбранные чертежи проекта на один текущий лист;
  • создать "взорванную" копию проекта для передачи заказчегу.

Дополнительно при помощи набора утилит можно сделать (без считывания проекта) следующие операции с текущим чертежом:

  • распечатать с текущего чертежа все рамки, если проект не содержит блоков форматных рамок, то можно добавить невидимые рамки заданных форматов на чертеж и после распечатать;
  • "разбить" файл на отдельные файлы по блокам форматных рамок, собрать несколько файлов содержащих блоки форматных рамок на один текущий чертеж;
  • перенумеровать штампы и номера листов (в блоке форматной рамки);
  • "причесать" ВОМ - bill of material сгенерированный АЭ, то есть оформить согласно требованиям ЕСКД;
  • выбрать и расставить группу блоков в форматную рамку;
  • добавить перечень слоев АЭ на текущий чертеж или на все чертежи в проекте, задать слоям цвет;
  • нарисовать блоки форматных рамок, пустые или заполненные атрибутами для АЭ;

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Видеоуроки

Я веду небольшой канал на ютубе и использую его не только для создания видео рассказов о программе, но и записываю видео ответы для пользователей. Иногда проще показать, чем писать целый роман, который не факт что прочитают и поймут. Да и писатель из меня никакой.

Видеоуроки можно посмотреть здесь

Created with the Personal Edition of HelpNDoc: Effortlessly upgrade your WinHelp HLP help files to CHM with HelpNDoc


Раздел «Исходные»

Это начальная страница. На ней расположены кнопки выбора файла базы данных проекта, фильтра считанных данных, обновление программы и ссылки на страницы в интернете с описанием и видеороликами.

Внешний вид страницы:

Инструменты управления:

Кнопка выбора БД- отображает диалоговое окно выбора файла БД проекта для считывания.

После выбора файла БД полный путь отображается в строке и копируется в буфер обмена при щелчке по нему.

Если щелкнуть правой кнопкой мыши на кнопке во всплывающем меню отображается список предыдущих открытых проектов. Список сохраняется в обычном текстовом файле в каталоге пользователя Виндоус. Настраивается в панели "Настройки программы".

Кнопка - позволяет заново считать информацию из БД проекта без отображения диалогового окна.

- Переключатель "Обновить БД" - при нажатии на кнопку «Обновить» перед повторным считыванием текущего файла БД проекта вызывает внутреннюю функцию АЭ выполняющую обновление БД проекта. Так учитываются текущие изменения в чертежах.

- Переключатель "Полное" - при нажатии на кнопку «Обновить» перед повторным считыванием текущего файла БД проекта вызывает внутреннюю функцию АЭ выполняющую полное обновление БД проекта - долго но зато все с нуля.

Кнопка [image] - открывает окно утилиты для выбора/создания/настройки текстового стиля, применяемого во всем проекте.

Кнопка [image] - открывает менюшку настроек всей программы и выбора драйвера БД. Описание тут.

Кнопка [image] - позволяет проверить наличие обновлений на серверах и обновить программу.

Кнопка [image] - открывает панель с ссылками на страницы Ютуба и сайт программы в интернете.

- Анимированный рисунок государственного флага независимого государства Украина – дуже бісить 'баних окупантів, комуняк, ватників і сепарів, радує око щирим українцям та адекватним людям з мізками. :)

Строка состояния отображает часики, краткое описание текущего действия и выводит «термометр» прогресса выполнения каких либо выбранных команд. По окончании выполнения операции выводится фраза «Готов» и прячется «термометр».

Переключатель языка [image] позволяет формировать выходные документы на выбранном языке. Тут пока два языка, но это анахронизм. Со временем будет больше.

Переключатель [image] включает использование шрифта "WWCADE", иначе используется текущий шрифт. Про вввкаду можно спорить долго и нудно. Не самый файный шрифт. Однако он и ЕСКД-шный и узкий. Для схем самое то. И я к нему привык. :)

Но есть еще куча шрифтов, которыми пользуются в других организациях и там разработчики привыкли к ним. Их можно выбрать основным шрифтом для рисования. Сейчас же, если отжата кнопка "WWCADE", то программа не назначает и не проверяет наличие этого шрифта, просто рисует текущим шрифтом по умолчанию для чертежа. Так что просто делайте текущим нужный стиль шрифта, отжимайте кнопку и все будет написано в вашем стиле. Однако все блоки должны быть откорректированы под использование вашего шрифта - может быть ширина разная и текстовые надписи повылазят за рамки.

После считывания проекта на закладках доступна следующая информация:

- Закладка "Чертежи проекта" содержит дерево проекта - перечень чертежей подключенных в проект и отсортированных в виде дерева, точно так, как расположено в проекте АЭ;

- Закладка "Настройки проекта" содержит таблицу атрибутов в блоке штампа, их обозначеними в меню и их заполнением;

- Закладка "Файл WDP" показывает сам файл <имя проекта>.wdp и позволяет его редактировать;

- Закладка "Файл WDT" показывает сам файл <имя проекта>.wdt и позволяет его редактировать;

- Закладка "Файл WDL" показывает сам файл <имя проекта>.wdl и позволяет его редактировать.

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Открытие проекта АЭ

Для открытия проекта AutoCAD Electrical необходимо найти и открыть файл проекта. Файл проекта всегда имеет следующий формат имени:

<имя проекта>.wdp

Более наглядно открытие проекта показано тут: Видео "Открытие проекта"

Перед открытием необходимо в обязательном порядке ОБНОВИТЬ базу данных проекта. На картинке показано как это сделать.

Боле подробно читаем тут .

Выбор файла осуществляется нажатием на кнопку: - и в открывшемся диалоговогом окошке выбора файла выбираем нужный файл:

При удачном открытии проекта имя файла проекта (и полный путь к нему) сохраняется в реестре. При последующем вызове диалогового окна выбора файла проекта открывает последний каталог из которого производилось чтение файла проекта.

После считывания файлов проекта (wdp, wdt и т.д.) программа автоматически производит поиск файла базы данных проекта с расширением MDB. Он хранится глубоко в "недрах" каталогов AutoCAD Electrical.

Есть нюанс - если создать новый проект с ОДНИМ чертежом или вообще без чертежей, то файл mdb вообще не создаётся. Он пока что не нужен автокаду, он будет создан позже по мере необходимости.

Если файл базы данных проекта по каким либо причинам не будет найден, то будет отображено предупреждение и показано окно ручного выбора файла <проект>.mdb. Вполне вероятно что программа не смогла найти стандартный путь к хранилищу и тут необходимо ей помочь, указать каталог где хранятся базы данных проектов.

В случае невозможности найти файл базы данных проекта загрузка проекта будет прервана.

После загрузки пути к найденным файлам и название проекта будут отражены на панели:

Если щёлкнуть мышкой по названию, то содержимое строки будет скопировано в буфер.

В случае необходимости повторного считывания проекта нужно воспользоваться отдельной кнопкой "Обновить". Это основная кнопка после внесения изменений в чертежи. При этом происходит закрытие, а потом открытие проекта заново. Если установлен какой либо из переключателей, то дополнительно производится обновление базы данных проекта. Это в работе основная кнопка.

Дополнительные переключатели справа от кнопки позволяют выполнить обновление базы данных перед считыванием. Переключатель "обновить БД" управляет обновлением базы данных проекта. Если он установлен, то в АЭ передается команда выполнить текущее обновление. При этом в базу данных вносятся только текущие изменения. Если установлен переключатель "Полное", то в АЭ передается команда выполнить полное обновление базы данных. Полное обновление выполняется долго, иногда очень долго. Однако иногда это очень полезно - убирает 99% ошибок в БД.

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Про базу данных проекта

Небольшое пояснение про базу данных проекта, что это за хреновина и зачем она нужна:

AutoCAD Electrical сохраняет всю информацию о проекте в так называемой Базе Данных (БД) проекта. Файл БД проекта в формате mdb, создаётся и обновляется каждый раз при открытии проекта и/или при внесении изменений в какой либо чертёж. В начале при создании проекта "с нуля" БД отсутствует. Она создается AutoCAD Electrical по мере необходимости.

Лирическое отступление: Вообще надо понимать, что это не совсем файл базы данных проекта - это, я бы назвал, "записная книжка" проекта. Ее удаление не приводит ни к каким последствиям, окромя потери небольшого времени при запуске AutoCAD Electrical и открытии проекта. В это время AutoCAD Electrical заново просмотрит все чертежи, которые входят в проект, и заполнит необходимые таблицы в базе данных. Все эти манипуляции обеспечивают ему тот минимум функциональности, который позволяет этому набору макросов гордо назваться "полноценной автоматизированной средой разработки". Благодаря тому, что в таблице собирается и концентрируется вся информация о блоках/элементах на всех чертежах, есть возможность считать эти таблицы и представить в удобном виде для анализа. В AutoCAD Electrical тоже есть такая функция... но, как бы помягче сказать, она не совсем удобна.

Правило: перед каждым открытием проекта необходимо обновлять БД проекта при помощи команды AutoCAD Electrical "Восстановить/обновить базу данных проекта"

Иногда при длительной работе с проектом, содержащем большое количество чертежей, сталкивался с необъяснимыми артефактами, которые не исправлялись даже при полном обновлении БД проекта. например он решает что какой то номер марки проводника уже есть. Или появляются ранее отсутствовавшие элементы из ниоткуда....

Лайфхак - закройте AutoCAD Electrical, закройте мою прожку и удалите руками нах ту базу данных. При запуске БД заново создастся и все будет ок.

Сам файл базы данных проекта как правило лежит в папке:

  • C:\Users\<Имя пользователя>\AppData\Roaming\Autodesk\AutoCAD Electrical 2017\R21.0\rus\Support\User\ (для АЕ 2017 )
  • C:\Users\<Имя пользователя>\AppData\Roaming\Autodesk\AutoCAD Electrical 2018\R22.0\rus\Support\User\ (для АЕ 2018).

Created with the Personal Edition of HelpNDoc: Streamline Your Documentation Creation with a Help Authoring Tool


Настройка текстового стиля проекта

Когда рисуются выходные документы (схемы внешних подключений, форматные рамки, кабельный журнал и т.д.) нужно определить каким текстовым стилем будут выводится текст. Как правило на каждой фирме есть свой сложившийся внутрифирменный "стандарт" оформления. В том числе и требования к текстовому стилю.

Я давно пользуюсь стилем WWCADE. Хз откуда он появился на нашей фирме, но я к нему привык. Он почти похож на ЕСКДшный шрифт, узенький, но, к сожалению, имеет ряд дыбильных заморочек (~220V - не получится нарисовать, тильда рисуется какой-то херней). Однако ничего не вечно. И со временем мы стали рисовать другими стилями, которые пришли или от заказчика, или от первичников... Не суть важно. Главное нужно было перестроить вывод под задаваемый стиль. Сделано. Теперь есть возможность выбрать любимый стиль и пользоваться им.

Для начала, когда нет никакого выбранного текстового стиля проекта, используется по умолчанию WWCADE. Это данность и неизменно, он зашит в программу и автоматом устанавливается при настройке принтера. В последствии необходимо нажать на кнопку [image] и откроется окно утилиты для настройки стиля:

Интерфейс прост как веник. Как видно можно считать стили с чертежа, выбрать какой-то и отрихтовать его. Большая кнопка "Использовать активный шрифт чертежа" считывает с активного чертежа настройки активного текстового стиля.

При открытии окна утилиты делается копия текущих настроек проекта, этакая рабочая копия стиля для рихтовки, стиль проекта не трогается. Далее можно творить все что угодно с указанным стилем.

Для сохранения откорректированного стиля предназначена кнопка "Применить и выйти". При ее нажатии откорректированный стиль копируется в стиль проекта и окно закрывается.

Кнопка "Сброс к исходным" затирает текущие настройки стиля и считывает стиль из проекта.

Кнопка "Настроить WWCADE" ессно настраивает стиль WWCADE (С)Кэп.

Можно кнопкой [image] считать из текущего чертежа автокада все доступные стили. Их перечень будет в выпадающем списке под кнопкой. Выбрав в списке какой-то стиль нажимаем кнопку "Выбрать" и его настройки перенесутся в соответствующие полях.

Кнопка "Отмена" просто закрывает окно.

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Подраздел «Чертежи проекта»

На этой страничке расположено дерево чертежей в том порядке как они расположены в проекте АЭ. Выбирая файл можно оперативно изменить его параметры внося изменения в соответствующие поля.

Внешний вид закладки:

Все изменения полей могут быть изменены и в самом файле WDP ( закладка "Файл WDP" ) но для этого нужно знать структуру описания файла в проекте.

Важно: Поле "Описание 1 (OPIS1)" - это наименование чертежа, содержимое этого поля будет внесено в штамп на чертеже при обновлении основной надписи.
Остальные два поля "Описание 2 (OPIS2)" и "Описание 3 (OPIS3)" - это просто поля описания чертежа которые облегчают навигацию по дереву чертежей и заполняются как угодно.

Инструменты управления:

Кнопка открывает выбранный файл в Автокаде

Кнопка открывает Проводник и находит/выделяет выбранный файл

Группа "Разделение по форматным рамкам".

Подробное описание механизма разделения находится тут .

Для обработки можно выбрать как текущий файл, так и выбрать из перечня чертежей в проекте. Сами кнопки ничего конкретного не делают - их задача перенаправить на соответствующую закладку ( сюда ) и выбрать в списке текущий файл.

Смысл "разделения" прост - вы рисуете схемы на отдельных чертежах, настраиваете ссылки, разбиваете получившиеся схемы по форматным рамкам. И так по всему проекту - он будет представлять из себя кучу файлов которые содержат по несколько форматных рамок. Теперь необходимо разбить эти чертежи на отдельные - по одной рамке на чертёж. Можно делать вручную - нажимать последовательно "Копировать в ..." как показано на картинке [image] и потом вытирать ненужное.

Но когда в проекте около 50 листов которые рассыпаются на 300-600 листов... Нужна автоматизация. Вот это и делает эта кнопка.

Программа откроет файл и будет искать форматные рамки. Если количество рамок больше чем одна, то запускается процесс "разделения" файла на несколько. Рамки сортируются, Делается копия файла с ОДНОЙ рамкой, под исходным именем с добавлением счётчика "_001", "_002" и т.д. Сохраненные файлы подключаются в проект на место исходного файла. При этом в поле рамки будет найден штамп и считаны поля "OPIS..." - они являются названием чертежа и это название будет автоматически добавлено в проект. Сам оригинальный файл будет сохранен под именем <Исходное имя>_ALL.dwg

Важно: Все что находится ВНЕ форматных рамок - не будет перенесено во вновь создаваемые чертежи и будет потеряно. Эти элементы при необходимости можно перенести вручную на чертежи.

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Подраздел «Настройки проекта»

На этой закладке расположена таблица для заполнения полей в штампах. Смысл этой таблицы - собрать в одном месте все настройки проекта и автоматизировать их редактирование.

Внешний вид закладки:

Эта таблица повторяет таблицу настроек описаний проекта, которую можно вызвать из стандартного меню:

В поле "Атрибут" указаны имена атрибутов в блоках форматных рамок/штампов, которые будут заполняться AE при вызове команды заполнения штампов.

Важно понимать что логика заполнения штампов такова:

- есть набор строк "LINEхх" или в русифицированном меню "Строка хх", которые содержат то что нужно внести в штамп и вообще в оформление, любая информация. содержимое этих строк сохраняется в файле "<имя проекта>.WDP"

- есть штатное меню настройки описаний проекта - вызывается через меню, см. выше.
- есть файл "<имя проекта>_wdtitle.wdl" в котором объявлены названия строк в меню. Если это файла нет или он пустой то в меню будут выведены только номера строк:

Это меню позволяет просто назначить строке какое-то значение.

Как использовать необходимо описать в файле "<имя проекта>.WDT"

- есть файл "<имя проекта>.WDT" который сопоставляет конкретные линии с конкретными атрибутами в штампе, по имени блока штампа и по имени атрибута.

- когда запускается автоматическое обновление штампов, АЭ открывает файл WDT и ищет там определение блока: "BLOCK = <имя блока>"

Я для себя принял и записал в программу что имя блока штампа всегда начинается (лучше) или содержит строку "PageESKD" - тогда программа находит этот блок, и по умолчанию поисковая строка будет такая: "BLOCK = PageESKD*". То есть будут найдены все блоки с, например, такими именами: PageESKD_УКР, PageESKD_А0 и т.д. Далее ищется на каждом выбранном для обновления чертеже подходящие по имени блоки и проверяются там доступные атрибуты. Если они найдены, то ищутся совпадения в определениях файле WDT: <Имя атрибута> = LINEхх

И если будут найдены правила, то будут заполнены атрибуты содержимым соответствующей строки LINExx

Для оперативной корректировки наименований блоков форматной рамки чертежа и наименования блока главной надписи (штампа) есть два поля:

Для удобства, чтобы не лазить по файлам настроек, я собрал все в одну таблицу "Настройки проекта". Все изменения в таблице сразу заносятся в текстовые поля на закладках "Файл WDT", "Файл WDP", "Файл WDL". Для изменения файлов на диске необходимо нажать кнопку "Сохранить изменения".

Created with the Personal Edition of HelpNDoc: Elevate your documentation to new heights with HelpNDoc's built-in SEO


Подраздел «Файл WDP»

На этой закладке расположен простенький текстовый редактор. При открытии/считывании проекта в него считывается сам файл WDP. Иногда это удобно - отредактировать вручную список файлов, добавить новые файлы или изменить какие-то поля. В общем на любителя.

Мощное описание формата файла WDP находится тут , в базе знаний AUTODESK KNOWLEDGE NETWORK. Очень рекомендую прочитать его перед какой-либо корректировкой самого файла WDP - последствия могут быть весьма забавные - от перестановки названий до исчезновения чертежей из проекта.

Внешний вид закладки:

Группа инструментов содержит следующие кнопки:

Кнопка "Сохранить изменения" - записывает в файл <Имя проекта>.WDP текущее содержимое редактора и корректирует остальные закладки. Но все таки рекомендую обновить базу данных и заново открыть проект. Хорошо под это дело подходит кнопка "Обновить"

Переключатель "Сделать резервную копию" - если установлен, то при сохранении будет создана резервная копия файла проекта с расширением "bak".

Кнопка "Сброс" - заново заполняет поле редактора исходным содержимым файла WDP. Происходит не считывание файла с диска, а заполнение сохраненной копией при открытии проекта.

Кнопка "Разделить группы чертежей" - выполняет вставку в редакторе пустых строк между группами параметров, которые относятся к отдельному чертежу. Таким образом визуально отделяются отдельные чертежи и облегчается навигация при значительном количестве чертежей.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Подраздел «Файл WDT»

пока нет :-(

Created with the Personal Edition of HelpNDoc: Simplify Your Help Documentation Process with a Help Authoring Tool


Подраздел «Файл WDL»

пока нет :-(

Created with the Personal Edition of HelpNDoc: Easy Qt Help documentation editor


Настройки программы

Для настройки программы есть отдельное окошко.

Из нее можно настроить:

- стиль оформления

- тип драйвера базы данных

- язык интерфейса программы (пока не работает, в процессе)

- выключить звуковые оповещения (бибикание)

- выбрать максимальное количество записей в выпадающем меню "Повторно открыть проект"

- создать иконку на рабочем столе

- настроить картинки на кнопках.

Внешний вид окна настроек программы:

Есть возможность отключения меню выбора ранее открытых проектов: если в настройках выставить равным нулю количество проектов отображаемых в списке меню, то меню вообще не будет отображаться. Всплывающее меню - правой кнопкой мыши на кнопке "Открыть проект".

Created with the Personal Edition of HelpNDoc: Transform Your Documentation Process with HelpNDoc's Project Analyzer


Раздел «Связи между элементами»

На этой странице приведены все связи между элементами которые есть в проекте, читай все проводники которые указаны в проекте. Количество записей может составлять десятки тысяч (типичное количество для проекта ПС 110 кВ с количеством листов около 300-500 составляет около 30-50 тыс). Навигация вручную по такому списку просто не реальна.

Для того что бы можно было отобрать необходимые связи (например по марке цепи, по источнику или приёмнику, по марке кабеля и т.д) предназначены фильтры собранные в группы. Набор инструментов для фильтрации данных расположен на панели фильтров, в верхней части закладки, и позволяет отфильтровать из списка проводников только те, которые необходимы для анализа. Например можно отобрать проводники с конкретной маркой или без неё, проводники принадлежащие какому-то кабелю, проводники идущие от конкретного шкафа и т.д.

На основании этой таблицы (используя считанные из БД проекта данные) создаются и работают другие инструменты расположенные на других закладках.

Внешний вид закладки:

Кнопка [image] - сбрасывает все установленные фильтры таблицы связей между элементами в исходное состояние.

Кнопка выводит в Эксель в виде таблицы перечень отфильтрованных связей которые отображаются в таблице. Переключатель "Полные названия" позволяет выводить в таблицу не сокращенные технические обозначения шкафов, а полное название описанное на закладке "Наименования". Читать как работает - тут . Нужно учесть что передача работает очень долго и на количестве связей более тысячи будет притормаживать и время вывода в Эксель будет более минуты. Например: на относительно старом ноуте i7, 8Gb вывод 13,5 тысяч записей составил почти 4 минуты.

При выводе получается что-то вроде этого:

Для отбора проводников по признакам предусмотрены следующие фильтры:
- группа «Провод/кабель» - отфильтровывает по марке кабеля и по номеру проводника;
- группы «Откуда» и «Куда» - отбирает проводники идущие из/в определенного места/шкафа, от определенного элемента и с определенной маркой;
- группа «Отбор связей» - отбор проводников которые идут только между шкафами или только внутри шкафа;
- переключатель "Оба направления" - позволяет отобрать оба направления вне зависимости источником или приемником является искомая точка подключения;
- кнопка "Сброс фильтров" - сбрасывает выбранные фильтры и отображает все связи в проекте.

Для каждого проводника в таблице показана следующая информация: откуда и куда идет, в каком кабеле является жилой, на каком чертеже находятся начало и конец проводника.

Например: выбирая связи только между шкафами и выбрав пустое поле в фильтре "Кабель" получим перечень связей не назначенных как жилы какого либо кабеля. То есть реально отслеживаются ошибки которые в процессе разработки схем невидны.

Контекстное меню:

Правой клавишей мыши можно вызвать контекстное меню для выделенной строчки в таблице:

При помощи меню можно оперативно открыть файл с чертежом (на примере лист №Р08 или №Р07) и перейти к элементу от которого начинается или где заканчивается проводник (в примере это клеммы шкафа №24 ХТ0:13 и шкафа №13 ХТ0:17). При выборе пункта "клемма шкафа 1: [ШКАФ №24]XT0:13" будет открыт в АЭ файл чертежа №Р08, найдена клемма XT0:13 и изображение клеммы будет выведено (с увеличением) в центр экрана .

При выборе кабеля "ED-29 [+EC1]" будет осуществлен поиск места где расположено обозначение этой жилы. Будет открыт чертеж и блок обозначающий метку кабеля на проводнике будет отцентрирован на экране с увеличением.

При выборе пункта "Перейти к кабелю ED-29 [+EC1]" будет осуществлен поиск и переход к обозначению кабеля в дереве кабелей на закладке "Кабели" . Фрагмент закладки показан слева, с открытым проводником в кабеле.

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Раздел «Ссылки в проекте»

На этой странице расположен перечень ссылок в виде дерева. Это позволяет оперативно просмотреть структуру ссылок и найти нужный блок ссылки на чертеже. Длина ссылок (как правило) не должна превышать 32 символа. Это ограничение накладывает внутренняя механика Автокада (длина полей в базе данных проекта ограничена 32 символами).

Внешний вид страницы:

Дерево содержит группы ссылок.

Обычно используется пара один источник -> один приемник. Но это не обязательно, приемников может быть несколько. Источник должен быть только один. Ибо только он выдает номер провода.

Развернув источник (плюсик возле метки) будут видны приёмники.

При выборе любого элемента в дереве ссылок, можно увидеть его параметры и перейти на страницу где она находится.

Так же можно отфильтровать по коду или типу ссылки.

Created with the Personal Edition of HelpNDoc: Elevate your documentation to new heights with HelpNDoc's built-in SEO


Раздел «Связи между шкафами»

На этой закладке отображаются все внешние связи между шкафами, как кабельные, так и без кабеля.

На закладке расположены дерево шкафов, управляющие кнопки и таблица связей. Так же отсюда можно нарисовать в АЭ схему внешних кабельных проводок (на моём жаргоне "Паук")

Внешний вид закладки:

Инструменты управления:

Переключатель структуры дерева шкафов, состоит из кнопок «Шкаф-Шкаф» и «Шкаф-клемник» - меняет режим построения дерева связей между шкафами.

Фильтр по имени шкафа. Проходит по дереву и отфильтровывает только те шкафы, которые содержат набранные символы.

Поле-кнопка перехода на закладку "Кабели". Если выделить в дереве кабель, то щелкнув по кнопке будет открыта закладка "Кабели" и найден в дереве кабелей выбранный кабель.

Кнопка выполняет рисование схемы внешних кабельных проводок на текущем открытом чертеже в АЭ.
Процесс создания подробно описан тут

Набор переключателей настройки рисования "паука".

  • переключатель «В рамку ЕСКД» - это главный переключатель. Он включает/отключает вписывание паука в форматную рамку при создании схемы внешних кабельных проводок. По умолчанию начальный формат А3.
    Если рисунок не помещается в А4 то будут выбраны большие форматные рамки.
  • переключатель «Начать с рамки А4» - меняет рамку по умолчанию на А4. Если рисунок не помещается в А4 то будут выбраны большие форматные рамки.
  • переключатель «Не подбирать форматные рамки» - отключает автовыбор форматных рамок в случае если паук не помещается или налазит на таблицу. То есть остается только два выбора форматных рамок А3 и А4.
  • переключатель «На новой странице» - принудительно создает новый чертеж в АЭ и выполняет создание схемы внешних кабельных проводок.
  • переключатель «Старый вар-т» - прорисовка немного по другому схемы внешних кабельных проводок (устарело, практичнски не используется).
  • переключатель «Запрос нач точки» - перед рисованием будет запрошена левая верхняя точка чертежа - необходимо будет щелкнуть мышкой в чертеж.
  • кнопка "Выбор цвета" - позволяет выбрать цвет для рисования. Удобно при контроле версий. На печать выводится черно-белым, конечно если выбраны цвета из стандартной палитры.

Далее расположена группа кнопок вспомогательных функций.

Кнопка «Перечень шкафов в память» - имена шкафов будут скопированы в буфер обмена.

Кнопка «Марки проводов в память» - марки проводов будут скопированы в буфер обмена.

Кнопка «Внешние подключения по КИПовски» - пока не работает :(

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Дерево внешних связей

При считывании БД проекта все связи между элементами сортируются, фильтруются и собираются в виде дерева «Шкаф-кабель-Шкаф» или «Шкаф-клемник-кабель-Шкаф». В процессе пользования программой стало со временем понятно, что вторая структура не имеет смысла и будет со временем удалена. Или нет - жрать не просит.

Все шкафы выстроены в дерево и отсортированы по названию. При раскрытии ветки шкафа открывается список шкафов к которым есть какие либо связи от текущего шкафа. При раскрытии ветки следующего уровня будут показаны все кабели которые соединяют эти два шкафа. При наличии "потерянных" проводников, не назначенных какому либо кабелю, они будут все собраны в одну группу с общим названием "не в кабеле". Просмотр дерева позволяет найти все потерянные проводники и назначить их в кабель.

В заголовке дерева стоит отдельная группа с названием «(???)». В эту группу будут сведены все связи у которых нет второй точки подключения. То есть например нарисовали кабель из шкафа №1 но не закончили и не привели в шкаф №2. Вместо шкафа №2 будет указан шкаф «(???)». Такое решение позволяет оперативно определять "зависшие в воздухе" соединения. Если сделали все хорошо и нет оборванных связей то этого шкафа не будет в дереве

Если между шкафами есть связи, которые не в кабеле - этот узел будет выделен красной стрелкой:

Контекстное меню в таблице связей позволяет для каждого выбранного проводника найти на чертежах назначенный кабель, точку подключения проводника (начала и окончание), открыть просто чертежи начала и окончания, перейти на закладку «Кабели» и в таблице кабелей найти искомый кабель.

Контекстное меню в дереве шкафов меняется в зависимости от того кто был выделен - шкаф или кабель.

Контекстное меню шкафа позволяет «перепрыгнуть» в дереве шкафов на другой конец связи, скопировать в буфер наименование шкафа, развернуть и свернуть дерево шкафов. Переход между шкафами осуществляется так: если был выбран «Шкаф№1» связанный кабелем с «Шкаф№2», то в выпадающем меню можно выбрать «Перейти к шкафу Шкаф№2» и по дереву будет произведен поиск «Шкаф№2» и на эту позицию будет перемещен фокус ввода (аналог щелкнуть мышкой).

Контекстное меню кабеля позволяет перейти на закладку «Кабели» и в дереве кабелей проекта выбрать указанный кабель, скопировать в буфер наименование кабеля, развернуть и свернуть дерево шкафов.

Created with the Personal Edition of HelpNDoc: Maximize Your Productivity with HelpNDoc's CHM Help File Creation Features


Подраздел "Таблица"

На закладке выводятся кабельные связи между шкафами в табличной форме.

При выборе какого либо шкафа или кабеля в дереве шкафов, в таблице будет отображаться соответствующий перечень проводников. Так же будет сформировано визуальное изображение связей.

Например выбран кабель "CS-Ш007" который идет из шкафа №9 в шкаф №1:

На закладке "Таблица" будут показаны все проводники которые соединяют эти два шкафа и принадлежат кабелю:

.

Если выбран кабель у которого не подключенные жилы - они будут показаны как в обрыве, с крестиком на конце. Кабель будет нарисован красным цветом. Так же проводники которые не принадлежат какому-либо кабелю будут обозначены "No Cabel".

Created with the Personal Edition of HelpNDoc: Upgrade Your Documentation Process with a Help Authoring Tool


Подраздел "Графика"

На закладке выводятся кабельные связи между шкафами в графической форме.

При необходимости наблюдаемое изображение схемы связей можно вывести в Автокад при помощи кнопки "Нарисовать в акаде схему". Про это более подробно написано тут .

Например в списке шкафов выбрана панель №107:

В поле выводится графическое представление этих связей:

По умолчанию изображение выводится в компактном виде. Чтобы больше влезло без прокрутки. Можно немного увеличить изображение при помощи кнопки "Крупно".

Если выбран кабель у которого есть не подключенные жилы - они будут показаны как в обрыве, с крестиком на конце. Кабель будет нарисован красным цветом. Так же проводники которые не принадлежат какому-либо кабелю будут обозначены "No Cabel".

Created with the Personal Edition of HelpNDoc: Upgrade your help files and your workflow with HelpNDoc's WinHelp HLP to CHM conversion


Подраздел "Список гермовводов" - Создание таблицы кабельных гермовводов

Данная [image] закладка появилась для облегчения создания чертежей "Задания заводу на изготовление шкафов/ящиков наружной установки". Шкафы/ящики устанавливаются на улице и для защиты от непогоды изготавливаются, как правило, с уровнем защиты IP54...IP65. К этим шкафам подходит достаточно большое количество кабелей, и вводы кабелей внутрь шкафа уплотняются при помощи гермовводов типа PG. Они стоят денег и их нужно считать. Хорошо если предприятие изготовитель шкафов само посчитает и укомплектует шкафы нужным количеством гермовводов. Но ведь бывают ситуации когда их нужно докупать отдельно, или на момент изготовления шкафа точное количество кабелей неизвестно (их монтажники установят по месту просверлив в вводной пластине шкафа нужное количество отверстий под гермовводы). В общем нужно считать. Чем собственно я и озаботился. Лень побеждает всё, а потому и появился этот инструмент позволяющий проанализировать проект и подсчитать необходимое количество гермововводов. В результате получается такая таблица:

и в перспективе вот такой чертежик:

Для создания спецификации этого более чем достаточно. Что еще автоматизировать хз.

Описание работы

Идея такая - берем тип кабеля и по его диаметру назначаем какой-то тип гермоввода.

<ТИП КАБЕЛЯ> = <ТИП ГЕРМОВВОДА>

Понятно что на один кабель можно натянуть кучу разных гермоводов разных производителей. Но тут я исходил из того, что у каждого художника со временем складывается свой привычный круг инструментов и которые "топают" по проектам многие годы. А посему каждый создает свой список на основе базового и пользуется им, внося при необходимости какие-то корректировки.

При окончании разработки принципиальных схем, когда количество кабелей уже четко известно и начинают делать задание заводу, выбирается какой-то шкаф и по нему программа создает таблицу и чертеж.

В программе есть своя таблица (по началу пустая) которая хранит все необходимые параметры - типы кабелей и назначенные им типы гермовводов. Таблица как угодно корректируется/дополняется/чистится. Таблица хранится в программе (в памяти компьютера) и что бы данные не пропали нужно сохранять их.

Основное место хранения - на диске компьютера в виде обычного текстового файла с незатейливым названием "ListGermoVvOds.txt". Файл хранится в пользовательском каталоге "C:\Users\<User>\Program12Utilites". Можете его копировать куда угодно и потом возвращать назад. Сохраняется кнопками.

При выходе из программы таблица всегда сохраняется принудительно и без запроса!

Отдельно есть специальная функция для "не жадин" - сохранение таблицы в "облаке". В роли облака выступает мой домашний веб сервер и импортный веб сервер №1 . Идея проста - допустим работаете на другом компе, где нет файла со списком гермовводов, то вы просто нажимаете кнопку "Добавить таблицу из облака в свою" - с сервера будет скопировано содержимое (если есть) этого файла и ДОБАВЛЕНО! в локальную таблицу. Именно без перезатирания содержимого, только добавлено.

Следует учесть что процесс добавления в файл и в облако не примитивный - если при добавлении будет найдена копия добавляемой записи, то запись не будет выполнена. То есть дубляжа в таблице не будет, хоть сто раз нажимайте кнопку.

Внешний вид закладки "Список гермовводов"

Описание кнопок управления:

Запускает процесс рисования таблицы в автокаде. Настройки - как и для рисования "Паука", расположены выше. Я не стал создавать новые элементы настройки - используются существующие. Может и не удобно, зато быстро.

Кнопки управления записью-чтение таблицы с диска на вашем компе.

Считывает из любого другого файла с параметрами таблицы

Открывает в Проводнике место расположения файла "ListGermoVvOds.txt"

Очищает таблицу, удаляет все записи.

Кнопки управления записью-чтение таблицы с в/из облака.

Для редактирования отдельной записи в таблице есть специальная группа. Внешний вид приведен на картинке ниже. При выборе записи поля заполняются содержимым записи и доступны для редактирования.

По окончании редактирования можно сохранить изменения, вставить как новую запись и удалить выбранную в таблице строку.

Для удобства навигации по таблице есть отдельная группа фильтров

При наборе искомого значения запускается таймер и по окончании времени таймаута производится пере заполнение таблицы с учетом набранного фильтра. Отфильтровываются все записи в соответствующих полях которых содержатся набранные символы.

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Подраздел "Всякое полезное"

Данная закладка содержит всякие вспомогательные утилиты. Назначение очевидно по надписям на кнопках.

Кнопка "Просмотр паука" - будет формировать предварительный просмотр между шкафных связей в классическом виде. Она еще пока в разработке.

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Создание схемы внешних кабельных связей, "Паук"

Для формирования и вывода на текущий чертёж в AutoCAD Electrical (в принципе выведет в любой открытый автокад) схему внешних кабельных связей (в дальнейшем СВКС) предназначена большая кнопка «Нарисовать “Паука».

СВКС рисуется в более-менее привычном для старой гвардии виде. Но в виду того что в проекте АЕ отсутствует такое понятие как «схема защиты» (то есть куски схем различных шкафов образующих одну какую то сложную схему – типа ДФЗ или ДЗ) то выделить и нарисовать такое без наличия искусственного интеллекта нереально. По этому было решено выводить СВКС в немного упрощенном виде:

СВКС и таблица могут быть вписаны в форматную рамку (как на картинке выше) или нарисованы просто как есть. Выбор, вписывать или нет, осуществляется при помощи переключателя «В рамку ЕСКД (А3)».

Если выбрано вписывать, то по умолчанию СВКС вписывается в рамку формата А3 или А4 .Формат А4 выбирается переключателем "начать с рамки А4". Таблица всегда располагается в правом верхнем углу рамки вне зависимости от размеров СВКС, таблицы или форматной рамки.

При вписывании таблицы и СВКС в рамку производится контроль размеров получившегося чертежа. В случае если размеры СВКС больше чем доступная площадь или СВКС наползает на таблицу производится удаление всего что создано, выбирается следующий формат и процесс повторяется. Порядок следования форматов такой:

1. формат A4 горизонтальный (не используется совсем),

2. формат A4 вертикальный,

3. формат A3 горизонтальный,

4. формат A4x3,

5. формат A4x4,

6. формат A4x5,

7. формат A4x6,

8. формат A4x7,

9. формат A4x8,

10. формат A4x9,

11. формат A3 вертикальный,

12. формат A2 горизонтальный,

13. формат A3x3,

14. формат A3x4,

15. формат A3x5,

16. формат A3x6,

17. формат A3x7,

18. формат A2 вертикальный,

19. формат A1 горизонтальный,

20. формат A2x3,

21. формат A2x4,

22. формат A2x5,

23. формат A1 вертикальный,

24. формат A0 горизонтальный,

25. формат A1x3,

26. формат A1x4,

27. формат A0 вертикальный,

28. формат A0x2,

29. формат A0x3

Отключить автоматический подбор форматных рамок можно переключателем "Не подбирать форматные рамки". Тогда в случае если не будет хватать места может получиться так:

Далее при помощи настроек можно указать вывод на новый лист и запросить начальную левую верхнюю точку вывода СВКС. Если вывод осуществляется на новый лист то по умолчанию выводится в точку с координатами 0,0.

Набор переключателей настроек создания СВКС :

  • переключатель «В рамку ЕСКД» - это главный переключатель. Он включает/отключает вписывание паука в форматную рамку при создании схемы внешних кабельных проводок. По умолчанию начальный формат А3.
    Если рисунок не помещается в А4 то будут выбраны большие форматные рамки.
  • переключатель «Начать с рамки А4» - меняет рамку по умолчанию на А4. Если рисунок не помещается в А4 то будут выбраны большие форматные рамки.
  • переключатель «Не подбирать форматные рамки» - отключает автовыбор форматных рамок в случае если паук не помещается или налазит на таблицу. То есть остается только два выбора форматных рамок А3 и А4.
  • переключатель «На новой странице» - принудительно создает новый чертеж в АЭ и выполняет создание схемы внешних кабельных проводок.
  • переключатель «Старый вар-т» - прорисовка немного по другому схемы внешних кабельных проводок (устарело, практичнски не используется).
  • переключатель «Запрос нач точки» - перед рисованием будет запрошена левая верхняя точка чертежа - необходимо будет щелкнуть мышкой в чертеж.
  • Группа "Выбор цвета для прорисовки" задает цвет в который будет окрашен получившийся чертеж. Удобно при контроле версий. Вне зависимости от раскраски на печать чертеж выводится черно-белым, конечно если для раскраски выбраны цвета из стандартной палитры, и выбран профиль печати монохром.

Цветной прямоугольник - отображает выбранный цвет и является клавишей вызова меню выбора цвета.

Три кнопки "Заданный", "По слою", "По блоку" - трехпозиционный переключатель выбора цвета: выбранный пользователем, цвет слоя и цвет блока.

Created with the Personal Edition of HelpNDoc: Revolutionize Your CHM Help File Output with HelpNDoc


Создание схемы соединений между шкафами

Для создания в автокаде схемы соединений между шкафами, как на предварительном просмотре на закладке "Графика", есть кнопка "Нарисовать в автокаде схему". При нажатии появится панель с настройками и кнопкой "Нарисовать схему".

Настройки просты - нарисовать в блок, расположить в форматной рамке, запрос точки вставки, нарисовать на новой странице и крупный или мелкий рисунок.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Таблица и предварительный просмотр внешних связей

При выборе какого либо шкафа или кабеля в дереве шкафов в таблице будет отображаться соответствующий перечень проводников. Так же будет сформировано визуальное изображение связей.

Например выбран кабель "CS-Ш007" который идет из шкафа №9 в шкаф №1:

На закладке "Таблица" будут показаны все проводники которые соединяют эти два шкафа и принадлежат кабелю:

.

На закладке "Графика" будут показаны эти соединения в графическом исполнении

Если выбран кабель у которого не подключенные жилы - они будут показаны как в обрыве, с крестиком на конце. Кабель будет нарисован красным цветом. Так же проводники которые не принадлежат какому-либо кабелю будут обозначены "No Cabel".

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Раздел «Перечень элементов»

На этой закладке отображаются все элементы использованные в проекте в виде дерева элементов и 4 переключаемых страницы:

  • Страница "Перечень чертежей для выбранного шкафа". Позволяет отобрать чертежи (по выбранному элементу/коемме/шкафу итд) и скопировать их на текущий чертеж в Автокаде.
  • Страница "ВОМ / Перечень элементов". Попытка собирать и оформлять ВОМ/перечень элементов при помощи программы, напрямую. Неудачно.
  • Страница "Связи элементов". В процессе разработки.
  • Страница "Всякие утилиты для элементов". В процессе разработки.

Внешний вид закладки:

Инструменты управления:

Дерево элементов.

Содержит все в проекте детали и клеммы. Позволяет просмотреть все детали и клеммы входящие в состав шкафа. Сгруппировано по структуре проекта вплоть до блока на чертеже, который обозначает выбранный элемент.

Фильтр элементов.

Поля позволяют отобрать элементы по имени, месту установки и по зоне установки.

кнопка "свернуть все" - сворачивает все дерево до верхнего узла

кнопка "развернуть все" - разворачивает все дерево до самого нижнего уровня

кнопка "развернуть до шкафов" - разворачивает все дерево до уровня шкафов

Кнопка запуска процесса копирования выбранных файлов на один лист.

Переключатели для настройки процесса копирования выбранных файлов на один лист.

Выделяет и снимает выделение фалов.

Пока бессмысленно ибо не работает и выделение ни на что не влияет. :)

Created with the Personal Edition of HelpNDoc: Elevate Your Documentation Process with HelpNDoc's Advanced Features


Сбор чертежей на один лист

В процессе внесения изменений или при анализе кучи чертежей по которым "размазаны" схемы одного шкафа часто появляется необходимость увидеть на одном листе все чертежи на которых есть конкретный шкаф. При создании раздела задания заводу тоже необходимо выполнить такую сборку.

Для этого предназначено это поле:

При выборе какого либо шкафа в дереве элементов в этом поле будет сформирован список чертежей на которых есть детали из этого шкафа. Как видно приводится порядковый номер страницы в проекте и имя файла чертежа. Имя файла относительно корневого пути проекта.

Кнопка "Сбор чертежей на один лист" - запускает процесс сбора чертежей. Программа последовательно соберет все детали шкафа, соберет наименования чертежей где они находятся, отсортирует их и, последовательно открывая чертежи, будет копировать их содержимое на текущий лист.

Чертежи будут расположены по горизонтали в один ряд.

Альтернативой является сбор чертежей через меню на закладке"Файлы проекта":

- при нажатии на кнопку выделенные в таблице чертежи будут скопированы на текущий лист.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Раздел «Кабели»

На этой закладке расположены инструменты для работы с кабелями: дерево кабелей, таблица перечня жил в выбранном кабеле, параметры выбранного кабеля, инструменты для редактирования кабеля и поиска отдельных составляющих.

Внешний вид закладки:

Инструменты управления:

- Дерево кабелей проекта с фильтрами

- Параметры кабелей

- Утилиты для кабелей

Лирическое отступление: Кабели в проекте АЭ обозначаются базовым блоком и дочерними блоками. Блоками отмечают жилы кабеля. Они вставляются в разрыв проводника. Базовый несет в себе различную информацию: марку, тип, длину и дополнительные описания. Дочерние блоки просто помечают проводники, назначенные как жилы этого кабеля.

Каждый кабель начинается на каком то элементе одного шкафа/ящика и заканчивается на элементе другого шкафа/ящика. Необязательно, но желательно, что бы кабель начинался и заканчивался на клеммах. И не рекомендуется (но не запрещается) подключать больше двух кабелей к одной клемме. Больше четырех вообще моветон.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Дерево кабелей проекта

Раздел «Кабели» ››

I love Ukraine

Дерево кабелей проекта

Все присутствующие в проекте кабели перечислены в списке-дереве кабелей.

Внешний вид списка кабелей:

Кабели в списке отсортированы по наименованию и разбиты на группы.

Группировка может быть осуществлена по полям "Inst"-"Loc", по "Монтажным единицам" + "Inst-Loc" и по меткам резервирования + "Inst-Loc". Выбор между типами группировки осуществляется переключателем над полем списка.

В списке можно выбрать один или несколько кабелей. Выбор одного динамически наполняет кнопками панель инструментов для быстрого перехода к чертежам проекта, в другие разделы программы или изменения каких-либо параметров кабеля.

Кабель в проекте состоит из блоков, каждый блок как правило обозначает один проводник (жилу кабеля) . Однако один блок может обозначать и несколько жил - если был применен разветвитель входов-выходов.

В списке эта структура повторяется - каждый кабель содержит список блоков и каждый блок содержит перечень проводников.

Это позволяет можно отследить "неправильные" блоки - которые по каким-либо причинам остались вне проводника. Такое часто бывает если обозначение кабеля при копировании просто легло поверх линии провода – визуально отличить нет возможности. В дереве кабелей этот блок будет без проводника.

Базовый блок всегда выделяется жирным шрифтом.

Для обработки кабелей можно выбирать как группу от первого к последнему (с зажатой клавишей Shift), так и поштучно (с зажатой клавишей Ctrl). Отсортированный перечень выбранных кабелей тут же будет отображаться в текстовом поле «Параметры выбранного кабеля».

Если выбрать группу кабелей, корневую позицию «Все кабели» или какое-либо поле Inst-Loc, то будет подсчитано количество кабелей и количество жил, что полезно для сметчиков:

Список кабелей можно отфильтровать по названию, типу, и шкафов подключения начала/конца. Понятие «начало-конец» кабеля условно, можно понимать под ними точка подключения №1 и точка подключения №2.

Created with the Personal Edition of HelpNDoc: Converting Word Docs to eBooks Made Easy with HelpNDoc


Контекстное меню дерева кабелей

Контекстное меню динамическое и зависит от того что было выбрано в дереве кабелей.

Выбрана любая группа кабелей - от "Все кабели" до "Inst - Loc":

Выбран один кабель:

Выбран один блок кабеля:

Выбран один проводник в блоке кабеля:

Created with the Personal Edition of HelpNDoc: Transform Your Help Documentation Process with a Help Authoring Tool


Группа фильтрации списка кабелей

Группа фильтрации списка кабелей выглядит так:

Все поля в группе - это редактируемые списки. Например, если нужно выбрать все кабели, которые начинаются/заканчиваются в шкафах "ШК-...", то в поле «Из» набираем просто первые буквы "ШК". Если необходимо отобрать кабели, которые идут к конкретному шкафу, то его имя его можно выбрать из выпадающего списка или набрать уникальную часть имени.

Фильтр работает с небольшой задержкой в 1,5 сек. То есть вы набираете первый символ, но фильтрация не запускается, запускается выдержка времени. При вводе второго и последующих символов выдержка времени перезапускается. По окончании ввода, через 1,5 сек запускается фильтрация. Эта «задумчивость» фильтра была необходима - при значительном количестве кабелей (от 300-500 и более) фильтр мог отрабатывать до пары секунд. И в это время игнорировался ввод следующих букв. Что приводило к не полной фильтрации.

Выпадающие списки полей «Из» и «В» содержат перечни шкафов к которым подключаются кабели и позволяют отфильтровать кабели которые начинаются/заканчиваются в определенных местах (Loc). Начинать заполнение первым желательно (но не обязательно) поле «Из». Списки динамические и заполняются по мере фильтрации. По началу оба списка содержат все шкафы в проекте.

Поле «Тип кабеля» - позволяет отфильтровать кабели определенного типа. Работает аналогично полям «Из» и «В» - позволяет отфильтровать по набору символов, входящих в тип кабеля, или выбрать тип кабеля целиком из выпадающего списка.

Далее идет не обозначенное поле имени кабеля - позволяет отфильтровать по набору символов, входящих в наименование кабеля.

Поле «Брак» - отфильтровывает "бракованные" кабели, например у которых нет базового блока или количество жил меньше чем задействовано, и т.д.

Кнопка «Сброс» - очищает все фильтры и выводит все кабели.

Created with the Personal Edition of HelpNDoc: Maximize Your Productivity with HelpNDoc's Efficient User Interface


Контроль ошибок в кабелях

Для облегчения поиска ошибок при создании кабелей в проекте, автоматически производится проверка кабелей на «правильность». «Неправильные» кабели будут обозначены оранжевой стрелкой. Такие кабели можно отфильтровать от общей массы для анализа и корректировки поставив галочку в поле «Брак».

Поле с переключателями, которые отвечают за какую-то одну проверку, выглядит так:

Проверку можно выключить при помощи одного "главного" выключателя.

Проверяется следующее:

- "Количество жил (зависшие блоки)" - контролируется количество проводников и количество блоков их обозначающих. Как правило один блок - один проводник. Но при использовании разветвителя входа-выхода количество проводников будет больше чем блоков. Это нормально и не является ошибкой. Если количество блоков больше чем количество жил - значит есть блоки "висящие в воздухе", или больше одного на линии проводника.

Лирическое отступление: разветвитель входа-выхода - фиговая штука я вам скажу. Вернее идея классная, но выполнена через жопу. Попробуйте сделать на одном чертеже несколько таких разветвителей для нескольких кабелей и получите кашу из назначенных жил… по крайней мере в АЭ 2012 именно так. При попытке нарисовать подключение трех трансформаторов напряжения к одному ящику ЯЗН, получил полную кашу - жилы он сам назначал как хотел и куда хотел.

- "Подключение только к клеммам" - контролируется что бы жилы кабеля были подключены к клеммам, а не к аппаратам.

- "Подключение к разным шкафам" - контролируется наличие и корректность указания шкафов источника/приемника. Например, если нарисовать проводник который никуда не приходит, обрывается "в воздухе", и обозначить как жилу кабеля, то это будет расценено как ошибка в кабеле. Так же кабель не может начинаться и заканчиваться в одном и том же шкафу.

- "Только один базовый блок" - контролируется наличие базовой жилы кабеля, контроль количества базовых блоков кабеля - должен быть только один базовый блок.

- "Тип кабеля" - контролируется соответствие количества использованных жил количеству доступных жил, указанному в типе кабеля (например, «КВВГ 14х1,5» не может вмещать 18 жил – будет ошибка и кабель помечен как «неправильный». Учитывается необходимость запаса жил согласно ПУЭ.

Для контроля задействованных жил кабеля анализируется строка тип кабеля. Тип кабеля представляет собой конструкцию из буквенной и цифровой частей. Пробелы игнорируются. Отделяется тип и анализируется числовая часть. Например: КПСВЭВнг(А)-LS 10х2х0,5 будет разделен на "КПСВЭВнг(А)-LS" и "10х2х0,5", сечение кабеля "0,5" будет отброшено и последующие цифры перемножены. В результате число жил равно 20. Для кабеля АВВГнгд "4х6 + 1х2.5" будет получено число жил 5.

Вообще общее название должно быть таким: "ТИП" NxNxN+NxNxS.

- "Контроль блоков" - контролируется "висящие" обозначения кабеля (бывают случаи когда блоки обозначения кабеля копируют и забывают перенести на проводник, тогда получается что как бы жила кабеля есть, но не обозначает ни один проводник) и контроль нескольких блоков обозначений кабеля на одном проводнике (например на одном листе поставили обозначение кабеля и ссылку-источник, на другом листе поставили второе обозначение кабеля и ссылку приемник).

- "Штаны" - контролируется подключение кабеля к одному клеммнику. Если есть два клеммника (левая и правая боковины), то при подключении кабеля часть проводников пойдет влево, а часть вправо - это и есть "штаны".

- "Чужие жилы" - контролируется соответствие начальных/конечных шкафов каждой жилы к базовой жиле. То есть если базовая жила идет от «Шкаф1» к «Шкаф2» то и дочерние проводники(жилы кабеля) должны так же начинаться в «Шкаф1» и заканчиваться в «Шкаф2».

Created with the Personal Edition of HelpNDoc: Maximize Your Productivity with HelpNDoc's CHM Help File Creation Features


Параметры кабелей

Закладка "Параметры выбранного кабеля" выглядит так:

В этой закладке выводится информация из проекта о выбранном кабеле. Так же в этом поле отображаются ошибки в кабеле. В случае если не было выбрано ни одного кабеля, или выбрано несколько кабелей - отображается перечень выбранных кабелей. Например:

Выбран кабель "1Т-105": Выбрана группа кабелей:

Таблица жил кабеля/кабелей:

Таблица содержит информацию о всех проводниках/жилах кабеля. Параметры выводимые в таблице очевидны и не требуют дополнительных пояснений.

В таблице работает динамическое контекстное меню. Набор пунктов зависит от того, где кликнули правой кнопкой мыши.

Группа динамического меню для выбранного кабеля:

Эта группа кнопок различных инструментов и быстрого перехода наполняется динамически во время выбора одного кабеля. При выборе группы каблей она очищается.

Кнопка «перейти в меню к…» позволяет оперативно найти в дереве внешних связей указанный шкаф и выделить его, раскрыв дерево именно на нем и именно на той связи, которая соединяет эти два шкафа между которыми проложен выбранный кабель.

Не рекомендуется к использованию, но отлично работает, см закладку "утилиты". Кнопка «Переименовать кабель» позволяет изменить наименование выбранного кабеля. Будет открыто соответствующее меню с предложением изменить текущее наименование. В случае согласия в проект будут внесены необходимые изменения – будут открыты последовательно все чертежи содержащие блоки кабеля и будет изменено поле TAG.

Не рекомендуется к использованию, но отлично работает, см закладку "утилиты". Кнопка «Установить дину» позволяет изменить длину кабеля. Изменение производится аналогично изменению наименования кабеля.

Кнопка «В буфер марку кабеля» просто копирует в буфер обмена (clipboard) наименование выбранного кабеля.

Кнопки «Найти базовую жилу» или «Найти жилу» - при работающем Автокаде открывают чертеж, содержащий выбранный блок кабеля и фокусируют (зуммируют) видовой экран на нем.

Самые нижние кнопки «Найти…» позволяют найти точки подключения жилы кабеля. Работают аналогично вышеописанным кнопкам поиска жил/блоков кабеля.

Created with the Personal Edition of HelpNDoc: Easy Qt Help documentation editor


Предварительный просмотр подключения кабеля

При выборе кабеля в дереве схема подключения выбранного кабеля отображается на панели "Попередній перегляд підключення кабеля". В виду того что клеммники могут быть по 100-300 клемм рисунок по вертикали может не поместиться, и тогда для просмотра его необходимо прокручивать ползунком справа.

Для вывода в чертеж этой схемы нужно воспользоваться утилитой, см описание тут

Внешний вид панели предварительного просмотра:

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Утилиты для кабелей

Закладка "Утилиты кабелей" выглядит так:

Инструменты разбиты на группы:

- изменение параметров выбранного в дереве кабеля или группы кабелей ;

- создание схем подключений кабеля .

- управление взаимо-резервированием кабелей .

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Изменение параметров кабеля или группы кабелей

Группа инструментов выглядит так:

Кнопка «Переименовать кабели выбранные в дереве» - переименовывает все выбранные кабели, один или несколько, согласно выбранному шаблону и выбранному шагу. Шаблон и шаг разделяются запятой. То есть "WR-101,1" означает что будут выбранные кабели сверху вниз переименованы в "WR-101", "WR-102", "WR-103" и так далее. Если не указывать через запятую значение приращения, то по умолчанию будет установлена единица. Для переименования будут открыты существующие чертежи, на которых находятся базовые блоки кабелей, и в соответствующие атрибуты будут внесены изменения.

Кнопка «Переименовать кабели выбирая на чертеже» - позволяет аналогично переименовать выбранные на текущем открытом чертеже. То есть процесс выглядит так: открываем чертеж, вводим начальное значение в поле шаблона имени файла, нажимаем кнопку. Программа "цепляется" к текущему открытому чертежу и высвечивает приветствие, далее по очереди тыцкаем мышкой в ЛЮБОЙ блок кабелей. Кабели запоминаются в списке для обработки в том порядке, в котором были выбраны на чертеже. Если кабель уже есть в списке, он не будет добавлен вторично. По окончании выбора кабелей просто нажимаем Esc или тыцкаем куда ни будь, главное не в кабель. Будет выдан запрос о прекращении операции или продолжении выбора. Нажимаем "Cancel" и программа начинает второй этап - переименование выбранных кабелей.

Кнопка «Установить для выбранных кабелей значения полей Inst и Loc» - позволяет назначить кабелям, выбранных в дереве кабелей, новые значения Inst и Loc. Чекбоксами можно выключить соответствующее поле.

Кнопка «Назначение/Монтажная единица» - позволяет назначить кабелям, выбранных в дереве кабелей, наименование монтажной единицы. Это условная сортировка кабелей. Она никак не влияет на работу AutoCAD Electrical.

Кнопка «Изменить тип кабелей выбранных в дереве» - позволяет изменить тип выбранного кабеля, или группы кабелей, и обозначение его производителя (пример - "КВВГнг 4х1,5" и "ОдесКабель"). Изменения будут автоматически внесены в базовый блок обозначение кабеля на чертеже.

Кнопка «Длина АВТО» - позволяет удалить вручную введенную длину и назначить длину рассчитанную ранее по плану прокладки кабельных трасс. При этом будут восстановлены все параметры прокладки кабеля по участкам трассы. Пояснение читать тут.

Кнопка «Фикс-ть» - позволяет "зафиксировать" длину кабелей. Вернее она переопределяет существующую длину кабеля как назначенную вручную. Как если бы вы каждый кабель выбрали и вручную ввели его длину.

Кнопка «Установить вручную дину кабеля» - позволяет вручную откорректировать длину кабеля или группы выбранных кабелей) и сохранить её в проекте. При этом будет выдан запрос на ввод новой длины и запрос на исполнение. При этом будут удалены из кабеля все параметры прокладки кабеля по участкам трассы. Пояснение читать тут.

Created with the Personal Edition of HelpNDoc: Bring your WinHelp HLP help files into the present with HelpNDoc's easy CHM conversion


Создание схем подключений кабелей

Группа инструментов для создания схем выглядит так:

Кнопка «Нарисовать схему подключения кабеля/кабелей» - для выбранной группы кабелей будут нарисованы схемы подключения. Видео процесса есть тут . Приблизительный вид схемы такой:

Схемы рисуются в одну горизонтальную линию с небольшим отступом между схемами.

Схемы можно выполнить в виде блоков и расставить в форматные рамки. За это отвечают переключатели справа от основной кнопки.

Если на чертеже уже есть блоки схем подключения, то их можно обновить при помощи кнопки "Обновить блоки на чертеже" :) Это удобно в случае если проект корректируется. Алгоритм может быть такой: собираем все чертежи на один лист, обновляем блоки, потом разбиваем на отдельные чертежи с заменой существующего файла.

Группа "выбор слоя и цвета для прорисовки" позволяет настроить слой и цвет которым будут нарисованы схемы подключения. Если слоя нет, то он будет создан.

Группа "разбивка по:" позволяет выбрать как будут отсортированы и разбиты на группы получившиеся схемы. Если выбрать "без разбивки", то, понятно что все схемы будут просто отсортированы по монтажным единицам(МЕ), потом по значению INST, потом по значению LOC и расставлены в один длинный ряд начиная с указанной точки или с координаты (0,0). Если выбрать другие варианты, то схемы будут отсортированы по выбранным полям и разбиты на группы соответствующие выбору. То есть, для примера, если выбран пункт "Inst-Loc", то все кабели будут разбиты на группы по одинаковым Inst-Loc и для каждой будет создана отдельная горизонтальная группа схем на чертеже.

Created with the Personal Edition of HelpNDoc: Streamline your documentation process with HelpNDoc's WinHelp HLP to CHM conversion feature


Ручной ввод длины. Пояснение

Раздел «Кабели» ››

I love Ukraine

Ручной ввод длины. Пояснение

Длина кабеля может быть получена из двух источников:

  • в результате автоматического расчета длин кабелей ( см. раздел "Расчет кабельного журнала" );
  • ввод вручную необходимой фиксированной длины кабеля.

Для ручного ввода есть маленький нюанс - при назначении длины кабеля вручную программа не в состоянии определить путь прокладки кабеля и, соответственно, участки прокладки.

Каждый кабель идет от шкафа А к шкафу В. Когда программа рассчитывает длины кабелей, она анализирует для каждого кабеля все возможные пути прокладки, от шкафа А к шкафу В, по заданным на чертеже кабельным трассам и выбирает кратчайший путь. Рассчитанные пути назначаются кабелям. То есть получается связка "кабель"-"путь". И кабель получает длину соответствующего пути. При этом появляется возможность вывести в таблицу кабельного журнала описание и длины участков трассы прокладки кабеля: "лоток 200х60мм: 241,1м; лоток 35х30мм: 148,1м; лоток 500х60мм: 71,2м; по констр-м: 0,6м".

Вся эта информация, все параметры пути, хранятся в свойствах пути. Сами рассчитанные пути сохраняются в отдельном файле (не в чертежах). При последующем открытии проекта вся эта информация о расчетной схеме и рассчитанных путях вновь считывается и вновь назначается кабелям.

Таким образом длина пути получается всегда "синхронизирована" с длинами участков этого пути. При выводе в кабельный журнал можно добавить длину к каждому кабелю (например на разделку кабеля) и увеличить на определенный процент рассчитанную длину кабеля. То есть, сначала к длине каждого кабеля добавляется заданный процент от рассчитанной длины кабеля (растягивается на заданный процент), а потом добавляется кусок "на разделку" - участок "по конструкциям" заданной длины. Таким образом если сесть с калькулятором и параноидально просчитать суммы длин участков для каждого кабеля, то они совпадут с общей длиной кабеля. Подробно описано тут.

При необходимости откорректировать длину кабеля есть возможность задать длину вручную. Задать можно как индивидуально для каждого кабеля так и для группы выбранных кабелей. Однако, тут же нарушается соответствие между участками и новой длиной кабеля. Если, допустим, программа рассчитала длину пути/кабеля 250 метров, который состоит из двух каких-то участков по 125 метров, то при ручном вводе длины 50 метров, невозможно понять, как идет кабель и по каким участкам.

Что бы избежать такого конфликта при вводе длины вручную, кабель теперь "отрывается" от расчетного пути. И в кабельный журнал в этом случае нечего выводить кроме длины. Поэтому в таблице кабельного журнала в графе "Участок трассы кабеля, провода" будет пустое поле. Заданная фиксированная длина сохраняется в настройках проекта и при следующем считывании проекта будет восстановлена.

При необходимости кабель можно обратно "привязать" к расчетному пути. И прокладка по участкам и длина будет восстановлена из назначенного пути.

Created with the Personal Edition of HelpNDoc: Free Qt Help documentation generator


Взаимо резервируемые кабели

В AutoCAD Electrical в принципе не предусмотрено наличие признака взаимо-резервируемых кабелей. Впрочем как и расчета КЖ. Я предпринял попытку исправить это. КЖ уже практически прекрасно считается, даже в 3D, но не учитывает множество нюансов: резервирование кабелей, заполнение лотков и т.д.

По идее взаимо-резервирование должно предусматривать прокладку кабеля по разным трассам, желательно подальше друг от друга. Но "искусственный интеллект" программы способен только на прокладку кабеля по кратчайшему маршруту. А посему я сделал хитрость - добавил метку в базовый блок обозначения кабеля. Метка назначается группе кабелей (от 2 и более, для одного смысла не имеет) и означает что кабели с этой меткой - взаимо-резервируемые. Метка представляет собой любую символьную строку уникальную в проекте. Она состоит из любых символов допустимых в AutoCAD Electrical . То есть теоретически можно использовать любые и кириллицу тоже. Но я, по опыту общения с AutoCAD Electrical, рекомендую все таки использовать буквы английского алфавита, символы (типа тире) и цифры. Пробел не рекомендую, хотя глюков не наблюдал, но что-то стрёмно.

Метка сохраняется в базовом блоке кабеля в атрибуте "RAITING12". Атрибут скрытый, и расположен в любой точке блока. В обычном блоке, который поставляется с AutoCAD Electrical этого атрибута нет и его необходимо добавить в блок. Тут есть два варианта. Первый - найти dwg файл этого блока на диске и откорректировать его. Потом обновить блоки на чертеже. Второй вариант - поставить галочку которая вызовет создание атрибута во время назначения метки.

Но второй вариант имеет колоссальный минус обусловленный спецификой организации работы с блоками внутри самого Автокада. Дело в том что то что вы видите на экране это "вхождение блока", как бы его "проекция на экран". Сам блок это набор цифр в памяти, его описание и сохраняется в чертеже. Фишка в том что значение атрибута хранится в отдельной таблице чертежа и при изменении значения атрибута просто меняется значение в таблице, и соответственно перерисовывается изображение на экране. Если вдруг в существующий блок добавить новый атрибут - он не появится во вхождениях бока, то есть вы его не увидите. Для этого есть штатная команда синхронизации, которая выполняет обновление этой таблицы атрибутов и во вхождениях блока появляется новый атрибут. Но и тут не без проблемы - эта команда просто сбрасывает в ноль все настройки атрибутов, до состояния как в исходном файле блока. А в нем все линии и атрибуты находятся на нулевом слое.То есть блок на чертеже - "белеет" - вся графика блока переносится на слой "0".

Перед расчетам все кабели проекта сортируются по именам. И потом по списку для каждого кабеля определяется индивидуальная "дорожка" - кабельная трассы от ящика к ящику. Выбор трассы происходит с учетом метки.

Если метки у кабеля нет, то он просчитывается как и ранее - по любому самому кратчайшему пути.

Если кабель имеет метку, то при расчете трассы просматривается каждый участок и ищется уже проложенный резервный кабель. Если такой кабель обнаружен, то этот участок считается "бракованым/неудобным"и ищется новый. Может быть ситуация когда вариантов прокладки просто нет. Тогда эти кабели прокладываются рядом. Увы, но следить за трассами это обязанность проектировщика.

Как вариант предлагаю тогда на расчетном плане, на таких участках, рисовать параллельно две линии. Они выходят "лодочкой" из одной точки и приходят в другую. В этом случае они будут отображать, например, кабельный канал/лоток разделенный щитком. И программа сама разложит кабели по этим разным трассам.

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Цвет жил кабеля

В AutoCAD Electrical предусмотрен механизм хранения цвета жил кабеля

Цвет сохраняется в атрибуте "Raiting1" блока, который обозначает жилу кабеля. Назначается при вставке блока в чертеж.

В AutoCAD Electrical встроены типовые цвета. Но это просто обычный атрибут и в это поле можно внести любую строку. Так что использование достаточно широкое.

В программе на закладке "Кабели" можно посмотреть перечень проводников выбранного кабеля и схему подключения на которых будет отображаться текущий цвет жилы.

При выводе схемы подключения кабеля также выводится цвет проводника в виде подписи над линией обозначающей проводник.

Если цвет жилы не нужен есть возможность отключить его в настройках:

Настройка цвета проводника осуществляется или из AutoCAD Electrical или из программы, как больше нравится. Смысл один - заполнить атрибут текстовой строкой.

Из программы замену можно сделать из контекстного меню в таблице проводников кабеля:

Или кнопкой "Сменить цвет жилы". Кнопка появляется только если выбрать в дереве проводник или строчку в таблице проводников кабеля на закладке "Параметры выбранного кабеля".

При нажатии будет предложено диалоговое окно в котором необходимо ввести новое значение:

После будет выдано предупреждение и в случае согласия в чертеж будет внесены изменения

Created with the Personal Edition of HelpNDoc: Elevate Your CHM Help Files with HelpNDoc's Advanced Customization Options


Кабели с нулевой длиной

Есть случаи когда кабелям необходимо задать фиксированную нулевую длину. Например: идет реконструкция, добавляется/меняется оборудование и нужно добавить новые кабели, при этом показав в кабельном журнале существующие. Что бы длина существующих кабелей не учитывались в спецификации, им назначается вручную нулевая длина. И как-бы они есть в каб журнале, и в тоже время они не учитываются в спецификации.

Created with the Personal Edition of HelpNDoc: Make Documentation a Breeze with a Help Authoring Tool


Раздел «Кабельный журнал»

I love Ukraine

Раздел «Кабельный журнал»

На этой закладке расположены инструменты для мониторинга и вычисления длин кабелей входящих в проект.

Инструменты сгруппированы по смыслу на нескольких отдельных закладках:

- Предварительный просмотр кабельного журнала

- Расчет длин кабелей и формирование кабельного журнала

- Рассчитанные кабельные трассы

- Типы кабельных прокладок

- Расчет кабельного журнала из файла Excel

Внешний вид закладки:

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Подраздел «Предварительный просмотр кабельного журнала»

Раздел «Кабельный журнал» ››

I love Ukraine

Подраздел «Предварительный просмотр кабельного журнала»

На этой закладке расположены таблицы отображающие текущие длины кабелей входящих в проект и группа инструментов для вывода кабельного журнала в автокад, в эксель. Так же есть возможность сортировки в таблицах по возрастанию - нужно кликнуть по соответствующему столбцу.

Внешний вид закладки:

Таблица "Длины кабелей" содержит выбранную из проекта информацию о всех кабелях и приведенную в упрощенном виде.

Графа "Рез" позволяет увидеть признак взаимо-резервирования. Если кабель обозначен такой меткой то в поле "Рез" будет поставлен значок. Графа "Руч" показывает кабели с установленной вручную длиной.

Таблица "Ведомость потребности кабелей" содержит сводную информацию о длинах кабелей.

Таблица "Ведомость потребности труб" содержит перечень типов труб и их суммарную длину.

Переключатель под таблицей позволяет вернутся к типам трасс (названия слоев по которым идет расчет кабельных трасс)

Инструменты управления:

Группа "Проектная "добавка" к длине кабелей" содержит значения для корректировки рассчитанных длин кабелей. Более подробно смотри тут

Кнопка "Нарисовать в DWG кабельный журнал" вызывает плавающую панель с инструментами настройки отображения предварительного просмотра кабельного журнала. Более подробно смотри тут . Более подробно о печати КЖ смотри тут.

Кнопка "Настройки отображения КЖ и фильтры кабелей" вызывает плавающую панель с инструментами для корректировки вида КЖ и отбора кабелей для отображения в КЖ. Более подробно смотри тут

Created with the Personal Edition of HelpNDoc: Make Documentation a Breeze with a Help Authoring Tool


Проектная "добавка" к длине кабеля

Формула расчета длины кабеля

Для того чтобы рассчитать длины кабелей как правило используется строительный план или создается довольно условный план объекта. По нему рисуются возможные трассы прокладки. Далее программа выполняет расчет и получает длины по кратчайшим трассам. Но есть нюанс - все трассы достаточно условны и планы тоже отражают пути прокладки без учета реалий. Естественно планы не имеет смысла создавать с феноменальной точностью (в обычных случаях, клинические ситуации я не рассматриваю). А по сему нет учета на неровную прокладку кабеля, на изгибы, на возможные отклонения проектных трасс от реальных и так далее... Таким образом полученная длина может отличаться от реальной на сколько-то процентов.

Для учета этих неточностей в программе предусмотрены два поля с редактируемыми значениями "добавок" к длинам. Создается запас к длине кабеля.

Внешний вид группы инструментов:

При изменении значений производится перерасчет кабельного журнала и корректируются числа в таблице. Но сам рассчитанный кабельный журнал, то есть "сырые" цифры длин кабелей, не меняются при изменении "добавок" - указанные значения добавляются к рассчитанным длинам кабелей "на лету". То есть в проекте всегда сохраняются только рассчитанные по плану длины кабелей.

При выводе кабельного журнала в таблицу предварительного просмотра, или в DWG, или в Excel длины корректируются на указанные значения

Описание полей:

- это поле позволяет задать "добавку" к длине каждого кабеля. Указанное значение суммируется с рассчитанной длинной и выводится в кабельный журнал. На сохраненные значения в проекте это поле никак не влияет. Обычно таким образом можно задавать отрезки на разделку кабеля и запас под вводы в шкафы.

- это поле позволяет увеличить рассчитанную длину кабеля на выбранное количество процентов. Обычно задается 8-10% для учета неравномерности прокладки и радиусов изгибов.

Формула расчета длины такая:

[Длина кабеля] = [рассчитанная длина] * [1 + (добавленный процент)/100] + [ добавленная длина ]
[Длина кабеля] = ОКРУГЛЕНИЕ( [Длина кабеля] )

При этом фиксированная длина кабеля (заданная вручную) не корректируется вообще - что сам задал, то и имеешь.

Округление вносит в кабельный журнал свои добавки. округляется всегда вверх.
То есть кабель с рассчитанной длиной 10,00001 метра будет округлен в 11,0 метров

Created with the Personal Edition of HelpNDoc: Elevate Your Documentation Process with HelpNDoc's Advanced Features


Отображение в КЖ фиксированной длины кабеля

Длина кабеля может быть или рассчитана автоматически, или назначена вручную (фиксированная длина). Ввод длины кабеля вручную описан тут .

В случае, если длину кабеля назначили вручную, длина кабеля не корректируется при автоматическом расчете - это ваша головная боль. Сами назначили и сами несете ответственность насколько точно указали.

Если с автоматическим расчетом все понятно, сколько программа рассчитала по нарисованному плану столько и отображается в кабельном журнале, то с ручным вводом длины кабеля есть нюансы.

Например по каким-то причинам мы ввели вручную длину кабеля 0 метров. Но после расчета длин кабелей длина этого кабеля будет, допустим, 100 метров. Но в КЖ будет отображено 0 метров. Всё типа ОК. Однако фактически трасса прокладки кабеля - ненулевая. Она тоже рассчитана по разным участкам и будет несоответствие между расчетной длиной и назначенной длиной кабеля. И длины участков трассы прокладки могут стать отрицательными.

Чтобы избежать этого предлагается следующий выбор при помощи переключателя "Для фиксированной длины отображать расчетную длину":

Идея в следующем: при рисовании кабельного журнала кабели с фиксированной длиной (введенной вручную) могут выводиться как с рассчитанной длиной, так и с фиксированной.

Если выбран вывод с фиксированной длиной, то описание участков трассы не заполняется, ибо ее длина никогда не будет равна заданной вручную длине кабеля. И в суммарную потребность кабелей добавляется заданная длина.

Если выбран вывод с расчетной длиной, то описание участков трассы заполняется как обычно и в поле "Длина" выводится рассчитанная длина. Однако в суммарную потребность кабелей добавляется не расчетная, а заданная вручную длина.

  • Переключатель отключен (галочка снята) - вывод в таблицу КЖ назначенной вручную длины кабеля
    • в поле "Длина" - показывается назначенная вручную длина.
    • На длину кабеля "добавки не распространяются - считается что если сам назначил, то понимаешь что делаешь и добавки назначишь сам.
    • В суммарную длину вносится заданное вручную значение длины кабеля.
    • в поле "Участок трассы" - выводится пустое поле

Пример:

  • Переключатель включен (галочка установлена) - вывод в таблицу КЖ рассчитанной автоматически длины кабеля
    • в поле "Длина" - показывается рассчитанная программой длина кабеля со всеми добавками.
    • В суммарную длину вносится заданное вручную значение длины кабеля.
    • Если заданная вручную длина кабеля нулевая, то дополнительно выводится пометка "Не учитывается в потребности кабелей".
    • в поле "Участок трассы" - выводится рассчитанная трасса, отображается как обычно.

Пример:

Но в потребности кабелей не учитывается:

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Панель инструментов "Рисование кабельного журнала"

Описание настроек вывода КЖ

Описание работы с наборами настроек

Плавающая панель инструментов "Нарисовать в DWG кабельный журнал" содержит группу элементов для вывода КЖ в Автокад и Эксель.

Панель появляется при нажатии на одноименную кнопку и закрывается если щелкнуть на кнопке с большим красным крестиком или каком либо не занятом поле панели.

Внешний вид панели:

На панели расположены следующие инструменты:

Основная кнопка "Нарисовать в Автокаде кабельный журнал" - запускает вывод на текущий лист кабельный журнал согласно настройкам описанны ниже.

Группа переключателей ("галочек") "Параметры вывода кабельного журнала" - всякие настройки при прорисовке КЖ в AutoCAD Electrical.

Описание основных настроек для рисования КЖ

Переключатель выбора формата кабельного журнала. По умолчанию выводится по ДБН/ГОСТ. Если включить будет альтернативная форма КЖ, описанная здесь

В случае установки "галочки" программа будет создавать для каждого листа кабельного журнала отдельный чертеж. Как правило не используется.

Наличие "галочки" приводит к появлению на каждой странице примечания - типовой фразы о недопустимости нарезки кабелей по данному кабельному журналу и необходимости уточнить по месту длины.

В поле кабельного журнала, где указано количество жил кабеля, будет еще выводиться число фактически задействованных жил.

Наличие "галочки" приводит к формированию программой на втором и последующих листах форматной рамки с "малым" штампом.

Наличие "галочки" приводит к сортировке кабелей по монтажным единицам и создает дополнительную колонку в таблице КЖ. Это конечно не по ГОСТ/ДСТУ, но испокон веков принято у релейщиков.

Наличие "галочки" приводит к созданию колонки в котором отображается название монтажной единицы

Наличие "галочки" приводит к разбивке по монтажным единицам на отдельных листах. То есть каждая группа кабелей будет начинаться и отображаться на отдельном листе/листах.

Наличие "галочки" приводит к выводу рассчитанной по плану длины кабеля для кабелей, которым назначена фиксированная длина. Более подробно тут

Наличие "галочки" приводит к запросу начальной точки, от которой вправо и сверху вниз будут последовательно расположены листы кабельного журнала.

Наличие "галочки" приводит к расположению форматных рамок по горизонтали. Отсутствие - по вертикали.

Наличие "галочки" приводит к игнорированию фильтрации и выбора кабелей. В кабельный журнал выводятся все кабели что есть в проекте.

Кнопка "Нарисовать спецификацию (раздел)" - позволяет вывести на текущий лист заготовку заказной спецификации в объеме потребностей кабеля.

кнопка "Экспорт в MS Excel" запускает и выводит в Excel таблицу с длинами кабелей и формулами для формирования потребности кабелей

кнопка для вывода в Word кабельного журнала... не используется, ибо не востребована и пока пожеланий вывода именно в Word не было.

Описание сохранения и восстановления типовых наборов настроек

Настроек очень много и они разные для разных условий. Кому-то нравится классика, кому-то вывод как для наладчиков. И переключаться между настройками заморочно. Поэтому создана группа сохранения/восстановления настроек.

Настройки сохраняются в реестре. А посему с проектом не передаются.

Кнопки "MS..." - сохранение (как на бухгалтерском калькуляторе). Кнопки "MR..." - восстановление. Всего можно сохранить 4 настройки. Считаю что больше не нужно (обсуждаемо). Дефолтной не существует. То есть по началу все галочки сброшены и нужно самому настроить конфигурацию и сохранить ее. Перед выводом КЖ восстановить ее.

Created with the Personal Edition of HelpNDoc: Maximize Your Productivity with a Help Authoring Tool


Форматы вывода кабельного журнала

В программе изначально была реализована прорисовка кабельного журнала (КЖ) на листах формата А3 и создание рамки по ДБН (ГОСТ). Это подходило всем. Однако пришли наладчики/монтажники и предложили свой вариант формы кабельного журнала.

Основная идея была в том что монтажники/наладчики при нарезке кабелей готовят и бирки на жилы. В типовом КЖ нет поля с указанием бирок. И приходится искать в других томах проекта схемы или таблицы внешних подключений и т.д. из которых кропотливо выбирать эти самые бирки и вносить в свой КЖ, который им гораздо удобнее. Чтобы облегчить их труд и убрать эту рутину я добавил новую форму КЖ в программу.

Внешний вид нового КЖ такой как показано на рисунке:

Размер строчки фиксированный - 10мм.

Но есть нюанс - количество жил, и количество марок, может быть очень большим и не помещаться в одну строчку. Для обхода этого есть два варианта - динамический размер строки и заполнять следующие строчки. Я остановился на втором варианте. На рисунке ниже показан кабель на 27 жил у которого почти все заняты. Марки жил заполнили несколько строк.

И еще один нюанс - если перечень марок занимает несколько строк и вылазит за последнюю строку, то вся строка переносится на новый лист и рисуется с начала листа. Последние строки на предыдущем листе остаются незаполненные.

Created with the Personal Edition of HelpNDoc: Enhance Your Documentation with HelpNDoc's Advanced Project Analyzer


Панель инструментов "Настройка отображения КЖ и фильтры кабелей"

Плавающая панель инструментов "Настройки отображения КЖ и фильтры кабелей" содержит группу элементов для настройки внешнего вида кабельного журнала на закладке предварительного просмотра.

Панель появляется при нажатии на одноименную кнопку и закрывается если щелкнуть на кнопке с большим красным крестиком или каком либо не занятом поле панели.

Внешний вид панели:

На панели расположены следующие инструменты:

Группа "Параметры отображения"

если поставить галку, то в полях "Откуда" и "Куда" будут отображены не проектные обозначения шкафов, а полные. Полные названия настраиваются на соответствующей закладке описанной тут

Группа "Фильтры кабелей" предназначена для отбора кабелей по каким либо признакам.

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Подраздел «Расчет длин кабелей и выбор трасс для прокладки кабелей»

На этой закладке расположены инструменты для расчета кабельных трасс и расчета длин кабелей.

Более подробно механика расчета описана тут

Подробно как выполнять расчет длин кабелей и формировать кабельный журнал описано тут и тут .

Created with the Personal Edition of HelpNDoc: Make Help Documentation a Breeze with a Help Authoring Tool


Подраздел «Рассчитанные кабельные трассы»

На этой закладке расположены инструменты для более точного определения типов прокладки кабелей по трассе - "в трубе/в лотке/в земле" и т.д.

То есть можно назначить для каждой трассы от шкафа А до шкафа В прокладку каких-то именованных "труб". Понятие "ТРУБА", в данном случае, условное, этакий сленг, применяется для обобщенного обозначения типа прокладки. Под понятием "труба" может быть спрятано как прокладка в гофрошланге, в металлической трубе, в канализации, в лотке, по конструкциям, так и просто в земле.

В трубу можно назначить любое количество кабелей - хоть мульён. Ограничения нет. Пока что. В перспективе ориентация типов прокладки и создания системы контроля заполнения труб.

Трубы не привязаны к конкретному пути. Они привязаны только к координатам на плане. От точки пересечения до точки пересечения. Не обращая внимания на типы участков трассы. Трубы начинаются и заканчиваются в пределах трассы. Если труба занимает часть трассы (несколько секторов), то вполне возможно что она будет видна на другой трассе (которая проходит по этим секторам), и доступна для прокладки в ней кабеля которые идут "транзитом" по этим участкам.

После настройки труб и назначения кабелей трубам все сохраняется в проекте.

При повторном расчете кабельного журнала трубы восстанавливаются, правда при возможности. Это будет происходить только в случае если участки занимаемые трубой. Если при корректировке плана будет сдвинута хотя бы одна координата (точка пересечения, передвинуты отрезки на плане, сдвинут шкаф и т.д.) - труба будет "оторвана" от назначенного ей участка трассы.

Растягивать и перемещать трубы можно мышкой за концы или середину трубы + удерживая клавишу Shift.

Created with the Personal Edition of HelpNDoc: Why Microsoft Word Isn't Cut Out for Documentation: The Benefits of a Help Authoring Tool


Подраздел «Типы кабельных прокладок»

На этой закладке - андэр констракшн )))

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Расчет кабельного журнала

Раздел «Кабельный журнал» ››

I love Ukraine

Расчет кабельного журнала

* Видео инструкция по расчету кабельного журнала находится тут . И тут - с учетом взаимо-резервирования .

Расчет ведется в три этапа:

1) Подготовка расчетного чертежа .

2) Собственно расчет программой длин кабелей

3) Формирование выходных документов.

В двух словах расчет длин кабелей ведется так:

Сначала создаем отдельный чертеж для расчета. Прорисовываем на этом чертеже план объекта, все этажи виды и т.д. - все виды, чтобы можно было проложить реальные трассы. Далее рисуем линиями всевозможные трассы прокладки кабелей, указываем типы прокладки для участков трасс назначая слои для отрезков трассы (всякие лотки, кабель-росты и т. д.). Потом расставляем блоки-маркеры шкафов/ящиков и другого оборудования. Сохраняем обязательно чертеж и смотрим что бы он был активным.

Далее обновляем проект с принципиальной схемой (на всякий случай), запускаем эту программу и считываем проект, запускаем программу на вычисление. Она подключается к автокаду, считывает с активного чертежа все что на нем есть и анализирует. По результатам анализа она или ругается, указывая на ошибку допущенную при составлении расчетной схемы, или выдает результаты - кабельный журнал и наполнение участков кабелями.

Далее (желательно сразу, но не обязательно) нажимаем кнопку сохранения расчета и выводим кабельный журнал в автокад. Так же выводим кусок спецификации, заготовку для подключения в общую спецификацию. При необходимости выдаем в Эксель результаты.

При расчете есть возможность назначить метку кабелям как "взаимо-резервируемые" и тогда программа будет стараться прокладывать кабели по разным трассам. Более подробно как назначить кабели описано тут

Created with the Personal Edition of HelpNDoc: Elevate Your Documentation Process with HelpNDoc's Advanced Features


Подготовка к рассчету

Раздел «Кабельный журнал» ›› Расчет кабельного журнала ››

I love Ukraine

Подготовка к рассчету

Подготовка по шагам:

1 шаг - создать чертеж размещения оборудования;

2 шаг - обновление базы данных проекта;

3 шаг - разместить на чертеже блоки обозначающие ящики/шкафы/оборудование и др. точки подключения кабелей.

Для начала создаем чертеж который будет анализировать программа - это план расположения оборудования.

Как правило этот чертеж берется у первичников/строителей и чистится от всего лишнего. Рекомендую всему изображению плана назначить темно серый цвет - на нем будут хорошо видны кабельные трассы. Так же удобно после чистки объединить получившуюся "подложку" в блок. Или перенести на один какой то слой. Место расположения "подложки" на чертеже абсолютно не имеет значения.

Важно: Используется только пространство модели (Model Space). На листах программа не работает.

Обычно план рисуется в масштабе 1:1. То есть 1 единица на экране соответствует 1 мм. Но можно рисовать в любом масштабе, однако для корректного масштабирования измеренных расстояний нужно будет указать программе как пересчитать в метры. То есть, всегда перед началом первого расчета нужно ввести значение коэффициента пересчета в метры. Введенное число сохраняется в настройках проекта и восстанавливается при повторном открытии проекта программой.

Немножко подробнее про этот коэффициент пересчета:

Аксиома: внутри программы все размеры считаются метрами, вне зависимости от реального масштаба чертежа и введенного коэффициента пересчета.

То есть, при прорисовке кабельного журнала длины кабелей выводятся с обозначением "метры". И это не изменить (по крайней мере никто об том не просил). Но ничем не ограничено измерение в любых других единицах, однако в подписях таблицы кж будет всегда обозначено "метры".

Если выставить коэффициент пересчета "1:1" вы получите длины трасс/кабелей в миллиметрах.

Обычно используются планы объекта в миллиметрах, то есть в масштабе "1:1", но для корректного отображения длин в метрах необходимо выставлять коэффициент пересчета "1:1000", то есть программа будет делить измеренные длины на 1000 и получать длины в метрах.

Таким образом в программе этот "масштаб" - не масштаб чертежа, а коэффициент пересчета в метры, масштаб программы.

Выбранный коэффициент пересчета вводится в поле "Масштаб чертежа". Число набирается в формате:
<число метров> : <число единиц чертежа>
"уууу:хххх" или "0,ххххх". где ххх и ууу - любые числа.
Например: "1:1000", "333:45", "65.456:0.123"

При снятой галочке "Вывод результатов на новой странице" рекомендую план располагать в правом верхнем квадранте, то есть точка "0,0" будет слева внизу чертежа. И отступить от нуля вверх вправо на тысяч 100-200 единиц. Это только для того, что бы выводимые результаты расчета (блоки и таблицы) не налезли на план.

Следующий шаг - считывание обновленной! базы данных проекта, с актуальными значениями. Как это делать написано тут

Далее необходимо нарисовать на плане трассы по которым будут проложены кабели и разместить блоки-маркеры оборудования/шкафов.

Блоков-маркеров должно быть строго по количеству шкафов/оборудования в проекте. Если чего-то не будет, то будет сформирована ошибка и процесс прервется. Например вам нужно протрассировать один кабель между двумя шкафчиками. И при этом в проекте есть 100 тысяч других шкафов. Тут увы без вариантов - нужно разместить на плане все сто тысяч шкафов.

Для создания блоков-маркеров и образцов типов трасс нажимаем на кнопку "Нарисовать на активном чертеже обозначения шкафов/ящиков".

Программа запросит указать в какой точке активного чертежа сформировать заготовки и на нем будут размещены блоки обозначающие шкафы/ящики и др. оборудование к которым идут кабели.

Так же будут начерчены линии на различных слоях - это примеры, "носители типа слоя". Они означают основные типы участков кабельной трассы: "по конструкциям", "кабельный канал", "лоток 35х30", "лоток 50х30" и т.д. Из них должна быть составлены все возможные трассы прокладки кабелей. После создания трасс эти образцы можно удалить.

В результате должно получится такое:

Маркеры шкафов/ящиков - это обычные блоки. А посему ничего не мешает "наполнить" его любым содержимым и любой "динамикой". Однако все атрибуты, их наименование и содержимое должны остаться как есть в блоке созданном программой. Но положение, видимость, стили оформления и текста, цвета и т.д. можно менять по своему усмотрению. Так же наименование блока должно быть или "Kir_box_cabinet_name", или любой длины но начинаться с "Kir_box_cabinet_name". То есть можно использовать наименование: "Kir_box_cabinet_nameХХХХХХХХХХХ"

Следующим шагом необходимо нарисовать пути по которым будут трассироваться кабели. Просто рисуются линии вдоль лотков/направлений и назначается слой соответствующий условиям прокладки. Должно получиться что то вроде этого:

На рисунке трассы показаны желтым цветом, серым нарисован сам план объекта. Для принудительной трассировки необходимо было "отключить" прохождение по неиспользуемому лотку - в одном месте (обведено кружком) трасса была разорвана.

Следует учитывать: что любое пересечение линий трасс - это объединение. То есть в этом месте получатся "перекресток". На этом перекрестке происходит логическое деление отрезка на две половинки.

Для разделения линий и/или для организации связи между различными планами (например переход со второго этажа на третий) предназначен специальный слой перемычки. Он нарисован самым первым, сразу под блоками.

Трассы рисуются в 2Д или в 3Д. Например в 3Д удобно учитывать запасы при вводе в шкафы. или учитывать подъем к оборудованию на стойках и т.д.

Возможно использование полилиний. Дело вкуса. Однако при расчете каждая полилиния виртуально разбивается на составляющие отрезки. Если по одному участку пройдет несколько полилиний - в результате будет только один отрезок, он как бы поглотит все остальные отрезки что проходят параллельно. То есть совпадающие линии объединяются.

При размещении линий необходимо следить за их размещением в 3Д. Если смотреть сверху на план, то можно не увидеть как одна линия проходит НАД или ПОД другой, и значит не будет пересечения - трасса будет разорвана. Это одна из наиболее частых ошибок.

При расположении линий трассы желательно (но не обязательно) что бы линии не стыковались концами а пересекались с небольшим запасом. Проблема в округлении координат - различие может оказаться в последнем разряде и концы отрезков для программы будут не соединенные и путь не будет найден. При анализе "хвостики" в никуда будут отброшены.

Для того чтобы определить откуда и куда тянуть кабель, программа во время анализа чертежа ищет блоки-маркеры шкафов. По этим маркерам определяется где расположены шкафы/устройства и программа уже далее выбирает куда вести кабельные лини по указанным возможным трассам.

Блоки-маркеры обязательно должны быть соединены с трассами. Точка в центре круга обозначает место присоединения конца отрезка трассы (не в середине отрезка!!! только к концам отрезка). Отсутствие соединения вызывает ошибку при анализе плана и останавливает процесс расчета с выдачей сообщения. Точка расположена в координатах (0,0) самого блока.

Часто при размещении блоков-маркеров шкафов все таки промахиваются и оставляют зазор. Для борьбы с этим есть настройка зон захвата. Описание здесь.

Пересечение линий желательно делать "внахлест" как показано на рисунке.

Дело в том что есть возможность увидеть на экране касание/пересечение которого по факту не будет. Как показывает практика зазор будет порядка 1Е-8 мм и менее. Такую ошибку будет найти достаточно трудно. Несмотря на то что я даю зону "захвата" в районе 0,001 миллиметра - все равно бывают "нестыковки".

В случае "нестыковки" трасса будет или проходить не по оптимальному пути (другим найденным окольным путем), или вообще не будет найдена трасса от шкафа к шкафу. В этом случае появится сообщение что такой то шкаф не имеет путей для прокладки, не подсоединен. Сообщение будет выведено в поле логов на закладке "Утилиты".

Для предотвращения таких случаев я разбиваю план объекта на несколько разных кусков, каждый из которых размещаю отдельно на одной плоскости с координатой Z=0. Трассы лежащие на разных кусках при необходимости соединяю между собой блоками обозначающими перемычки. Что это дает? Во-первых все лежит на одной плоскости и гарантированные пересечения, блоки шкафов четко попадают в "кончики" отрезков. И не нужно крутить в 3Д. Я как бы разворачиваю в плоскость объемный чертеж.

На этом подготовка закончена и можно переходить к анализу плана кабельных трасс .

Created with the Personal Edition of HelpNDoc: Maximize Your Documentation Efficiency with a Help Authoring Tool


Настройка зон "захвата" для линий и блоков

Настройка зоны захвата - важный момент при расчете длин кабелей (расчете трасс). Неправильное значение может привести к ошибкам при расчете.

Описание зоны захвата для линий

Описание зоны захвата для блоков

Нюанс при выборе значения зоны захвата

Описание зоны захвата для линий

Теоретически когда, с привязкой даже, совпадают концы отрезков, то считаем что координаты концов совпадают. как бы да, но есть нюансы и числа с плавающей запятой. И вроде бы равные числа координат на самом деле отличаются на миллионные доли. И всё - числа не равны. По изображению на экране это никак не определить. И программа тоже скажет что отрезки не пересекаются ни в какой точке, а значит трасса будет разорвана в этой точке и программа не сможет найти путь.

Для того, чтобы решить эту проблему введено понятие "зоны захвата" - число представляющее собой максимальное расстояние между концами линий, при котором еще считается что отрезки касаются, совпадают. В 3Д координатах это будет шар. Понятное дело что радиус захвата отсчитывается в единицах чертежа. Трассы на моих планах измеряются метрами при единицах чертежа в мм. А посему можно выставлять радиусы до 100 единиц и не сильно заморачиваться с точностью рисования и привязками. Однако это приведет к относительно небольшим неточностям в длинах. Разумнее было бы выставлять такое значение, которое и не требует снайперской точности, и дает удобоваримую погрешность при расчете длин. Чисто экспериментально я пришел к цифре 1...3 единицы (мм) на планах в масштабе 1:1.

Настроить это можно при помощи поля "Зона захвата линий". При первом запуске для ново проекта по умолчанию выставляется число 3 мм.

Чтобы изменить щелкните мышкой по полю и откроется окно с запросом нового значения. Если будет введена строка, которая не может быть преобразована в число, текущее значение не изменится.

Введенные значения сохраняются в настройках проекта и не требуют повторного ввода перед расчетом КЖ.

Если указать значение зоны захвата равной нулю (бог знает когда это может понадобиться), то сравнение значений координат будет выполняться без округления, как есть. Что практически стопроцентно приведет к ошибкам при расчете кабельного журнала - программа не найдет пересечения/касания линий из-за разницы в миллионных долях в координатах концов отрезков, которые представлены числами с плавающей запятой.

Описание зоны захвата для блоков

Часто при размещении блоков-маркеров шкафов все таки промахиваются и оставляют зазор. Пример на картинке.

Помогает повысить точность "попадания" включение режима привязок, но даже это не всегда спасает, если дрожат руки после вчерашнего. На картинке видно что есть зазор в 50 единиц чертежа. На планах размерами сторон в 300 - 400 метров такой зазор практически незаметен.

Для борьбы с этим в программе есть специальная настройка именно для увеличения зоны "захвата" - поле "Зона захвата блоков". Выглядит это так:

Если щелкнуть по нему, то появится диалоговое окно с запросом нового значения. Если будет введена строка, которая не может быть преобразована в число, текущее значение не изменится.

Зона захвата это расстояние от точки вставки блока маркера шкафа. В 3Д это представляет собой шар.

Если при просмотре чертежа блок маркера шкафа окажется возле конца отрезка, но не совпадает с ним, и при этом конец отрезка попадает в зону захвата - блок маркера будет насильно передвинут в эту точку.

Если указать зону захвата равной нулю, то механизм поиска ближайшей точки отключается и точка вставки блока маркера применяется как есть, без какой либо коррекции положения. То есть работает как было до этого.

Нюанс при выборе значения зоны захвата

Есть еще момент который нужно учитывать: Если установить значение зоны захвата достаточно больших размеров, то можно ввести программу в заблуждение и получить неправильный расчет КЖ. На рисунке ниже представлена типичная ситуация. Как видно мы хотим установить блок шкафа с центральным узлом (я так называю точку вставки блока 0,0) "Ш1" в конец линии Л1 - то есть точки Ш1 и Л1 должны совпасть. Но они немного расходятся. Мы даем достаточно большую зону захвата и вроде всё хорошо - программа видит что узлы совпадают. Однако рядом проходят еще трассы и представьте что расстояние до узла Л2 или Л3 будет так же входить в зону захвата. Коллизия. В этом случае работает алгоритм минимального расстояния - узел Ш1 будет совмещен с узлом, который находится ближе всех к нему. И если по каким-либо причинам узел Л2 будет ближе чем Л1 - шкаф "сам прикрепится" к узлу Л2. Так что тут надо быть внимательным или отключать коррекцию установив зону захвата равной нулю.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Виртуальные перемычки

При прорисовке кабельных трасс иногда необходимо указать связь между двумя различными планами. Например - первый и второй этажи здания. Для этого можно воспользоваться линией "Перемычка". Однако если таких связей очень много, выгоднее создавать связи в трассах при помощи специальных блоков-маркеров.

Эти маркеры играют роль ссылок, связывают между собой отдельные участки трасс. На картинке показаны два блока. Над ними видны ссылочные номера "123123". Номера эти условные и могут быть любыми - числа/буквы/фразы и т.д. Абы просто совпадали при поиске.

Программа при анализе плана находит эти маркеры и создает виртуальные линии на слое перемычек между точками вставки блоков. На рисунке фиолетовые линии - это виртуальные линии перемычек между маркерами. Эти линии нигде физически не существуют, они находятся в памяти при расчете. Так связываются между собой только блоки с одинаковым ссылочным номером. Номер у маркера - это признак по которому программа понимает что эти блоки являются фактически одной точкой соединения трасс.

Линиями соединяются между собой ВСЕ маркеры с одинаковым ссылочным номером. Поэтому количество линий перемычек, а значит и вариантов трасс, растет в геометрической прогрессии. Рекомендуется ограничиваться количеством маркеров с одинаковым ссылочным номером порядка 50штук. Хотя это не обязательно и большее количество маркеров просто приведет к пропорциональному росту времени при анализе и выводе результатов. Однако это не сильно критично если количество маркеров будет в разумных пределах (около 50-100 шт).

Блок-заготовка маркера создается при нажатии на кнопку [image] .

Маркеры ссылок - это обычные блоки. А посему ничего не мешает "наполнить" его любым содержимым и любой "динамикой". Однако все атрибуты, их наименование и содержимое должны остаться как есть в блоке созданном программой. Но положение, видимость, стили оформления и текста, цвета и т.д. можно менять по своему усмотрению. Так же наименование блока должно быть или "Kir_BlockPeremTrassaAutoCalc", или любой длины но начинаться с "Kir_BlockPeremTrassaAutoCalc". То есть можно использовать наименование: "Kir_BlockPeremTrassaAutoCalcХХХХХХХХХХХ"

Далее нужно назначить маркерам какой-то уникальный номер (просто отредактировать атрибут сверху блока) и скопировать/перенести его в конец нужного участка на чертеже. Обрабатываются пары, потому блоков должно быть не менее двух штук, один маркер не имеет смысла.

Если на чертеже маркеров слишком много, а компьютер не шибко новый, вполне возможно что системе не хватит ресурсов. Для примера: такое сообщение выскочило когда я создал 500 блоков с одинаковым номером.

Created with the Personal Edition of HelpNDoc: Make Your PDFs More Secure with Encryption and Password Protection


Анализ плана кабельных трасс

Раздел «Кабельный журнал» ›› Расчет кабельного журнала ››

I love Ukraine

Анализ плана кабельных трасс

Собственно сам расчёт запускается нажатием кнопки "Выполнить анализ плана кабельных трасс".

Справа от кнопки находятся поля для настройки зон захвата:

Поле "Зона захвата блоков" предназначено для указания зоны вокруг точки вставки блока-маркера шкафа, в которой будут искаться ближайшие точка концов отрезков трасс.

Поле "Зона захвата линий" предназначено для указания максимального расстояния между концами линий меньше которого будет считаться что линии совпадают концами.

Переключатель "Поправить положение блока" включает механизм "подтягивания" точки вставки блока к концу ближайшего отрезка.

Более подробно механизмы захвата описано в подготовке к расчету .

Дополнительно, перед началом, есть возможность отобрать результаты и выбрать куда будет осуществляться вывод результатов:

"Вывод результатов на новой странице" - все результаты расчета будут выведены на новой странице. Иначе они будут расположены на том же чертеже начиная с точки "0,0" вправо-вниз.

"Условный план" - ну полезность условная... идея была что бы автоматически создавался план прокладки. Что бы программа сама впихивала в лист формата А2 весь план, трассы и располагала обозначения шкафов и кабелей. Идея хорошая, но пока в зачаточном состоянии. Обычно эта галочка снята.

"Перечень - шкафы" - будет сформирован список шкафов из проекта и под каждым обозначением шкафа будет выведен перечень кабелей которые приходят в него

"Показывать линии перемычек" - если установить "галочку" на плане будут нарисованы линии перемычек между маркерами. Насколько нужно... хз, обычно я не устанавливаю эту галочку. Было полезно при отладке, так и прижилось )))

"Кабельный журнал" - сразу выводится рассчитанный кабельный журнал.

"Перечень - участки" - будет сформирован список участков на плане и для каждого участка будет создан перечень кабелей которые проходят по нему.

"Кабельный журнал" - будет сформирован кабельный журнал с нулевыми добавками к длине и без процентного увеличения общей длинны кабеля. То есть привычные 6-8-10% не будут наброшены.

Если на плане нет ошибок (подключены все блоки обозначений шкафов, есть возможность провести кабель, в наличии все шкафы и т.д.) то в результате будет сделано следующее:

- собран перечень всех отрезков кабельных трасс;

- отброшены участки которые идут в никуда;

- собран перечень всех блоков обозначающих шкафы/оборудование;

!если нет на плане какого то блока шкафа (LOC), который есть в проекте, процесс будет остановлен с соответствующим замечанием.

- трассы будут разбиты на отрезки/участки и пронумерованы, рассчитана их длина;

- будут протрассированы все кабели по кратчайшему пути и создана таблица

Created with the Personal Edition of HelpNDoc: Maximize Your PDF Protection with These Simple Steps


Основная ошибка при расчете КЖ

Внимание, всё что описано ниже относится только к методу построения расчетного плана в 2D. Если будет использована возможность просчёта кабельных трасс в 3D, то всё ниже приведенное не имеет смысла. Только для 2D !!!

Собственно часто происходит следующее: схемы нарисованы, вычищены от ошибок, план красиво нарисован, всё расставлено как надо и трассы проложены как нужно. Запускаем расчет и оппа сюрприз - длины всех или части кабелей равны нулю и имеют метку неправильно рассчитанных. Начинается адская переработка всех схем, плана и всего что есть в проекте. Однако ничего не помогает. И все плохие-нехорошие, особенно я ))))

Фишка в следующем - Автокад очень оригинально рисует линии когда находишься в модели и проекция сверху, то есть взгляд сверху на чертеж и координата Z не видна. Он сам как хочет расставляет высоту, руководствуясь какими-то темными мыслями. Но сверху линия будет горизонтальной, а на самом деле она будет под углом.

Смотрим на картинку:

И признак будет такой: нет нумерации участков после "перекрестка".

То есть к точке пересечения, которая образуется ДВУМЯ отрезками, будут подходить четыре участка - те два отрезка исходных как бы логически разделят на до и после точки пересечения. И всем новым четырем участкам дадут свой номер. На картинке ниже четко видно что линия L0001 пересекается, но после точки пересечения нет номера. Значит линия проходит над другой линией, не касаясь её. Визуально пересечение есть а по факту - нет.

Что бы вылечить такое нужно сделать следующее:

  1. С начала рисуем все линии слоёв кнопкой из «шага 2»
  2. Выделяем всё нарисованное, так же добавляем в выделение блоки шкафов и блоки перемычек
  3. Открываем свойства в Автокаде (Ctrl-1)
  4. Выбираем сначала блоки. Выставляем координату Z = 0 (или любое другое приятное число). Я на картинках для примера выставлю 0. Даже если бы выставил 22222222 - ничего бы не поменялось. Главное условие - одинаковая цифра.

было:

стало:

  5. Так же выделяем отрезки и выставляем начало и конец отрезка по координате Z =0

  6. Текст можно не трогать – он ни на что не влияет.
  7. Далее сохраняем получившийся план и делаем заново расчет.

В результате программа найдет пересечения и пометит участки, см. картинку ниже

Created with the Personal Edition of HelpNDoc: Elevate Your Help Documentation with a Help Authoring Tool


Трассировка плана кабельных трасс

Инструмент трассировки путей на расчетном плане предназначен для облегчения поиска ошибок (несовпадений) при размещении блоков маркеров шкафов и концов отрезков трасс.

Идея проста как веник. При расчете в кабельному журнале обнаруживаются "неверные" кабели, для которых программа не смогла найти трассу от шкафа к шкафу. Непросчитанные кабели обозначаются так:

А посему найти где же не совпадают отрезки и/или блоки шкафов - та еще задача. Проще "пустить ручеек" - выбираем шкаф и программа прорисовывает все отрезки, которые нашла.

Запускается "ручеек" кнопкой "Трассировать от шкафа пути". После запуска программа подключится к текущему чертежу и будет предложено выбрать блок. Если вдруг с первого раза не попали в блок, выбрали не тот и тд.., будет предложено или повторить попытку, или прекратить мучить мышку.

В результате программа прорисует все пути от выбранного блока. Прорисовываются линиями толщиной 2 единицы. Поэтому нужно включить отображение весов линий.

После трассировки линии мешают на чертеже. Их можно удалить из программы (кнопка "Удалить линии подсветки трасс") или вручную - выбрать линию и отобрать такие же (меню "выбрать подобные"). Они расположены на отдельном слое и могут быть легко отфильтрованы.

"А теперь слайды"(С) Анек. На рисунках ниже показан план до и после трассировки.

Изображение после трассировки.

После трассировки линии мешают на чертеже. Их можно удалить из программы (кнопка "Удалить линии подсветки трасс") или вручную - выбрать линию и отобрать такие же (меню "выбрать подобные"). Они расположены на отдельном слое и могут быть легко отфильтрованы.

Created with the Personal Edition of HelpNDoc: Step-by-Step Guide: How to Turn Your Word Document into an eBook


Формирование кабельного журнала

Раздел «Кабельный журнал» ››

I love Ukraine

Формирование кабельного журнала

После того как длины кабелей рассчитаны и сохранены в проекте, можно выполнить формирование кабельного журнала. Для этого предназначена группа элементов управления на плавающей панели инструментов "Нарисовать в DWG кабельный журнал". Она расположена на закладке "Кабельный журнал"->"Предварительный просмотр кабельного журнал".

Инструменты и функции панели описаны тут

Created with the Personal Edition of HelpNDoc: Maximize Your CHM Help File Capabilities with HelpNDoc


Вывод кабельного журнала в Автокад

Раздел «Кабельный журнал» ›› Формирование кабельного журнала ››

I love Ukraine

Вывод кабельного журнала в Автокад

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Вывод спецификации в Автокад

Раздел «Кабельный журнал» ›› Формирование кабельного журнала ››

I love Ukraine

Вывод спецификации в Автокад

Created with the Personal Edition of HelpNDoc: HelpNDoc's Project Analyzer: Incredible documentation assistant


Экспорт КЖ в Эксель

Раздел «Кабельный журнал» ›› Формирование кабельного журнала ››

I love Ukraine

Экспорт КЖ в Эксель

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Экспорт в Ворд

Раздел «Кабельный журнал» ›› Формирование кабельного журнала ››

I love Ukraine

Экспорт в Ворд

Пункт пока не работает за ненадобностью.

Created with the Personal Edition of HelpNDoc: Revolutionize Your Documentation Review with HelpNDoc's Project Analyzer


Утилиты для кабельного журнала

Раздел «Кабельный журнал» ››

I love Ukraine

Утилиты для кабельного журнала

В группе утилит и прочих полезностей для кабельного журнала собраны всякие полезные функции для облегчения прорисовки планов кабельных трасс и для расчета кабельных трасс.

Кнопка "Нарисовать обозначения кабелей на плане" - рисует на текущем открытом чертеже обозначение кабеля. Представляет собой прямоугольник с наименование кабеля. Полезно для ручного заполнения плана прокладки кабелей и кабельных трасс.

В результате должно получиться что-то вроде такого:

Для настраивания внешнего вида блока есть три параметра - размеры (высота-ширина) и размер шрифта. Нужные значения вводятся в специальные поля. Если значение какого-либо размера будет равно нулю, то будет использована автонастройка. Размер шрифта автоматически не подбирается - он выставляется как заданный, но не менее 1. То есть нулевую высоту выставить не получится. При автонастройке габариты прямоугольника вычисляются от заданного размера шрифта.

Для наведения дополнительной красоты добавлена возможность задать зазоры между текстов и рамкой. Формат записи "А , В" или "С". Разделитель - запятая. Пробелы игнорируются. Числа могут быть и дробными. В первом случае зазор по горизонтали будет равен "А", зазор по вертикали равен "В". Во втором случае оба зазора будут равны "С".

Если в поле набрать не число, программа не сможет распознать его и это значение будет выставлено по умолчанию - для высоты 3 ед., для ширины 12 ед., и размер шрифта 2 ед, для зазоров "1,1".

Нарисованные прямоугольники расставляются встык по вертикали или по горизонтали, по заданному количеству в ряд. ряды могут наполняться по горизонтали и по вертикали, в зависимости от выбора (кнопки "По горизонтали" и "По вертикали"). Количество элементов в ряду задается в поле "Кол-во в ряд".

Параметры по умолчанию:

Обозначение кабеля представляет собой блок с атрибутом содержащим название кабеля. Положение атрибута фиксированное. Все элементы имеют параметры (цвет, толщину, тип линий) настроенные "по блоку".

В начале создается нужный блок обозначения кабеля. Возможны варианты когда блок уже существует. Тут есть выбор: можно использовать существующий блок, можно его очистить и заново заполнить, можно создать новый. Нужное выбирается переключателем.

При использовании существующего блока:

  • если блока по факту нет то, он создается с параметрами по умолчанию 3х12 ед., заданным размером шрифта (но если шрифт = 0 то и он по умолчанию = 2 ед.) и заданными зазорами.
  • размер шрифта атрибута существующего блока может отличаться от заданного в параметрах рисования. В этом случае размер шрифта устанавливается как заданный. И посему надпись может вылезти за рамки блока.

При обновлении блока:

  • если блока нет то, он создается с заданными параметрами.
  • Если блок есть, то он очищается и заполняется заново.

При создании нового блока:

  • Если блока нет, то просто создается блок с заданными параметрами.
  • Если блок есть, то создается новый блок с другим именем и с заданными параметрами.
  • Имя нового блока всегда будет уникальным - каждый раз при начале операции генерируется новое имя блока с дополнением из случайных символов и проверяется на повтор.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Расчет кабельного журнала из файла Excel

описание алгоритма

Часто появляется такая достаточно нетривиальная задача, как пересчитать существующий кабельный журнал, который предоставляется в файле Excel. Он может появиться бог знает откуда. Например, переданный смежниками, или старые какие-то кабельные журналы и т.д. Вариантов много. Но задача одна - нужно заново вычислить длины. И выхода два: или терпеливо поштучно, "с циркулем в руках", отмерять по плану первичников/строителей/геодезистов длины участков и из них вычислять длины кабелей, или как-то автоматизировать этот процесс.

Собственно что и сделано, автоматизация этого нудного процесса при помощи AutoCAD Electrical. Если коротко то весь путь прост: сначала из перечня кабелей программой создается простенькая принципиальная схема, самая примитивная. Потом по ней вычисляется и создается кабельный журнал.

Видео, как это работает выложено в ютуб-канале, ссылка тут

Внешний вид панельки:

Основная задача - рассказать программе где в файле Экселя искать нужные исходные данные.

Для этого есть группа элементов позволяющих как можно проще выполнить эту операцию.

Самый идеальный вариант - создать заготовку и по ней работать.

Но можно и доработать исходный файл кабельного журнала. То есть указать где что брать.

Для создания схемы (см подробное описание далее) программе нужно несколько значений: тип и марка кабеля (например кабель "EC-100" типа "КВВГнг 10х2,5") и точки "откуда" и "куда" он проложен. Каждая строчка экселя это один кабель.

Значения ячеек "откуда" и "куда" должны содержать текстовые наименования в формате [Inst]=[Loc] или [Место]=[Шкаф]. Разделитель по умолчанию знак равно. Но его можно переопределить на любое другое значение, максимум два символа.

В результате должно получиться нечто: "Цех1=ШР123" - это значит зона "Цех1" и шкаф "ШР123".

Если по каким-то причинам программа не сможет распознать что вы там набрали, то эта строчка не будет обработана и в схеме не будет этого кабеля.

Для указания программе где в таблице искать исходные данные есть ряд полей:

Описание кнопок управления столбцами:

Первая колонка - поля в которых указан номер столбца для выбора имени кабеля. При анализе таблицы Excel из столбца с этим номером буду выбираться имена кабелей.

Вторая колонка - кнопки выбора столбца. В таблице Excel нужно выделить ячейку с заголовком и нажать кнопку. Из ячейки будет извлечен номер столбца и текст заголовка.

Третья колонка - поля с заголовками столбцов. Поле редактируется. Используется для поиска нужного столбца.

Четвертая колонка - кнопки поиска ячейки с заданным названием столбца. При нажатии будет произведен поиск по всему листу. Если ячейка будет найдена, то номер её столбца будет занесен в соответствующее поле номера столбца.

Описание алгоритма:

Весь процесс состоит из трех шагов: подготовка временного проекта, "причесывание" экселевского файла и собственно сам перегон.

Первый шаг - подготовка временного проекта. Для того что бы использовать AutoCAD Electrical для расчета длин кабелей нужно создать простой временный проект из двух листиков чертежей. Почему именно два? Фишка АЭ - когда в проекте всего один лист, АЭ не вносит в базу данных проекта информацию. Увы. И моей программе нечего считывать. А посему я обычно делаю два листа - один схема, второй расчетный план в масштабе 1:1. Просто, дешево и сердито.

Второй шаг - "причесывание" файла Excel с перечнем кабелей. Те, кто создавали файл Excel, ни сном ни духом не ведали что их файл будет использован "не по назначению". А посему расположение и наполнение колонок будет у каждого по своему. Для того что бы программа знала что и где искать - нужно привести этот файл к нормализованному виду и рассказать про это программе.

Для создания схемы подключения кабеля нужны 4 колонки: "Марка кабеля", "Тип кабеля", "Шкаф откуда", "Шкаф куда".

Содержимое первой и второй колонки считываются как есть. Колонки шкафов должны содержать в одной строке два значения: название зоны и название шкафа. То есть содержимое Inst и Loc. В ячейке они разделяются символом разделителем. По умолчанию используется знак равно. При необходимости можно установить свой собственный символ, в соответствующем поле.

Положение колонок этих колонок - произвольное. Главное указать где искать, номер колонки.

В результате должно получится что-то вроде такого:

Третий шаг - запуск на исполнение.

К этому моменту запущен Автокад, создан любой активный чертеж и список кабелей в Excel подготовлен ("причёсан").

Нажимаем на большую кнопку в левом верхнем углу окна и ждем результата.

Программа по очереди перебирает все строки активного листа Excel. От первой и до последней. В каждой строчке ищет ячейки с маркой кабеля, его типом и обозначения "откуда" и "куда". Проверка каждой строки может закончится или принятием данных или отбрасыванием из-за некорректных данных. Если хотя бы одна ячейка из четырех пустая, значит нет необходимых данных и строка будет отброшена.

Количество строк для обработки запрашивается у Excel. И тут есть нюанс - иногда Excel говорит что заполнены данными все! ячейки, которых овер дофига, и программа вынуждена проверять каждую строчку. Это может затянутся надолго - минуты или десятки минут. Однако когда закончится считывание и формирование списка кабелей, начнется рисование кабелей на листе. Это гораздо быстрее.

Во время процесса руками Excel и AutoCAD Electrical лучше не трогать, нужно дождаться окончания обработки.

После считывания данных из таблицы Excel, по ним строится принципиальная схема в активном листе Автокад.

Результат будет выглядеть так:

Слева используется универсальный блок обозначения шкафа с двумя точками подключения, "двусторонний". Справа используются два блока односторонние, "левый" и "правый".

Универсальные блоки:

Односторонние блоки:

Теперь лист чертежа можно закрывать и обновлять базу данных проекта (считывая программой или вручную через меню автокада, как нравится). После повторного считывания проекта видим появившиеся шкафы, зоны и кабели. Проверяем их на корректность и запускаем расчет длин кабелей, весь процесс описан тут

Created with the Personal Edition of HelpNDoc: Easily convert your WinHelp HLP help files to CHM with HelpNDoc's step-by-step guide


Раздел «Клеммники»

I love Ukraine

Раздел «Клеммники»

Это страница с инструментами позволяющими оперативно (насколько это возможно в AutoCAD Electrical) просматривать клеммники шкафов, находить в чертежах выбранные клеммы, редактировать клеммники, выводить в чертежи внешний вид и схемы внешних подключений, передавать в CLIP PROJECT (Phoenix Contact), считывать и выводить в виде таблицы ВОМ клеммных рядов, и т.д .

Настоятельно рекомендуется перед началом работы с клеммниками

при считывании или перед считыванием проекта

обновлять базу данных

Внешний вид закладки:

Строка "Нет описания клеммника" - обозначает место где можно разместить необходимое общее поясняющее описание клеммника. Оно при желании будет выведено над наименованием клеммника при прорисовке в Автокаде клеммника. Иногда полезно для пояснений. Что бы изменить это поле - просто дважды щелкнуть левой кнопкой мышкой по нему и в открывшемся поле ввести нужную строку.

Инструменты управления:

Все инструменты расположены на "плавающей" панельке, которая прячется и не мешает просмотру. При наведении курсора на розовую полоску она появляется.

Кнопка «Нарисовать клеммник» - позволяет нарисовать выбранный клеммник на текущем открытом листе АЭ.

Кнопка «Нарисовать фрагмент клеммника» - позволяет нарисовать только выбранные клеммы.

Кнопка «Нарисовать клеммники как один» - позволяет нарисовать выбранные клеммники в один ряд, как на одной дин-рейке

Кнопка «Редактировать клеммник» - открывает новое окно редактора выбранной клеммной колодки.

Кнопка «Найти клемму в АКАДЕ» - просто ищет в чертежах проекта выбранную клемму и открывает в АЭ найденный чертеж, позиционирует экран на найденной клемме.

На закладке "Инструменты" расположены следующие кнопки:

Кнопка «Экспорт в ClipProject» - генерирует файл в формате xml, для передачи в ClipProject, для дальнейшего редактирования и формирования красивого внешнего вида клеммника и создание ВОМ (перечная элементов) клеммника.

Кнопка «Спецификацию в АКАД» - считывает ВОМ клеммника созданный в ClipProject и формирует на чертеже отформатированную таблицу перечная элементов клеммника. Есть возможность вывести как таблицу АЭ или просто прорисованную из линий и ТЕХТ.

Кнопка «Создать перечень клемм» - просто рисует в отрытом чертеже перечень клемм, спецификацию. Переключатель "запрос начальной точки" определяет - запрашивать точку вставки или рисовать в 0,0 верхний левый угол таблицы.

Кнопки «Обновить блоки клеммников» - обновляют все найденные блоки клеммников на текущем чертеже или по всему проекту. Более подробно механизм обновления описан тут

-- //--

На закладке "Всякое" расположены следующие кнопки:

Кнопка «Распаковать блоки клемм» - распаковывает сохраненные внутри программы (в ресурсах) чертежи блоков клемм. Дело в том что имена блоков определяют для программы тип клемм: проходная или испытательная. И в зависимости от типа прорисовывается по разному клеммник. Например:

сверху показаны клеммы 20...22 - это испытательные, клеммы 23-26 - обычные проходные

Кнопка «Сортировка по номерам» - удаляет для новых клеммников существующий внутренний порядок расположения клемм в клемном ряду, сортирует клеммы по их номерам и записывает положение каждой клеммы в блок клеммы. Для старых клеммников происходит только сортировка и запись положения клеммы. Эта кнопка полезна для открытия и обработки клеммников/проектов созданных еще очень старыми версиями программы.

Кнопка «Обновить LinkTerm всем клеммам» - это "костыль". Я как то рисовал клеммы просто копируя их. И клеммники работали и все было хорошо. Но стал замечать что клеммы стали исчезать из перечня. Оказалось что если в этом поле не содержится или уникальное для клемм число, или ноль, то срабатывает механизм считающий что это не отдельные клеммы, а уровни одной клеммы. То есть логика - это две клеммы в одной, первый и второй ярусы не связанные между собой. К стати их можно соединить невидимой перемычкой - штатные средства АЭ, и перемычка сохраняется в свойствах чертежа. Поэтому я и ввел этот инструмент который разрывает эти связи устанавливая в это поле ноль или случайное число - выбор при помощи чекбокса.

Эта группа пока не работает. И не знаю заработает ли когда ни будь.

На экране показан пример клеммника шкафа РЗА. При построении изображения клеммника клеммы сортируются по возрастанию внутренних номеров от 1. Внутренний номер не отображается на экране, техническая информация. Он отображает позицию в клемном ряду и позволяет "оторваться" от видимого номера клеммы. Это дает возможность иметь несколько клемм с одинаковыми номерами и/или располагать клеммы в клеммном ряду вне зависимости от номера клеммы.

Но в процессе редактирования клеммника, есть возможность отсортировать клеммы по номерам (как было ранее). Наименование клеммы делится на две части: [текстовая][численная]. Сортировка производится сначала по текстовой, а затем по численной. Таким образом корректно обрабатываются клеммы с марками типа "*12", "А12" и т.д.

Если в процессе построения клеммника попадается нарушение последовательности: нет следующего логичного номера (то есть за клеммой с номером 1 должна идти с номером 2 и т.д. по возрастанию с шагом единица) или есть несколько одинаковых, то "неправильная" клемма подсвечивается желтым цветом для облегчения поиска. Если попадаются две и более клемм с одинаковым номером, то они выводятся в случайном порядке, вторая и последующие клеммы подсвечиваются.

У дерева клеммников есть небольшой фильтр и кнопки быстрого доступа. При наборе символов в поле имени шкафа/клеммника отфильтровываются только те клеммники/шкафы у которых в имени есть вхождение этих символов.

Кнопки позволяют быстро свернуть/развернуть дерево и сбросить фильтр.

Контекстные меню (PopUp Menu)

Контекстное меню в дереве клеммников позволяет: - перейти к шкафу в дереве шкафов на закладке "Связи между шкафами", свернуть или развернуть дерево клеммников.

Контекстное меню у каждой клеммы позволяет осуществить быстрый поиск выбранной клеммы, аналогично кнопке «Найти клемму в АКАДЕ»:

На изображении клеммника можно выделять как отдельные клеммы, так и группы клемм.

Если в предпросмотре клеммного ряда щелкнуть по перемычке, то будет выделена перемычка и все последующие, связанные с ней, перемычки. То есть в куче перемычек можно легко увидеть нужную последовательность. Чтобы снять выделение просто щелкнуть по пустому полю, вне перемычки.

Если в предпросмотре клеммного ряда дважды щелкнуть по перемычке, то будет выделена сначала верхняя клемма, а при повторном щелчке будет выделена и показана, если вне окна, другая клемма перемычки.

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Описание принципов работы с клемником

Раздел «Клеммники» ››

I love Ukraine

Описание принципов работы с клемником

При открытии проекта, сделанного с помощью предыдущих версий этой программы, до версии 20.35, будьте внимательны - сортировка клемм в программе уже не работает так, как она работала ранее.
Если есть необходимость работы/переделки/распечатки клеммника, то необходимо просто открыть в редакторе каждый клеммник и проверить порядок клемм. При необходимости сортировки клемм "как раньше" воспользоваться кнопкой [image] на панели.
При выходе согласиться для внесения изменений. Увы, другого пути нет. Так же можно воспользоваться штатным редактором клеммных колодок.
Сделал маленькое видео о том как обновлять клеммники - рекомендую ознакомиться

Считаю что важно понимать что клеммник это набор не именованных клемм. То есть это безликие, без номера, просто набранные в ряд зажимы разных форм и конструкций.

Далее на них лепится нумерация например "1, 2,3...128". И как принято на территории пост совка - в шкафу РЗА есть только ОДИН клеммник со сквозной нумерацией, и все клеммы нумеруются начиная с 1, с левого верхнего угла левой половины шкафа. Бывает разделяют этот клеммник по функциональным группам, однако нумерация все равно не прерывается. Ебанутое решение. И многие потихоньку отходят от него. На роZZии это древнее требование закреплено законодательно. Бггг.

Импортные проектировщики такой ерундой не заморачиваются и нумеруют клеммы как им удобно. В шкафу как правило они устанавливают несколько отдельных клеммников. Посмотрите клеммники в приводах выключателей АВВ, Сименс и др. Там есть и пустые клеммы, там есть и разрывы типа: "110,111,112, 210, 211, 212, 310, 311, 312". И есть всякие обозначения типа 112, 112a, 112b, и т.д. Клеммные ряды всякие разбитые по смыслу - отдельно для токовых цепей, цепей напряжения, выходных цепей и т.д.

В предыдущих версиях программы сортировка клемм была примитивной - по номерам. То есть клеммы выстраивались согласно их номеру. Поменял номер и клемма "перепрыгнула" на новое место. Однако не было никакой возможности поставить клемму с номером "10" перед клеммой с номером "9". Это конечно просто, но хреново - гибкости не было.

Теперь все происходит просто - при первом! открытии клеммной колодки в редакторе, клеммы сортируются как обычно, по номерам, и прорисовывается обычный клеммный ряд. Но дополнительно клеммы последовательно нумеруются скрытой нумерацией (которая не зависит от номера клеммы), создавая последовательность клемм, которая запоминается в программе (на время текущего сеанса редактирования клеммной колодки). Далее при необходимости редактируется расположение клемм. И при выходе из редактора вновь созданный или отредактированный порядок клемм сохраняется в атрибутах блоков обозначающих клеммы. Причём используется штатный механизм АЭ. Что позволяет менять порядок как в штатном редакторе клеммных колодок, так и в программе - результат будет одинаковый.

В этом случае вы можете рисовать ЛЮБЫЕ номера клемм в любом порядке, сортировать ЛЮБЫЕ группы клемм, переименовывать и перемещать ЛЮБЫЕ группы клемм - этот порядок будет запомнен в чертежах и будет восстанавливаться при последующих считываниях проекта.

Created with the Personal Edition of HelpNDoc: Make Documentation a Breeze with HelpNDoc's Clean and Efficient User Interface


Редактирование клеммника

Раздел «Клеммники» ››

I love Ukraine

Редактирование клеммника

После осмотра клеммника и осознания неизбежности рихтовки оного, вызываем редактор выбранного клеммника кнопкой «Редактировать клеммник» [image] она открывает новое окно редактора выбранной клеммной колодки. Окно появится только в случае выбора именно клеммника

Внешний вид окна редактирования клеммника:

как видно в окне схематично нарисованы клеммы и кабели подходящие к нему.

Окно при открытии вписывается в правый угол экрана, занимая пол экрана. Если последовательно открывать окна разных клеммников, то окна будут открываться последовательно заполняя экран.

Клеммы для редактирования можно выделять по одиночке или группами. По одиночке выделяются простым щелчком по изображению клеммы:

Группу можно выбрать щелкая с шифтом или контролом. Выделяем первую клемму, зажимаем "Shift" и щелкаем по другой клеме. Выделяется диапазон между первой и второй клеммами. Если щелкать с "Ctrl" - выделяются по одной.

Для снятия выделения нужно щелкнуть за полем клеммника, по другой клемме или выбрать кнопку меню.

Доступны следующие команды:

- самая важная кнопка - расставить клеммы по номерам клемм игнорируя текущий порядок. То есть как было ранее - просто сортировка по назначенным номерам.

- выйти из редактора. При наличии сделанных изменений в клеммнике будет предложено:

- сохранить изменения в проекте

- выделить все клеммы или снять выделение с клемм соответственно

- сдвинуть выделенные клеммы вверх или вниз соответственно

- оптимизировать перемычки и расположение клемм.

-перенумеровать клеммы

- переименовать клеммник, например "ХТ1" в "ХТ3"

-найти выбранную клемму в чертеже (откроется чертеж в АЭ и на чертеже будет найдена эта клемма, экран будет отмаштабирован на эту клемму)

-изменение номера/марки клеммы или группы клемм. Если другой командой перенумеровать, то счетчик будет расти (...11,12,13...) Этой командой можно всем выбранным клеммам назначить одно имя без всяких счетчиков.

- клемма удаляется из базы и из ЧЕРТЕЖА!!! Отмены команды нет. Перед действием будет выдано предупреждение:

- перенести выбранные клеммы в ДРУГОЙ клеммник. Более подробно описано тут .

- создание/изменение маркировочной колодки. Маркировочная колодка всегда привязана к какой то клемме и сохраняется в блоке клеммы в атрибуте DESC3. На примере ниже показана маркировочная колодка с надписью "Струм ст 110 кВ". Если в АЭ на чертеже выбрать блок клеммы и в редакторе свойств

В чертеже АЭ клемма №7 выглядит так:

- группа выбора типа для клеммы/группы клемм и изменения его. Если нажать на кнопку будет выдан запрос:

Настройки редактора выполняются в меню:

пункт меню "Редактор поверх всех окон" - переключает окно в режим при котором оно будет всегда "плавать" поверх всех остальных окон

пункт меню "Закрыть и сохранить каждый файл" - если отмечен (как на картинке) пункт, то при внесении изменений файл чертежа будет открываться в АЭ, вноситься изменения и файл будет закрываться с сохранением. Если пункт не отмечен - файлы будут оставаться открытыми в АЭ. Иногда полезно.

пункт меню "Обмен номерами при перемещении" - если пункт отмечен, то при сдвиге клемм они будут обмениваться номерами с клеммами, на место которых они становятся. Иначе они просто будут сдвигаться вверх/вниз.

Так же все команды доступны через всплывающее меню:

Created with the Personal Edition of HelpNDoc: Make Documentation a Breeze with HelpNDoc's Clean and Efficient User Interface


Перетаскивание клемм по ряду

Для удобства ручной сортировки есть возможность выделить и перетащить в нужное место одну или группу клемм. Есть маленькое видео про то как я делаю рихтовку клеммного ряда.

Сначала выделяем клеммы, кликаем на клемме или на группе клемм для выделения. Далее наводим мышку на клемму (или на любую в выделенной группе), которую собираемся перетащить, и нажимаем левую кнопку мыши. Не отпускаем. Через 1 сек включится механизм перетаскивания - курсор поменяет внешний вид, а сама клемма станет зеленого цвета. И далее тянем ее в нужную позицию, на другую клемму. При этом клеммы над которыми проходит курсор будут подсвечиваться зеленым цветом, для облегчения навигации и прицеливания. Подведя к выбранной клемме отпускаем кнопку мыши и смотрим как клеммы переезжают в выбранную позицию.

При перетаскивании всегда нужно учитывать несколько нюансов:

  • Номера клемм при перетаскивании могут меняться, а могут не меняться. То есть если кнопка "обмен номеров при перемещении" не включена - номера клемм на новой позиции сохраняются как были, клеммы переезжают на новое место со своими номерами. Если включена, то порядок номеров клемм сохранится как до перемещения и сдвинутые клеммы получат новые номера.
  • Всегда есть "ведущая" клемма в группе выделенных и перетаскиваемых. От нее ведется отсчет. Она та клемма на которой нажали левую кнопку мыши и начали перетаскивание.
  • Клемма, в позицию которой будут перемещены выделенные клеммы, будет сдвинута в сторону конца клеммника.
  • Перетаскиваются только выделенные клеммы. Если клемма, над которой нажали левую кнопку мыши и начали перетаскивание, не выделена, то она будет принудительно выделена в начале перетаскивания.
  • Выделенные клеммы будут установлены в в новую позицию в том порядке, в котором они расположены до выделения, пересортировка не выполняется.

И теперь слайды, как будет это происходить:

Created with the Personal Edition of HelpNDoc: Make Documentation Review a Breeze with HelpNDoc's Advanced Project Analyzer


Перенос клемм в другой клеммник

Иногда в процессе нужно изменить назначение уже нарисованных клемм. Это значит что клемма будет перенесена в другой выбранный шкаф или ящик. Для переноса необходимо в чертеже изменить значения атрибутов выбранной клеммы, что и делает эта программа.

При нажатии на кнопку откроется меню выбора целевого клеммника.

Выбрав существующий клеммник и нажав кнопку "Выбрать клеммник" программа определит что нужно откорректировать в чертежах и в полностью автоматическом режиме внесет изменения.

Клеммы можно перенести в любой существующий клеммник, или перенести в несуществующий/новый.

Несуществующий - это означает что в проекте еще нет деталей/элементов/клемм с выбранным наименованием места расположения (Inst), наименованием шкафа (Loc) и наименованием клеммного ряда.

Если в списках выбрать кнопку "Новое месторасположение" или/и "Новый шкаф" или/и "Новый клеммник", то есть не указать конкретно куда переносить, и нажать кнопку "Выбрать клеммник" то, естественно, программа не понимает куда собственно нужно запихнуть эти клеммы. И поэтому открывается новое окно, в котором нужно ввести вручную наименования места, шкафа и клеммника. Так же можно сразу выбрать этот вариант нажав кнопку "Создать новое место".

Заполнив поля и нажав кнопку "Выбрать клеммник" программа автоматически откроет чертежи и заполнит необходимые атрибуты.

Очень рекомендуется после такой корректировки клеммного ряда обновить базу данных проекта. Дело в том, что внутри программы остался "слепок" состояния ДО корректировки. И клеммы перенесенные в несуществующий клеммник просто "висят" в воздухе, удаленные из старого клеммника и не подключенные к новому клеммнику. То есть становятся недоступными для корректировки из программы.

Если из какого-то клеммника были перенесены ВСЕ клеммы, то окно редактирования будет закрыто с соответствующим сообщением ибо клемм для редактирования в этом клеммнике просто нет. Но сам клеммник, хоть и пустой, но остается. То есть в него можно напихать другие клеммы.

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Вывод рядов зажимов в AutoCAD

Раздел «Клеммники» ››

I love Ukraine

Вывод рядов зажимов в AutoCAD

Общее описание

Группа "Общие настройки"

Группа настроек "Для задания заводу"

Группа настроек "Для внешних подключений"

Группа настроек "Расположение кабелей"

Группа настроек "Выбор цвета для прорисовки"

Группа настроек "Название шкафа клеммника "

Общее описание

Прорисовка клеммника всегда осуществляется в текущий открытый лист в Автокаде. Абсолютно не обязательно в AutoCAD Electrical. Выводится в любой Автокад.

Клеммники прорисовываются согласно выбранным настройкам, описанных тут . Есть возможность создать собственные конфигурации прорисовки клеммников и сохранить в проекте или реестре.

Для вывода выбранного клеммника или группы клеммников в AutoCAD Electrical делаем следующее:

  1. Выделяем в дереве клеммников нужный клеммник (на примере выделен клеммник "ХТ" шкафа №1);

Выбрать можно не только отдельный клеммник, но и целиком весь шкаф. Или даже весь проект. Из выбранного будет составлен список клеммников для рисования, отсортирован и нарисован в Автокаде.
  2. Нажимаем кнопку [image] и откроется панель с настройками, как показано на картинке:
  3. Далее настраиваем параметры рисования клеммника и запускаем на исполнение.

Кнопка запускает выполнение операции прорисовки клеммника с выбранными настройками.

Кнопка отказаться от задуманного и закрыть окно

Ссылка на эту страницу хэлпа. Если хэлп не скачан будет открыта в браузере ссылка на страницу с хэлпом в инете

Параметры прорисовки клеммника собраны в группы:

Группа "Общие настройки":

- перед прорисовкой клеммника появится запрос начальной точки, верхний левый угол клеммника.

- нарисованное изображение клеммника будет повернуто на 90гр.

- прорисовывает испытательные и др. типы клемм соответствующим УГО, если не установлена все клеммы рисуются одним условным изображением.

Группа настроек "Для задания заводу":

- клеммник анализируется и разбивается последовательно на группы клемм для того что бы вписать в форматную рамку А3. Иногда очень полезно - экономит время при распечатке. Лазерный принтер быстро справится с несколькими сотнями листов, покуда струйный пережуёт огромные листы типа А2х3 и больше. получится нечто такое:

- Переключатели "Указать типы клемм" и "Указать производителя" - прорисовывает за каждой клеммой заказной номер изделия и название производителя. На картинке выше показан именно такой вариант.

- после того как будет нарисован клеммник/клеммники, они будут расставлены в форматные рамки. Минимальный формат - А3. Если клеммник не помещается, то формат рамки будет подобран в сторону увеличения так, что бы поместился самый большой клеммник. Оставшееся свободное поле будет заполнено остальными клеммниками так, что бы пустое пространство было минимально. Иногда эффективно распихивает, если не может подобрать размер рамки тупит.

- выбор пока не работает. Думаю как красиво реализовать это.

Группа настроек "Для внешних подключений":

Данная группа настроек формирует радость монтажников - рисуночки подключения кабелей.

- аналогично вышеописанной настройке. Клеммник анализируется и разбивается последовательно на группы клемм для того что бы вписать в форматную рамку А3. Вид безошибочный, но чертовски неудобный для монтажников.

- клеммник рисуется в чертеже в виде блока с определенным индивидуальным именем блока. Включение этой настройки включает сопутствующие настройки:

- действие переключателя аналогичное описанному выше. Надо учитывать что выполнение этого может растянутся надолго. Если допустим будете рисовать шкаф с 10-20 клеммниками разного размера то время подбора может затянутся на десятки минут. Подбор осуществляется по 10 бальной шкале на 5-8. Иногда достаточно эффективно выполняет, иногда неприемлемо и приходится расставлять вручную.

- Самая полезная функция. :) При прорисовке блока с клеммником, сначала на текущем чертеже ищется существующий блок. Если он найден, то он очищается и заполняется заново. Таким образом происходит обновление.
Пример: у вас есть раздел внешних подключений. И там нарисована куча этих блоков. В результате каких то изменений - добавились кабели/клеммы, любые изменения требующие перерисовки. Просто открываем чертеж и нажимаем кнопку нарисовать (ессно с галочкой "обновить") - вуаля, блок сам перерисован в секунду.

- переключатель меняет форму прорисовки и заполнение полей клеммника. Это не по правилам ("Правила составления рядов зажимов для низковольтных комплектных устройств подстанций" 8205тм-Т1 от 1 июня 1979года), но как по мне более информативно. Так сказать это моя кнопочка и мне она больше нравится.

- в поле можно задать значение зазора (в милиметрах) между блоками при их расстановке в форматную рамку.

Группа настроек "Расположение кабелей":

В этой группе задается сторона и направление подключение кабелей. Нажимая кнопки мы можем выбрать ориентацию клеммника для левой или правой боковины и подход кабелей сверху или снизу. При выборе на предпросмотре показывается виртуальный клемник, это не тот который был выбран. Смысл просто напомнить как будут выглядеть кабели при прорисовке.

Кнопка "Автоопределение" пока не работает. Кнопка "Без кабелей" включает ориентацию для левой половины шкафа.

Группа настроек "Выбор цвета для прорисовки":

В этом поле можно назначить цвет для рисования клеммника. По умолчанию - по слою. Кнопка "выбор" открываем меню выбора цвета. Выбранный цвет будет отображаться прямоугольником. Так же для выбора цвета можно щелкнуть по цветному квадратику.

При прорисовке клеммника будет подобран ближайший в Автокаде цвет.

Очень удобно для контроля изменений. Допустим все клеммники были нарисованы желтым цветом. При изменении новые клеммники (или при обновлении существующих) рисуются зеленым - всегда можно узнать какие клеммники были изменены.

Переключатель "Разноцветные кабели" - отменяет цвет рисования клеммника и рисует кабели различными цветами. Цветов всего шесть из восьми доступных. Если кабелей больше чем шесть то цвет повторяется. Шесть цветов - что бы чертеж в монохроме всегда был черно-белым. Если цвет сделать произвольным, то даже при назначении монохрома при печати клеммник останется цветным. В результате получится что-то вроде этого:

Группа настроек "Название шкафа клеммника":

Идея в том что когда нарисована куча клеммников сам черт ногу сломит что за клеммник если он не подписан. А поэтому выводится надпись однозначно идентифицирующая что за хреновина нарисована. Режимы можно выбрать в меню выбора режима отображения названия шкафа в котором расположен клеммник. Надпись располагается над верхом клеммника:

Описание клеммника - любая текстовая строка. Задается при просмотре клеммника. Выводится если поставить переключатель "Выводить описание клеммного ряда".

По пунктам сверху вниз:

- при печати надпись не будет видна - она рисуется на defpoints. В надпись вносятся LOC и INST клеммника. Полезна при навигации, что бы не забыть что за клеммник нарисован.

- Надпись содержит только проектное обозначение шкафа, код в проекте - LOC.

- Надпись содержит проектные обозначения шкафа и зоны, код в проекте - LOC и INST.

- Надпись содержит полное длинное описание шкафа, оно заполняется в таблице описаний - на закладке "Наименования"

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Настройка параметров изображения клеммного ряда

Прорисовка рядов клеммных зажимов выполняется согласно выбранной настройке - этакой кучке параметров определяющих внешний вид - высоту и ширину клемм, размер шрифта для поля клеммы, набор полей для клеммы, размер треугольничка входа жилы в кабель, высота "шапки" клеммника и т.д.

Есть три варианта настроек:

- фиксированная, моя собственная ( как мне нравится, рекламации не принимаются )

- фиксированная строгая, согласно 8205тм-Т1 "Правила составления рядов зажимов для НКУ" ЭСП, 1979г.

- пользовательская, терпеливо настраивается юзером под себя.

Выбирается тут:

Если выбрать переключатель "По бразильски" (слева вверху на картинке), то новый пользовательский стиль блокируется и его настройки не используются. Используется старый вариант рисования, как было до этой версии.

Если нажать кнопки "По умолчанию" и "По 8250тм-Т1", то колонки клеммника будут настроены соответственно по двум предустановленным конфигурациям. Первая - это старая конфигурация, которая мне нравится. Вторая четко соответствует "8250тм-Т1".

Пояснение: идея была в том, что для прорисовки рядов зажимов будет ВСЕГДА пользовательская конфигурация, но настраивать ее под фиксированные можно при помощи соответствующих кнопок на панели настроек.

В любой момент текущий стиль можно подкорректировать - удалить/добавить колонку, поменять размер шрифта, поменять высоту клемм, поменять размер треугольника.

Текущий стиль можно сохранить как в проекте, так и в реестре.

При открытии проекта, из него считывается сохраненная конфигурация и настраиваются параметры рисования клеммника. Если текущая конфигурация настроек была изменена, то при окончании рисования/закрытии окна будет предложено или сохранить новую конфигурацию, или отменить изменения.

Стиль прорисовки подключения жилы к кабелю

На чертеже AutoCAD Electrical позволяет подключить до 12 кабелей. Вернее можно присобачить гораздо больше, но это уже паранойя. Да и 12 тоже. Реально количество кабелей не превышает четырех в наихудших случаях. Мы имеем в виду обычную проходную клемму, без всяких "вторых этажей" или доп отводов. Там другой разговор.

Программа поддерживает прорисовку до 4 кабелей, и в универсальном режиме до бесконечности.

В программе есть два условных типа клемм: проходная/транзитная и обычная. Названия тоже условные

На картинке в "Ящик 1" клемма обычная, кабели могут подключаться только с одной стороны. Вторая "занята" проводом идущим внутрь шкафа к приборам.

Ниже в "Ящик 2" показана проходная/транзитная клемма - к ней подключаются только кабели.

Исходя из этого и есть два вида прорисовки подключений - к транзитной и к обычной клемме. Они более подробно показаны тут по ссылке

.

Есть три варианта изображения. Нужный выбирается в этом поле:

Самый удобный это третий "Универсальный". Он позволяет показывать любое количество кабелей. Выглядеть это будет так:

Как видно просто рисуется горизонтальная линия и в месте входа в кабель рисуется треугольник.

Самый простой это первый "Без скосов". Линии просто "упираются" в стенку клеммника.м На картинке ниже показано изображение 4х жил к проходной клемме - по две с каждой стороны.

И обычный это "Со скосами" (я хз как назвать правильно такой стиль).

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Изображения подключения кабелей к клемам

Тип клеммы: | Обычная клемма | Проходная/транзитная клемма
Вид на схеме AutoCAD Electrical |  |
Без скосов
Подключение одного кабеля |  |
Подключение двух кабелей |  |
Подключение трех кабелей |  |
Подключение четырех кабелей |  |
Со скосами
Подключение одного кабеля |  |
Подключение двух кабелей |  |
Подключение трех кабелей |  |
Подключение четырех кабелей |  |

Created with the Personal Edition of HelpNDoc: Effortlessly Create High-Quality Help Documentation with a Help Authoring Tool


Вывод нескольких клеммников как один клемник

Прорисовка нескольких рядов клеммных зажимов выполняется так же как и одного клеммника.

В дереве клеммников нужно указать какие клеммники нужно нарисовать. При этом активизируется кнопка "Нарисовать клеммники как один". Выбрать для прорисовки можно только:

      • Один шкаф. Все клеммники этого шкафа будут прорисованы как один клеммник.
      • Несколько клеммников одного шкафа. Они будут объединены и прорисованы как один клеммник.

Выглядит так: или

Запуск на выполнение осуществляется кнопкой "Нарисовать клеммники как один". В остальном выполняется аналогично - откроется окно настройки параметров прорисовки клеммника и далее команда рисования.

Выбранные для прорисовки клеммники сортируются в порядке возрастания имен.

Например:

Выбраны клеммники в дереве: | Получилось в результате:

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Экспорт в ClipProject

Раздел «Клеммники» ››

I love Ukraine

Экспорт в ClipProject

В программе есть возможность передать список клемм выбранного клеммника или группы клеммников в программу Clip Project от Phoenix Contact. Для чего это делать? В программе Clip Project есть возможность легко получить точную спецификацию "до последнего болтика". Получить внешний вид клеммника и перенести его в свой проект. Причем сделано это очень удобно. Обмен осуществляется при помощи файла описания клемника в формате XML.

Для переноса в Clip Project делаем следующее:

- выделяем в перечне клеммников какой либо клеммник или шкаф (для вывода группы клеммников)
Например выберем "ШКАФ №16"

- нажимаем кнопку "Экспорт в Clip Project" и на запрос куда сохранить файл "ШКАФ №16.xml" указываем любую отдельную папку.

- запускаем программу Clip Project

- в меню программы выбираем пункт как показано на рисунке:

- дожидаемся окончания загрузки...

- далее удаляем все перемычки.

Программа переносит в Clip Project все клеммы и все перемычки. Однако из-за специфики организации клемм, перенести корректно их практически никогда не удается. Поэтому удаляем и вручную расставляем на клеммнике. После нажимаем кнопку автокорректировки [image] и Clip Project устанавливает все неободимые крышки и концевые упоры.

- после формируем спецификацию. Выбираем в меню Clip Project пункт "Обмен данными"-"Функция экспорта"

- в открывшемся меню снимаем "галочки" с пунктов "Панель клемм" и "Спецификация", устанавливаем галочку на пункте "Спецификация проекта". Выбираем путь для сохранения и нажимаем "ОК".

- в результате должны получить сообщение о успешном завершении:

- в папке будет создан файл "ШКАФ №16.txt" со спецификацией. Что бы не переносит ее вручную в проект в программе есть кнопка: - нажимаем ее и ищем файл "ШКАФ №16.txt". Дале указываем точку на чертеже куда будет вставлена таблица. Получится что-то вроде этого:

Замечание: Некоторые типы клемм моя программа не знает, поэтому словесное описание необходимо будет ввести руками. Я по мере необходимости наполняю ее, но весь каталог забивать в программу не имеет смысла.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Обновление блоков клемников в проекте

Раздел в процессе написания...

Created with the Personal Edition of HelpNDoc: Maximize Your Reach: Convert Your Word Document to an ePub or Kindle eBook


Фильтрация перемычек

В окне предпросмотра клеммников есть возможность выполнить фильтрацию перемычек по маркам цепей. Это позволяет игнорировать перемычки и делать менее захламленный клеммник на стадии разработки схем.

Предыстория. Работал с клеммником на 400+ клемм и не малая часть из них была с заземлением. В схемах, естественно, назначил их соединение с "заземлением" (УГО "земля") и дал марку провода "GND". А так как таких клемм было огромное количество и все в разнобой. В результате клеммник выглядел как пьяный ёжик. Мало того что мешал просмотру, так еще и внешний вид как спросонья. Неудобно. Тем более такие перемычки выполняются через дин-рейку - клеммы желто-зеленые с ножами которые врезаются в дин рейку. То есть перемычки между ними можно не показывать, и так ясно что и как.

Поэтому сделал механизм фильтрации по имени. Результат порадовал, удобненько. На картинках ниже видно что перемычки и линии соединений исчезли.

До фильтрации: | После фильтрации:

Так можно убрать любую/любые перемычки с заданной маркой цепи. Количество игнорируемых цепей не ограничено. Но обобщающие символы пока что не используются. То есть нужно задавать список полных названий.

Фильтр это просто текстовое поле (а-ля Блокнот) в котором каждая строка содержит одну марку. Через запятую/двоеточие и прочее - не работает. Каждая строка = только одна марка цепи.

После того как набрали список игнорируемых марок нужно обновить клеммник, выполнить фильтрацию. Нажимаем кнопку "Update" - клеммник будет перерисован с учетом перечня.

Внешний вид поля фильтрации: | Описание кнопок
 | Кнопка "Update" - выполняется обновление предпросмотра Кнопка "Clear" - выполняется очистка списка

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Раздел «Наименования»

I love Ukraine

Раздел «Наименования»

При разработке проекта удобно давать короткие обозначения шкафов/ящиков. Например, ящик стоящий на ОРУ 110 кВ в проекте можно обозначить как "ЯЗВ1-W1H". Однако, при выводе схем внешних подключений и других схем, будет более понятно если шкаф будет обозначен как "ОРУ 110 кВ. Ящик зажимов выключателя ВЛ-110кВ ЯЗВ1-W1H". Поэтому и был создан механизм позволяющий менять названия шкафов при создании выходных документов.

На закладке расположена таблица с перечнем всех шкафов/ящиков и т.д. присутствующих в проекте. В неё вводятся правильные "длинные" наименования. Содержимое таблицы сохраняется при закрытии проекта (выход из программы или обновление-пересчитывание проекта) в каталоге проекта в виде обычного текстового файла с именем: "<Имя проекта>_FullNameBox.txt".

Формат этого файла прост. Начинается файл всегда с наименования раздела "[FullName]" - эта строка должна идти самой первой. Далее перечисляются построчно обозначения шкафов в формате: <короткое обозначение>=<полное название>. Например: "ШКАФ №3=ОПУ. Шкаф РЗА №3". После первого открытия проекта автоматически создаётся новый файл и обновляется существующий. В виду того что количество шкафов/ящиков/щитков и т.п. может быть очень велико удобно перенести содержимое в Microsoft Excel или Word и там отредактировать строки простым поиском и заменой. Далее скопировать отредактированные строки обратно в указанный выше файл.

При создании файла поля заполняются начальными значениями "<короткое обозначение>=(<короткое обозначение>)". Например: "ШКАФ №3=(ШКАФ №3)".

Внешний вид закладки:

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Раздел «Файлы проекта»

I love Ukraine

Раздел «Файлы проекта»

Эта закладка содержит инструменты для оформления и управления файлами проекта.

На панели расположены общая таблица с перечнем файлов проекта и дополнительные группы инструментов. В таблице приведены относительные пути к чертежам проекта, номера листов и номера схем. Путь к чертежу вычисляется относительно расположения файла WDP. Снизу расположены группы для навигации по списку - отбор файлов, поиск файла, сортировка файлов и фильтрация списка по какому либо признаку.

Над таблицей находятся следующие панели инструментов:

  • "Общие данные" - набор инструментов для формирования отформатированного и оформленного перечня чертежей входящих в проект.
  • "Счетчик страниц" - набор инструментов для заполнения счетчиков в главной надписи и в счетчике страниц.
  • "Вывод на печать" - набор инструментов для печати в PDF всего или части проекта.
  • "Сборка/Разборка" - набор инструментов для сборки на один лист чертежей проекта или разбивки по форматным рамкам выбарнного чертежа проекта
  • "Полезности" - набор различных инструментов облегчающих отдельные рутинные операции.
  • "Настройка Автокада для печати" - набор инструментов для настройки автокада под автоматическую печать проекта или выбранных чертежей.

Внешний вид панели инструментов:

Описание таблицы

Столбец "Номер листа" содержит порядковый номер листа в томе. Это последовательная нумерация, сквозная в пределах всего проекта. Поле с номером находится в правом верхнем углу форматной рамки чертежа.

Столбец "Номер схемы" содержит порядковый номер чертежа. Поле с номером расположено в штампе форматной рамки чертежа.

Столбец "Имя файла" содержит относительный путь файлу с чертежом проекта.

При начальном заполнении таблицы чертежи не сортируются и приводятся в последовательности как указано в проекте, в файле WDP. При необходимости есть возможность отсортировать строки. Щелчок мыши по заголовку таблицы производит пересортировку строк по возрастанию значений в том столбце, по заголовку которого был сделан щелчок.

Группа "Поиск файла"

Позволяет производить поиск чертежей по названию, номеру чертежа/листа. При нажатии на кнопку "Найти в таблице чертеж" производится поиск и выделяется первая найденная строка. Поиск осуществляется с первой строки. Условия поиска вводятся в поля "Маска имени файла", "Номер чертежа" и "Номер листа". В поле "Маска имени файла" можно набрать не полное имя файла, а часть входящую в имя файла. Во время поиска будет проверятся список файлов построчно, начиная с первой строки. В случае обнаружения совпадения по какому либо полю поиск прекращается и строка выделяется. Если выделенная строка находится вне текущего экрана ("спряталась" за краем), то экран прокручивается до ее появления.

Группа "Редактирование"

Позволяет выбирать или сбрасывать выделение файлов и изменять порядок строк в таблице. И при необходимости отсортировать в том порядке в котором они расположены в проекте.

Кнопка "Выбрать все" - выделяет все строки в таблице для последующих операций

Кнопка "Очистить выбор" - снимает выделение со всех строк

Кнопка "Вверх" и "Вниз" - сдвигает выбранные строки вверх или вниз соответственно. Следует учесть что это НИКАК не влияет на порядок расположения файлов в проекте. Это может быть необходимо в исключительных случаях, например для печати.

Кнопка "Сортировка по WDP" - возвращает последовательность файлов согласно последовательности в проекте.

Группа "Редактирование"

Позволяет отфильтровывать список по какому-либо признаку и по части имени файла. Кнопка с крестиком "Х" - сброс фильтров.

Если при применении команд, которые подразумевают возможность обработки одного или более чертежей, в момент пуска команды на исполнение не будет выбран ни один файл - считается что пользователь хочет обработать ВСЕ файлы в проекте. И будет выдано соответствующее предупреждение с запросом на продолжение.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Подраздел "Общие данные" - формирование перечня чертежей

Раздел «Файлы проекта» ››

I love Ukraine

Подраздел "Общие данные" - формирование перечня чертежей

Группа "Общие данные"

Внешний вид панели инструментов:

При помощи этой панели можно сформировать и нарисовать на текущем чертеже в AutoCAD стандартную таблицу перечня наименований чертежей входящих в проект. Перечень оформляется как стандартная таблица AutoCAD.

Список может быть

Есть три режима форматирования таблицы выбираемые в группе "Формирование выходной таблицы":

  • "В рамки формата А3" - В этом режиме таблица общих данных разбивается на куски и располагается в отдельных рамках формата А3.

Поле [image] определяет число строк на форматном листе А3.

  • "В одну рамку формата А4х" - В этом режиме делается подбор наиболее оптимальной форматной рамки среди всех возможных форматов. Перебор форматов осуществляется по возрастанию высоты рамки. То есть сначала идет А4 портрет, потом А3 горизонтально, потом А4х3 и так до Ах9, далее проверяется форматы А3 портрет, А2 горизонтально, А3х3 и так до А3х7, далее А2 портрет и так по всем 28 форматам.
    Для каждого формата осуществляется расчет количества столбцов, максимального количества строк в столбце. По ним вычисляется занимаемая площадь. Наиболее оптимальной считается форматная рамка у которой оставшаяся незанятая площадь будет минимальной.
    Такой вариант очень удобен если со временем будут добавлены чертежи в проект и не хочется менять количество листов общих данных - просто "растет" в длину таблица и вслед за ней форматная рамка.
  • "Без рамки, просто таблица" - В этом режиме таблица остается как есть, без подбора форматной рамки, в виде одного большого столбца.

- Переключатель меняет режим "сворачивания" последовательных номеров в короткую строку. Например есть ряд страниц с номерами 1,2,3,4,5 с одним названием чертежа "Схема такая-то". При снятой галочке в таблице будут нарисованы пять строк с одинаковым названием чертежа. При установленной галочке будет создана одна строка с названием чертежа и в поле номер будет приведено: 1...5

- В этих полях можно выбрать разделители номеров чертежей для включенного режима "сворачивания" номеров.

- Переключатель выбирает какие поля в чертежах использовать для нумерации чертежей в таблице - сквозную нумерацию листов или нумерацию чертежей.

- Кнопка запускает операцию на исполнение. Таблицы рисуются на текущем открытом чертеже.

Created with the Personal Edition of HelpNDoc: Effortlessly Spot and Fix Problems in Your Documentation with HelpNDoc's Project Analyzer


Подраздел "Счетчик страниц" - нумерация листов

Раздел «Файлы проекта» ››

I love Ukraine

Подраздел "Счетчик страниц" - нумерация листов

Группа "Счётчик страниц"

Полезный набор инструментов для автоматической нумерации листов в проекте.

Дело в том что в АЭ поддерживается всего один счётчик. Как правило он используется в поле "Лист" штампов. И когда в проекте необходимо делать две нумерации, сквозную для листов и индивидуальную для чертежей, то это не реально. Для решения этой проблемы и создана эта группа.

Для перенумерации листов необходимо задать в поле начальное значение и через запятую приращение. ТО есть например нумерация с номера 5 с шагом 12 будет выглядеть так: "5,12". Дополнительно можно ставить префикс в начальном значении - какие либо буквенные обозначения . Например "А1,1" - начальное значение "1", префикс "А", приращение "1". И нумерация будет А1, А2,А3 и т.д.

После нажатия кнопки "Заполнить поле" программа будет последовательно открывать в AutoCADе чертежи. Последовательность берётся из таблицы. Последовательность действий такая:

  • Открывается лист
  • Ищется форматная рамка
  • В форматной рамке ищется атрибут и его значение корректируется
  • Закрывается лист с сохранением.

Если открытом чертеже рамка не будет найдена, чертёж закрывается без изменений. Счётчик будет увеличен на заданное приращение. Пропусков в счёте из-за не найденной рамки не будет.

Если рамка будет найдена, то в ней будет заполнено поле счётчика следующим вычисленным значением.

Если будет найдено несколько рамок, то они сначала будут отсортированы последовательно и потом для каждой рамки будет вычислено новое значение как для нового листа. К стати это признак нескольких рамок на одном листе! В этом случае номер в списке "прыгнет" больше чем на приращение. Описание алгоритма сортировки рамок приведено тут

Что бы программа могла найти рамку она должна представлять из себя блок и иметь определённое имя. Имя блока форматной рамки ОБЯЗАТЕЛЬНО должно содержать строку "RamkaESKD". Например "RamkaESKD_A3L_UkrFrm3_вер321".

Счётчик листов это обычный атрибут с заданным именем "MyCountList".

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Подраздел "Вывод на печать" - вывод в PDF чертежей

Раздел «Файлы проекта» ››

I love Ukraine

Подраздел "Вывод на печать" - вывод в PDF чертежей

Группа "Вывод на печать"

Для того что бы автоматизировать вывод на печать большого проекта листов в 300-500 есть два пути:

      • вручную перелопатить все чертежи
      • использовать штатные средства AutoCAD, так называемую подшивку
      • использовать встроенные функции программы.

Подшивка AutoCAD - инструмент заточенный под использование листов. Но это эффективно только при каком-либо проектировании (например территориальные, строительные или 3D) при котором необходимо расставлять на листах нескольких видовых экранов с проекциями из ModelSpace. Это слишком сложный и мощный инструмент требующий долгой индивидуальной привязки листов. И в случае изменения размера форматной рамки, изменения формата листа - необходимо все заново настраивать. Это нудно и долго.

При рисовании обычных схем как правило не имеет смысла использовать листы и никто не заморачивается с такими изысками и просто рисуют всё на ModelSpace. И функции АЭ заточены под использование ModelSpace. Поэтому для облегчения этой рутинной операции я создал функцию печати проекта.

Основной смысл - что бы не зависеть от какого-либо конкретного принтера, как сделано в Подшивке, печать производится в стандартный принтер "DWG To PDF". Но для правильной работы этой функции необходимо выполнить несколько простых условий:

      • выполнить настройку принтера (делается автоматически из программы)
      • использовать именованные форматные рамки с фиксированными именами
      • размещать в одном файле dwg одну форматную рамку.

Более подробно как работает механизм печати описано тут

Группа "Вывод на печать"

В группе собраны управляющие элементы для настройки и выбора режимов печати.

Большая кнопка "Печать в PDF" осуществляет запуск на исполнение функции печати.

Поле "Префикс" - редактируемое и содержит префикс имени PDF файла/файлов.

Выпадающий список поля "Стиль" - содержит перечень файлов стилей. При необходимости можно вписать нужный стиль.

Чекбоксы (галочки):

      • "Собрать в один файл" - собирает в один файл PDF весь проект
      • "Подготовка к печати" - производит сортировку в группы по размерам форматных рамок (А4, А3, А2, А4х3 и т.д.). Каждая группа собирается в один PDF файл и ему присваевается определенное имя содержащее наименование формата и количество листов. Например "Format=A3 landscape_(20 pages).pdf" или "Format=A2x3_(2 pages).pdf"
      • "Вставить дату" - в имя файла вставляется строка с текущей датой. Например: "Схемы_принципиальные_(2019-02-08).pdf" Данная опция применима только к отдельным файлам PDF и к сборке.
      • "Указать формат" - в имя файла вставляется строка с наименованием формата. Данная опция применима только к отдельным файлам PDF .
      • "Имя DWG файла" - в имя файла вставляется строка с именем чертежа dwg. Данная опция применима только к отдельным файлам PDF .

Если не установлена галочка "Собрать в один файл", то каждый чертёж будет перегнан в один отдельный файл. Если галочка установлена, то все файлы будут собраны в один суммарный и отдельные файлы будут удалены за ненадобностью.

В случае если на чертеже будет обнаружена больше чем одна форматная рамка, они будут отсортированы и последовательно распечатаны. Описание алгоритма сортировки рамок приведено тут

При начале печати производится запрос на место сохранения. Указанный пользователем путь сохраняется в реестре и при последующей печати восстанавливается при выборе пути сохранения.

Если будет выбрана опция "Подготовка к печати" результирующие файлы будут собраны в отдельную папку "CollateToPrn"

К сожалению если будет запущен процесс, то прервать его возможности нет. Только убить процесс через диспетчер задач. Тоже самое происходит при падении/зависании автокада - программа зависает наглухо.

Таким образом что бы распечатать проект в PDF необходимо сделать следующее:

  • Настроить виртуальный принтер "DWG to PDF". Выполняется единожды, только в первый раз. Дело в том что в настройках принтера нет таких уникальных форматов типа А4х3 и т.д. Настройка позволяет добавить их в список поддерживаемых форматов. Выполняется настройка кнопкой [image] . Процедура настройки максимально автоматизированна и в большинстве случаев отрабатывает автоматически, без необходимости вмешательства в процесс. Однако если программа не сможет найти где расположен файл "DWG To PDF.pc3" и файл "DWG To PDF.pmp", то будет выдан запрос на выбор каталога с этими файлами. После настройки программа сможет сама определять форматы, настраивать принтер и выводить корректно на печать.
  • Выбрать группу файлов в таблице. Если не будет выбран ни один файл, то программа выдаст запрос на обработку всех файлов в проекте.
  • Настроить желаемые параметры (описаны выше).
  • Нажать кнопку [image] .

Сборка файлов в один производится сторонней утилитой "pdftk". Она "вшита" внутрь программы и перед распечаткой распаковывается на диск "C:\PDFTK". Поэтому после окончания распечатки будут появляться DOS-окна во время работы программы pdftk.

Created with the Personal Edition of HelpNDoc: Ensure High-Quality Documentation with HelpNDoc's Hyperlink and Library Item Reports


Подраздел "Сборка/Разборка" - разбивка на отдельные рамки и сборка на один лист

Описание инструментов сборки чертежей

Описание инструментов разделения чертежей

Настройка параметров разделения для разных групп форматных рамок

Описание алгоритма разделения чертежей

Группа "Сборка/разборка"

В этой группе собраны инструменты для разделения чертежа на отдельные файлы содержащие по одной форматной рамке на один файл.

При разработке проекта удобно держать все схемы на одном чертеже. Но для работы таких функций AutoCAD Electrical как нумерация штампов, настройка ссылок между чертежами и т.д. необходимо разбивать этот общий файл на отдельные файлы, каждый из которых содержит по одной форматной рамке. Вручную делать это не удобно, а посему этот процесс был автоматизирован.

Более подробно механизм разделения описан тут: подробное описание механизма разделения .

Внешний вид группы:

Операции сборки/разборки производятся как над одним выбранным файлом, так и над группой файлов выделенных в таблице чертежей. .

Описание элементов управления сборки:

Кнопка запускает процесс сборки форматных рамок на один текущий лист. Будут по очереди открыты в AutoCAD Electrical и скопированы оттуда форматные рамки на текущий лист. Рамки выстраиваются в ряд по горизонтали.

Переключатель выбора начальной точки. Если он включен, то будет выдан запрос указать на чертеже точку вставки. Если переключатель не включен, то вставка осуществляется в начало координат, в нулевую точку - 0,0.

Переключатель направления сборки чертежей. По умолчанию чертежи располагаются в одну линию по горизонтали. Если включить переключатель, то чертежи будут выстраиваться по вертикали.

Переключатель выбора элементов для копирования. Если выключен, то копируется только форматная рамка и все что внутри нее. Если включен - копируется все что есть в чертеже.

Важный переключатель режима копирования чертежей. Если выключен то выбранные чертежи будут просто расположены по горизонтальной или вертикальной линии. Если включен, то скопированные чертежи располагаются исключительно по горизонтали и разбиваются на группы. Перед каждой группой вставляется блок "Карандаш" с параметрами группы чертежей.

Кнопка "Прервать операцию". Во время выполнения сборки чертежей, кнопка увеличивается и становится активной.При нажатии прерывает сборку.

Поле выбора сортировки чертежей. При сборке на один лист удобно что бы чертежи группировались по смыслу.
Группировка может быть следующая:

  • по описанию - будут выбраны наименования чертежей из штампов и отсортированы в группы по совпадению
  • по чертежу - будут собраны в группы по значению поля "чертеж" в свойствах чертежа.
  • по разделу - будут собраны в группы по значению поля "раздел" в свойствах чертежа.
  • по подразделу - будут собраны в группы по значению поля "подраздел" в свойствах чертежа.
  • по каталогу - будут собраны в группы по наименованию каталога в дереве проекта.
  • без сорт. - без сортировки, как и было ранее

Описание элементов управления разборки:

Кнопка запускает процесс разбивки файла чертежа на отдельные файлы с одной форматной рамкой в файле.

Поля содержат маски имён блоков форматной рамки и штампа. Поиск производится по совпадению части имени блока с указанной в поле маской, без учета регистра. Например блок с именем "MySmallPageESKD_A3_V1.01" будет опознан как штамп. Если поля не заполнены используются значения по умолчанию - они указанны на картинке.

Если переключатель установлен, то будет открыто диалоговое окно с запросом указать путь для сохранения разбиваемых файлов. Если переключатель не установлен, то по умолчанию новые файлы будут расположены возле исходного.

Если переключатель установлен, то новые файлы будут перезаписывать существующие с таким же именем. Полезно при повторном разбиении.

Если на чертеже, предназначенном для разбивки, будет обнаружен только ОДНА форматная рамка, то, если переключатель установлен, файл будет обработан аналогично многорамочным: будет сделана его копия и считано содержимое штампа для внесения в проект.

Если переключатель установлен, то перед делением каждый файл будет скопирован в резервную копию, с именем: <имя фала>_ALL.dwg

Если переключатель установлен, то исходный файл будет удален. Однако, если файл содержит только одну рамку и не переключатель установлен "создавать резервный файл", то он не будет удален.

Создание заготовки специального блока настроек (неофициальное название "Карандаш", в котором содержатся параметры используемые при добавлении созданных файлов в проект

Настройка параметров разделения для отдельных групп форматных рамок

Назначение блока настроек «Карандаш». При разделении файла проекта на отдельные чертежи по форматным рамкам возникает необходимость корректно подключить полученные файлы обратно в проект. Простая замена исходного чертежа на группу новых файлов оказывается неудобной: в дереве проекта появляется множество однотипных элементов с одинаковыми описаниями, а в папке — чертежи с неинформативными именами, расположенные рядом с исходным файлом.

Да, можно вручную переименовывать, заполнять описания, группировать… но это утомительный и долгий процесс. Гораздо эффективнее — заранее задать правила, по которым программа сама выполнит нужные действия. Пусть компьютер сам разбирается — у него голова железная. :)

Именно для этого предназначен специальный блок настроек «Карандаш». Он создаётся автоматически при помощи кнопки «Создать заготовку блока "Карандаш"».

Блок содержит три ключевых параметра:

  • Базовое имя файлов группы — используется при именовании новых чертежей;
  • Наименование каталога в дереве проекта — определяет, куда в проекте будут добавлены файлы;
  • Описание чертежей — отображается в дереве проекта.

Внешний вид блока не имеет значения — вы можете изменить его по своему вкусу. Главное — сохранить имя блока и названия атрибутов. Точка вставки блока служит указателем на область, к которой относятся чертежи.

Чтобы автоматическая обработка группы чертежей сработала корректно, блок настроек «Карандаш» необходимо разместить напротив выбранной полосы форматных рамок. Важно, чтобы точка вставки блока находилась по вертикали внутри группы рамок — это служит ориентиром для алгоритма.

На иллюстрации (штрихпунктиром) показаны границы, по которым программа сортирует рамки. Если в процессе сортировки программа обнаруживает блок «Карандаш», указывающий на соответствующую группу, она применяет к этой группе параметры из блока: имя файлов, описание, каталог в дереве проекта.

Если блок отсутствует — алгоритм работает по умолчанию, как и раньше.

⚠️ Важно: если по каким-либо причинам на одну и ту же группу рамок указывают два блока настроек, программа выбирает один из них случайным образом. Это поведение непредсказуемо, поэтому рекомендуется избегать таких ситуаций.

Назначение полей (сверху вниз):

  • базовое имя файла (шаблон), от которого будут созданы наименования файлов чертежей с добавлением счетчика. Например "файл_001", "файл_002" и т.д. Обычно, если не распологать на чертеже блоки настроек, то в виде шаблона используется имя чертежа который разделяется на чертежи - как было ранее. Если в имени файла использовать недопустимые символы, или оставить поле пустым, или произойдет еще какая-то ошибка, то тоже процесс не прервется, а так же будут использованы в роли шаблона значения пути и имени по умолчанию - имя файла который разделяется.
    Если при создании имени файла для очередной рамки окажется что такой файл существует, то найденный файл не будет перезаписан. Счетчик будет последовательно увеличиваться на единицу до тех пор, пока не будет найдено "свободное" место, уникальное имя файла. Однако если включить переключатель [image] , то тут алгоритм меняется - найденный файл будет перезаписан при условии что это не файл проекта.

Расширение имени файла не учитывается, при подготовке обрезается и назначается стандартное ".dwg". То есть в поле можно набирать просто "Мой_файл", а не "Мой_файл.dwg". Любое расширение отбрасывается и не участвует в формировании имени нового файла.

Имя может содержать путь к папке куда будут перенесены все файлы группы. Путь может быть относительным относительно пути к файлу который разделяется. Например "Папка назначения\имя_файла", "..\..\Папка назначения\имя_файла", "С:\Папка1\Папка2\имя_файла", "Папка назначения\".

  • Базовое имя файла (шаблон). Один из ключевых параметров блока «Карандаш» — базовое имя файла, которое используется как шаблон при создании новых чертежей. К каждому имени автоматически добавляется числовой счётчик, формируя уникальные имена:

например, файл_001.dwg, файл_002.dwg и так далее.

Если блок не размещён на чертеже, программа по умолчанию использует имя исходного файла, как это происходило ранее.

Обработка ошибок. Если в шаблоне имени: используются недопустимые символы, поле оставлено пустым, или возникает любая другая ошибка, то процесс не прерывается. Вместо этого программа автоматически подставляет имя исходного файла и путь к нему как базу для формирования новых имён.

Проверка уникальности. При создании имени для очередного чертежа программа проверяет, существует ли уже файл с таким именем. Если файл найден, он не перезаписывается — счётчик увеличивается до тех пор, пока не будет найдено уникальное имя. Однако, если включён специальный переключатель перезаписи, алгоритм меняется: найденный файл будет перезаписан, если это не файл проекта.

Путь и расширение. Расширение файла в шаблоне игнорируется — программа всегда присваивает стандартное расширение ".dwg". То есть можно указать просто "Мой_файл", без ".dwg". Имя может содержать путь к папке, куда будут сохранены все файлы группы.

Путь интерпретируется относительно исходного файла, который разделяется. Путь может быть:

относительным — например: Папка назначения\имя_файла, ..\..\Папка\имя_файла;

абсолютным — например: C:\Проекты\Чертежи\имя_файла;

или просто названием папки: Папка назначения\.

Если в нужно указать путь без указания имени файла, то просто нужно закончить строку слэшем. Например "C:\Проекты\Чертежи\". Если слэш не указать, то последнее название "Чертежи" в примере будет интерпретировано как имя файла.

Если у всех или некоторых блоков настроек будет задано одинаковое значение базового имени файла, то будет выдано предупреждение - обнаружены разные группы рамок, а имена файлов у них будут одинаковые. Это не ошибка! Ничего ужасного не произойдет. Это прото подсказка, мол обрати внимание на возможное упущение - зачем ставил разные блоки настроек для групп рамок если у них будут создаваться одинаковые имена файлов? Хотя может так и надо.

Пояснение: после того как для первой группы рамок была создана группа файлов с номерами, например: "файл_001.dwg", "файл_002.dwg" ... "файл_005.dwg", далее начнет обрабатываться следующая группа рамок и нумерация файлов начнется снова с единицы, а значит имена файлов будут: "файл_001.dwg" итд. Но эти файлы уже существуют. И потому они будут пропущены, будет найден последний файл "файл_005.dwg" и вычислено новое последовательное имя "файл_006.dwg". И так далее для остальных рамок

Если было вызвано переименование группы файлов (да хоть весь проект), и во время обработки какого-то файла произошло что-то аномальное (сбой, зависание акада, ошибка или еще что-то, что привело к невозможности разделить нормально файл), то процесс для всех файлов не будет прерван - будет пропущен только указанный файл, а операция продолжится над остальными чертежами. Однако если будет какой-то критический сбой - операция будет перкращена с соответствующим сообщением.

  • имя папки в дереве проектов, в которую будут добавлены новые файлы.
  • базовое описание чертежа, которое будет отображаться в дереве проекта

Блок настроек должен располагаться на одной линии с форматными рамками, к которым относятся эти настройки.

Created with the Personal Edition of HelpNDoc: Effortlessly Publish Your Word Document as an eBook


Описание сборки проекта на один лист

Цель создания этого инструмента была в том чтобы упростить процесс сборки/разборки существующего проекта.

Допустим у нас есть старый проект, ...надцати летней давности. И вдруг всплыла необходимость его подкорректировать. Вряд ли кто-то вспомнит нюансы. То есть нужно просмотреть проект заново. А он раскидан по листам. И переключаться по листам очень неудобно. Тем более вносить изменения. Необходимо вернуть к исходному виду - собрать чертежи на один лист. Да, можно вручную открывать каждый чертеж и копировать. Однако если в проекте больше полусотни чертежей, то это займет очень много времени. Неплохо было чтобы можно было в автоматическом режиме собрать проект на один текущий лист. Но, не просто собрать, а с возможностью вернуть как было - разбить его на отдельные чертежи.

Результат работы функции сборки Для этого и создана функция "Собрать чертежи на один лист". Она копирует чертежи выделенные в таблице файлов проекта на текущий лист. При этом она не только копирует, но и расставляет специальные блоки настроек "Карандаш" - для запоминания организации чертежей в проекте. В содержимое этих блоков настройки будет использовано при разбивке чертежа на отдельные файлы по форматным рамкам.

В результате будет нечто вроде этого как на изображении слева.

Указанная возможность работает только если включен переключатель "Создавать карандаши". Если он выключен, то происходит обычное копирование выделенных чертежей в одну линию, по вертикали/горизонтали.

Created with the Personal Edition of HelpNDoc: Leave the tedious WinHelp HLP to CHM conversion process behind with HelpNDoc


Подраздел "Настройка Автокада для печати" - инструменты для настройки печати

Раздел «Файлы проекта» ››

I love Ukraine

Подраздел "Настройка Автокада для печати" - инструменты для настройки печати

Для того чтобы корректно работали функции вывода на печать необходимо немного настроить AutoCAD Electrical.

Вывод чертежей осуществляется только на встроенный принтер "DWG to PDF". Почему именно этот встроенный принтер? Да потому, что он есть всегда! И не нужно искать какие-то сторонние программы. Но его стандартные настройки форматов бумаги не содержат наши дополнительные форматы типа А3х4 и т.д. Я добавил их. Хранятся настройки принтера в файлах "DWG To PDF.pc3" и "DWG To PDF.pmp". Теперь осталось запихнуть эти файлы в нужные каталоги автокада.

Чтобы пользователи не маялись в поисках чего и куда впихнуть, я автоматизировал этот процесс. И собрал в одно поле все кнопки для настройки.

Группа "Насройка автокада для печати"

Внешний вид группы:

Для настройки принтера "DWG to PDF" достаточно нажать самую верхнюю и большую кнопку. При этом будет найден в реестре путь к каталогу с настройками принтеров и туда скопированы файлы настроек. Сами файлы с моими настройками упакованы внутри программы и просто распаковываются в нужный каталог.

Однако может получиться так что путь не будет найден. В этом случае будет показано сообщение и рядом с программой создаётся каталог со всеми необходимыми фалами. Эти файлы придется перенести вручную.

Тоже самое касается и шрифта "WWCADE.SHX". Он не обязателен, но я к нему привык. Он устанавливается автоматом. Хуже не будет.

Кнопки "Папка шрифтов" и "Папка с настройками принтеров" - открывают проводник с соответсвующими каталогами. Это работает если в реестре будут найдены правильные пути.

Кнопка "Установить PDFTK" - распаковывает на диск "С", папку с программой PDFTK. Дело в том что встроенный принтер не умеет собирать несколько pdf файлов в один. Вот я и подключил бесплатную програмку для сборки в один файл. Бонусом идет "обертка" к некоторым функциям (как я посчитал наиболее востребованным). Панель управления находится тут

Created with the Personal Edition of HelpNDoc: Free Qt Help documentation generator


Подраздел "Полезности" - всякие полезности инструменты

На этой панели расположены всякие полезные утилиты.

Внешний вид панели инструментов:

Операции производятся как над одним выбранным файлом, так и над группой файлов.

Описание элементов управления:

Кнопка просто открывает в Автокаде выбранный файл. Если Автокад в данный момент не работает, то он будет запущен и в нем будет открыт файл. Если комп медленный, то может быть превышен таймаут ожидания и будет сбой. Рекомендуется в таком случае просто подождать загрузки автокада и повторить операцию.

Кнопка открывает Проводник и выделяет в списке фалов выбранный файл.

Кнопка очищает выбранные фалы. Это обычная команда "Purge" повторенная три раза. Повтор необходим из-за вложенных в блоки элементов, которые появляются после удаления блока. Иногда и трех раз мало.

Кнопка превращает выбранные чертежи из "живых" в формате AutoCAD Electrical в обычные, нарисованные чертежи. Все примитивы взрываются штатными средствами. Выполняется аналогично как описано тут.

Кнопка запускает обновление перекрёстных ссылок в выбранных чертежах. Считаю что самая полезная кнопка. Выполняется последовательное открытие чертежей и запуск команды АЭ на обновление ссылок.

Примечание: как то столкнулся с тем что при количестве чертежей в проекте более 500 штатная команда обновления ссылок работает странно и нечётко. Было опробовано несколько раз обновлять но с какого то листа пропадали номера цепей и сбивалось все вообще. Однако обновление на отдельных листах работало изумительно чётко и без ошибок. Вот это и делает эта команда - обновляет для одного листа, перебирая по очереди все выбранные листы в проекте. Работает команда меееедленноооо. Это необходимо для того что бы штатный движок АЭ успевал отслеживать и вносить в базу данных изменения в чертежах. Между обновлениями листов даётся пауза в несколько секунд.

Кнопка запускает обновление клеммников по всему проекту. Последовательно перебираются чертежи, проверяется наличие блоков клеммников. Именно блоков. Если клеммник нарисован просто - никто и никогда не узнает где он и что с ним делать. Но есть риск - размер блока может увеличиться и он "вылезет" за рамки листа. Так что применять нужно с умом.

Кнопка обновляет текстовый стиль во всех выбранных в дереве чертежах. Более подробно здесь

Кнопка еще не работает, ундер констракшн типа. Кнопка выполняет настройку слоев на выбранных чертежах. Настройка перечня слоев, которые будут созданы или обновлены, производится ПРЕДВАРИТЕЛЬНО на закладке "Утилиты всякие" -> "Настройка слоев в чертежах проекта".

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Раздел «Утилиты всякие»

I love Ukraine

Раздел «Утилиты всякие»

Это страница на которой собраны различные полезные функции . На ней расположены закладки переключающие наборы управления для различных утилит и информационное поле.

Внешний вид закладки раздела:

На странице "Всякое" - кнопки инструментов.

На странице "Замена текста" - альтернатива поиску и замене текста в чертеже и в проекте. Специфическая штука.

На странице "Логи" - специальное информационное поле, куда в процессе работы выводятся всякие технические сообщения, информационные и сообщения о сбоях.

Инструменты управления на закладке "Логи":

Кнопка «В буфер» - копирует содержимое информационного поля в буфер.

Кнопка «Очистить» - очищает информационное поле.

Переключатель «подробно» - позволяет увидеть все информационные сообщения при работе утилиты, в том числе и технические. Как правило это никому не нужно, кроме меня для процесса отладки.

Инструменты управления на закладке "Всякое":

При нажатии на некоторые кнопки будет открывается окно соответствующей утилиты и сворачивается главное окно на время работы утилиты.

Кнопка «Распечатка отдельных чертежей не подключенных в проект» - полезная утилита позволяющая распечатывать чертежи сделанные не в АЭ и не подключенные в проект. Удобно, когда приходит чертеж с кучей рамок от смежников и просят распечатать на вашем прекрасном новом принтере. И листочков то всего 50-60... Или просто распечатать на текущем чертеже все рамки в пдф.

Кнопка «Настроить шрифты и печать (принтер PDFtoDWG)» - собственно автоматизирует процесс настройки штатного принтера PDFtoDWG. Вся настройка заключается в добавлении в него ГОСТовских форматных рамок. Если при печати "длинные" рамки А4х и др печатаются на А4 или А3 горизонтально печатается на вертикальный лист - значит не настроен драйвер принтера. Тыцкаем в кнопку и оно само все сделает.

Кнопка «"Причесать" перечень элементов ВОМ» - Выполняет форматирование (причёсывание) таблицы перечня элементов (ВОМ - bill of materials) сделанный средствами АЭ.

Кнопка «Разбивка чертежа на файлы» - утилита разбивает лист с рамками на отдельные файлы с одним чертежом в файле. Полезна при подключении в проект новых схем.

Кнопка «Настройка слоев в чертежах проекта» - утилита позволяет настроить на текущем листе или в чертежах проекта слои.

Кнопка «Перенумерация листов и штампов» - утилита позволяет перенумеровать на текущем листе штампы (счетчик чертежей) и рамки (счетчик листов в томе).

Кнопка «Перегнать кабели из экселя в Автокад» - позволяет создать схему электрическую для расчета кабельного журнала из списка кабелей в таблице Эксель.

Кнопка «Создать каталоги под проектик РЗА» - создает стандартный набор каталогов под проект РЗА (схемы принципиальные, внеш подключения, каб журнал, спецификация, задание заводу).

Кнопка «Расставить блоки на чертеже» - утилита позволяет расставить любые выбранные блоки (вхождения блоков) в форматные рамки. Иногда очень полезно и ускоряет работу.

Кнопка «Группировка клемм в красивый квадратик» - выполняет перенос и размещение группы указанных клемм в прямоугольную область указанную юзверем.

Кнопка «Утилита "Группировка блоков обозначений кабелей"» - выполняет перенос и размещение группы указанных блоков обозначений кабелей на плане в указанную прямоугольную область. Обычно используется на схемах прокладки кабельных трасс.

Кнопка «Удалить дубликаты линий» - автоматизирует процесс очистки чертежа от дубликатов линий.

Кнопка «Перенос маркировки клеммы» - автоматически переносит обозначение клеммы "ХТ:123" в указанное место.

Кнопка «Вписать ТЕХТ или МТЕХТ в рамку» - автоматически переносит и меняет размеры указанного текста в указанное место вписывая в окружающие отрезки и полилинии.

Кнопка «Подровнять положение штампов» - просматривает чертеж и проверяет/корректирует положение блока штампа на чертеже.

Кнопка «Перевести текст на чертеже» - переводит на українську мову текстовые поля типа ТЕХТ или МТЕХТ.

Кнопка «Редактор PDF» - открывает окно с инструментарием редактирования pdf файлов. Набор функций пока что минимальный - собрать в один несколько файлов, добавить страничку/странички в файл, удалить выбранные странички из файла. После пользования рекомендую перепроверять результат.

Кнопки «Удалить инфоцентр» и «Вернуть» - посылает команду в АЭ и выключает на ленте инструментов панельку с инфоцентром. Исчезает эта хреновина после перезапуска АЭ.

Кнопка «Тиражирование файла» - рудимент, егойные функции полностью заменяются закладкой «Разбивка чертежа на файлы». Позволяет выбрать какой либо файл и скопировать его несколько раз дав имена <имя>_001.dwg, <имя>_002.dwg, и так далее.

Кнопка «Сотворить свой блок для АЭ и не только» - в разработке.

Кнопка «Расчет трансформатора тока» - в разработке.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Утилита «Распечатка отдельных чертежей не подключенных в проект»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Распечатка отдельных чертежей не подключенных в проект»

Утилита распечатки отдельных файлов вызывается нажатием на эту кнопку:

При помощи её можно распечатать в PDF рамки расположенные на текущем чертеже или в указанном файле или создать рамки для распечатки существующих чертежей.

Утилита подключается к текущему открытому в АЭ файлу и ищет блоки форматных рамок. Далее они сортируются в определённом порядке и выводятся на принтер DWG2PDF. Полученная в результате кучка файлов pdf собирается в один файл и/или переименовывается в заданном формате. Так же есть возможность отсортировать файлы по формату листов (А4, А3 и т.д.) и собрать в отдельные сборки pdf - очень удобно для последующей распечатки. Так же, при отсутствии блоков форматных рамок, есть возможность задать области печати - наложить блоки с заданным именем, по которому программа найдёт эти блоки и выведет на печать подобрав необходимый размер форматной рамки.

Более подробно как работает механизм печати описано тут

Внешний вид поля инструментов для распечатки с активного чертежа:

Инструменты управления:

Кнопка «Распечатать все рамки с активного чертежа» - распечатывает все рамки с активного чертежа.

Кнопка «Распечатать указанную рамку» - распечатывает выбранную рамку с активного чертежа.

Кнопка «Распечатать все рамки из файла» - распечатывает все рамки из выбранного файла.

«Имя файла для печати» - выбирается файл который необходимо распечатать

Группа «Настройка сборки PDF файлов»
- предназначена для настройки режима сборки в один pdf файл.
Содержит следующие чекбоксы:

«Все распечатанные PDF собрать в один файл» - заставляет после окончания распечатки чертежей объединить их в один pdf файл. Промежуточные pdf файлы удаляются. Имя фала сборки задаётся в отдельном поле (см ниже). Если имя сборки не задано, то по умолчанию назначается имя "TMP.pdf"

«Подготовка к печати - разбивка по форматам и сборка» - очень полезная опция. Заставляет после окончания печати разобрать по форматам чертежи и объединить их. Имя результирующему pdf файлу даётся по обозначению формата. Так же указывается количество листов в сборке. Например: "Format=A3 landscape_(3 pages).pdf". Эти файлы разбивки по форматам складываются в отдельную папку с именем "CollateToPrn" которая располагается возле основного pdf файла.

Группа «Настройки одиночных PDF файлов»
- предназначена для настройки имени pdf файла в случае если не выбрана сборка файлов в один pdf.
Содержит следующие чекбоксы:

«Вставить дату» - добавляет к имени файла и к папке "CollateToPrn" текущую дату в формате:
TMP_(2019-03-19).pdf. Работает как при выводе отдельными pdf файлами, так и при сборке в один файл.

«Имя DWG файла» - добавляет в имя PDF файла имя исходного DWG файла. Отключает режим сборки в один файл. (не работает пока что :-) ).

«Указать формат» - добавляет к имени файла описание формата, например "...(А4х3).pdf" [image] отключает при этом режим сборки в один файл.

«Номер из штампа» - добавляет к имени файла номер чертежа из штампа. (не работает пока что :-) ).

Группа «Настройки печати»
- предназначена для настройки параметров печати и поиска форматных рамок.
Содержит следующие элементы:

Поле "Имя блока рамки" - в поле должно быть указано имя блока или его часть. По умолчанию стоит "RamkaESKD". Желательно что бы блок форматной рамки начинался с этого, например: "RamkaESKD_A3x3_UkrFrm3"

Поле "Префикс в имени" - задаёт имя результирующего файла сборки или отдельных pdf файлов. По умолчанию стоит "ТМР"

Выпадающий список "Стиль печати" - обычный перечень стилей который используется при печати. Я в основном использую стиль "monochrome.ctb". Если есть необходимость в другом стиле всегда есть возможность указать его имя прост набрав в поле списка.

Чекбокс "Игнорировать старые "многорамочные" форматы" - было время когда я использовал блок с кучей видимостей для различных рамок. Было очень удобно - в выпадающем списке выбора формата тыкнул и вуаля. Однако использование таких рамок приводило к сильной задержке при определении размера (есть специфика внутренней реализации Автокада) и приводило к увеличению времени печати до неприличных величин.

Внешний вид поля инструментов для распечатки выбранных файлов:

Смысл такой: допустим необходимо распечатать чужой проект у которого вообще нет форматных рамок в чертежах. То есть сделан по старинке в обчном автокаде.

Сначала необходимо подготовить чертеди - в кажом чертеде наложить на форматные рамки блок-рамку, которую сгенерировать на закладке "распечатка с активного чертежа". Таким образом программа будет знать какие рамки и в каком порядке печатать. Там же настроить параметры печати и сборки.

Выбрать подготовленные файлы в список. Отсортировать, выделить галочками те кого необходимо печатать (обычно все выделяются). И распечатать список.

Created with the Personal Edition of HelpNDoc: Ensure High-Quality Documentation with HelpNDoc's Hyperlink and Library Item Reports


Утилита «"Причесать" перечень элементов (ВОМ)»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «"Причесать" перечень элементов (ВОМ)»

В этом окне расположены элементы управления утилиты предназначенной для приведения штатного ВОМ в удобоваримый вид.

BOM - bill of materials, по-нашему "перечень элементов". Такая таблица собирается АЭ (закладка "Отчеты"->"Отчеты по схемам" и т.д.) и выводится на чертеж. Но формат у нее импортный, не по ЕСКД оформленный. В принципе это прекрасная заготовка, которую необходимо просто «причесать». То есть нужно отобрать необходимые столбцы и их содержимое вывести в нашу привычную форму. Что эта утилитка и делает.

Важно: Этот "причёсыватель" предназначен для обработки уже готовой таблицы, которая является просто набором ячеек с текстом. Нет никаких признаков по которым можно было бы хоть как-то определить тип и назначение столбца. Единственный выход - смотреть на заголовок столбца. Исходя из этого программа работает так - в выбранной таблице собирает названия столбцов (самый верхний ряд) и ищет совпадения с шаблонами заданными в полях программы. Если находит совпадение с шаблонами, то "понимает" откуда брать данные для заполнения соответствующих столбцов новой таблицы. Поэтому для правильной работы функции внимательно следите за наименованиями столбцов которые создает АЭ.

Внешний вид закладки:

На закладке расположены:

- Кнопка "Причесать" - запускает на исполнение утилиту.

- Кнопки "Вариант1" и "Вариант2" - выбирает два типа таблицы перечня элементов.

Первый вариант - тот который и был, классический с пятью строками. Второй вариант - с шестью строками

- Кнопка "Добавить" - пока не работает - добавляет колонку в выходную таблицу

- Кнопка "Удалить" - пока не работает - удаляет колонку из выходной таблицы

- Кнопка "Считать из реестра" - считывает из реестра последние сохраненные настройки

- Кнопка "Сохранить в реестре" - сохраняет текущие настройки в реестре

- Кнопки "Считать из проекта" и "Сохранить в реестре" - сохраняют и восстанавливают настройки из файла настроек проекта. Работают только при открытом в программе проекте.

Группа позволяет разбить таблицу ВОМ по признаку функц-й группы и по месту (шкаф). При установленном чекбоксе ищутся и анализируются столбцы в исходной таблице ВОМ. При изменении содержимого столбцов создается новая выходная таблица с перечнем элементов. Заголовки столбцов, по которым идет анализ, указываются в редактируемых полях.

- Поле "Высота строки" - позволяет задать высоту строки в выходной таблице

- Поле "Высота таблицы" - позволяет задать высоту выходной таблицы, заполняет свойство самой таблицы. При достижении заданной высоты Автокад переносит строки в следующий столбец вправо.

- Чекбокс "Не сворачивать номера TAG" - отключает "свёртку" последовательности позиционных обозначений элементов (атрибут TAG).

Например: в таблице ВОМ есть строка описывающая промежуточные реле KL1 - KL10. В таблице ВОМ в колонке "ПОЗИЦИОННЫЕ ОБОЗНАЧЕНИЯ" будет указано "KL1,KL2,KL3,KL4,KL5,KL6,KL7,KL8,KL9,KL10". Если не отключена "свертка", то в выходной таблице будет показано: "KL1...KL10".

Поле с параметрами столцов в выходной таблице перечня элементов.

Так как выходная таблица ВОМ не имеет никаких признаков у колонок, обнаружить нужные колонки для обработки можно только по их заголовкам.

- поле "Наименования столбцов" - туда заносится название столбца в выходной таблице.

- поле "Ширина столбца" - содержит значение ширины указанного столбца в единицах чертежа

- поле "Столбец в ВОМ" - содержит несколько возможных названий столбца в исходной таблице ВОМ. Названия вводятся через точку с запятой ";" и без всяких пробелов до и после точки с запятой. Это не маска для поиска - нужны точные названия столбцов которые генерирует в отчете Автокад Электрикал.

- чекбокс "OFF" - пока не работает - позволяет исключить столбец из выходной таблицы

- чекбокс "TAGs" - указывает в какой колонке будут позиционные обозначения. Это важно. Если её отключить то программа не будет знать в какой колонке сворачивать перечень позиционных обозначений.

- Кнопка "Сохранить на диске "kirill_bom.set". Создает на диске файл с предустановленными настройками ВОМ для АЭ. Для формирования отчета ВОМ обычно используется идущий по умолчанию файл параметров формата отчетов «bom.set», который идет в поставке. Там есть кнопка «Формат» и обычно ее не трогают. Однако можно использовать мою заготовку «kirill_bom.set». Отличия только в том, какие столбцы попадают в таблицу, их порядок, размеры, и то, что таблица является НЕОБНОВЛЯЕМОЙ! Если сдуру выбрать «Обновить существующий», то эта хрень перелопатит все ваши перечни элементов на всех листах… я так уже однажды нарвался, создавал все заново.

- Чекбокс "Использовать шаблон "kirill_bom.set" - включает заранее предустановленную последовательность столбцов под "kirill_bom.set", в котором уже жестко задана последовательность. То есть АЭ выдаст таблицу ВОМ с упорядоченной последовательностью столбцов: 1й - позиционные обозначения, 2й - наименование, 3й - Тип, технические данные, 4й - количество, 5й - Примечания (изготовитель).

Поля по которым составляется перечень элементов: [МЕСТО ], [ФУНКЦИОНАЛЬНАЯ ГРУППА ], [ПОЗИЦИОННЫЕ ОБОЗНАЧЕНИЯ ], [ К-ВО ], [ НОМЕР ПО КАТАЛОГУ ], [ ИЗГОТОВИТЕЛЬ ], [ ОПИСАНИЕ ]

Можно выполнять сборку ВОМ для ВСЕГО проекта - тогда при "причесывании" будут созданы отдельные таблицы для каждой пары [МЕСТО]-[ФУНКЦИОНАЛЬНАЯ ГРУППА]. Таблицы выстраиваются по вертикали вниз начиная из выбранной точки. Точку выбирает пользователь в начале операции.

Отсутствие какого либо столбца не приводит к отказу - просто соответствующий столбец не будет заполнен.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Утилита «Разбивка чертежа на файлы»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Разбивка чертежа на файлы»

В этом окне расположены элементы управления утилиты для разбивки текущего чертежа на отдельные файлы.

Допустим у вас есть схема чего нибудь, все рамки которой собраны на одном чертеже. Теперь что бы подключить в автокад файлы необходимо их разбить на отдельные чертежи. Можно конечно вручную покрамсать их, терпеливо сохранить в несколько файлов и в каждом поудалять лишние рамки... но это долго и нудно. А если на листе более сотни рамок? Вот тут и пригодится эта утилита.

Она может:

- разделить файл на несколько по форматным рамкам и собрать описания чертежей из блоков главных надписей.

Обрабатывается только текущий открытый файл. Алгоритм описан тут.

- собрать в один файл несколько файлов с форматными рамками.

Выбираются для обработки несколько файлов или каталогов, выделяются файлы для обработки и запускается процесс. Найденные в файлах рамки будут скопированы на активный чертеж автокада.

Все сообщения выводятся на закладке "Логи". Перед началом операции логи очищаются.

Внешний вид утилиты:

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Утилита «Настройка слоев в чертежах проекта»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Настройка слоев в чертежах проекта»

В этом окне расположены элементы управления утилиты для настройки слоев как в текущем чертеже так и во всем проекте

Created with the Personal Edition of HelpNDoc: Effortlessly Support Your Windows Applications with HelpNDoc's CHM Generation


Утилита «Перенумерация листов и штампов»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Перенумерация листов и штампов»

В этом окне расположены элементы управления утилиты для автоматической нумерации чертежей.

Можно автоматически перенумеровать счетчики листов (в правом верхнем углу рамки) и счетчики чертежей в главной надписи (в штампе).

Можно перенумеровать как все рамки/штампы которые есть на листе, так и выбрать только часть указав в ответ на запрос.

Внешний вид панели:

Начальное значение задается в поле "Начальное значение и шаг приращения". Исходные значения нужно указать в следующем формате: <Начальное значение>,<Приращение>.

Начальное значение может состоять из префикса и счетчика, например: АА01, 12KL223. Желтым выделен префикс, он не изменяется. Голубым выделен счетчик, который меняется от рамки к рамке. Если не указывать счетчик, например задать только АВС, то начальное значение будет 1.

Приращение задается через запятую или не указывается вообще. Если не указывать, то приращение будет по умолчанию равно 1. Приращение - только цифры. Если задать "0", то все рамки/штампы получат одинаковое (начальное) значение.

На поле активного чертежа программа находит все рамки, или выбирает указанные, составляет список и далее сортирует его. Описание алгоритма сортировки рамок приведено тут . Далее в найденных рамках будут искаться соответствующие атрибуты и заполняться следующим вычисленным значением.

По умолчанию используется два атрибута: "SH" - содержит номер листа в блоке штампа (главной надписи), "MyCountList" - содержит счетчик листов. Имя атрибута "SH" жестко задано и не меняется. Имя атрибута "MyCountList" можно изменить в соответствующем поле.

Есть возможность выполнять нумерацию любых блоков задавая необходимое имя блока в поле "Имя блока рамки" и имя атрибута "MyCountList".

Created with the Personal Edition of HelpNDoc: Streamline your documentation process with HelpNDoc's WinHelp HLP to CHM conversion feature


Утилита «Расстановка блоков на чертеже»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Расстановка блоков на чертеже»

В этом окне расположены элементы управления утилиты для автоматической расстановки выбранных блоков в текущем чертеже.

Например вы нарисовали кучу кусочков схем, или еще каких ни будь штучек в виде блоков, которые необходимо расставить культурно-аккуратно в форматные рамки. Эта утилита анализирует размеры блоков, прикидывает минимальный размер и начинает заполнять рамки.

Этот процесс может оказаться ОЧЕНЬ длительным ибо задача о наилучшем размещении является нетривиальной и требует значительного количества переборов вариантов расположения элементов. Это может вылиться в очень длительный срок работы... например при 500 клемниках расстановка заняла более трех часов... Ну как говорят - "зато не пешком" :)

Created with the Personal Edition of HelpNDoc: Make the switch to CHM with HelpNDoc's hassle-free WinHelp HLP to CHM conversion tool


Утилита «Тиражирование файла»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Тиражирование файла»

Собственно выполняемые функции описаны на самом поле (см. картинку внешнего вида).

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Утилита «Редактор PDF (простенький)»

Раздел «Утилиты всякие» ››

I love Ukraine

Утилита «Редактор PDF (простенький)»

В этом окне расположены инструменты для быстрого редактирования pdf файлов.

Первая закладка "Обьединить файлы" - собственно и предназначена для выбора и обьединения списка файлов.

Вторая закладка "Вставка/удаление листов" - предназначена для удаления/замены/добавления отдельных листов в файле.

Created with the Personal Edition of HelpNDoc: Bring your WinHelp HLP help files into the present with HelpNDoc's easy CHM conversion


Объединение файлов

Раздел «Утилиты всякие» ›› Утилита «Редактор PDF (простенький)» ››

I love Ukraine

Объединение файлов

В этом окне расположены инструменты для быстрого редактирования pdf файлов. Внешний вид закладки показан ниже.

Для объединения необходимо выбрать группу файлов, выбрать в списке необходимые, указать имя и расположение результирующего файла.

Для выбора можно воспользоваться кнопками "Выбрать файлы для сборки" и "Выбрать каталог для сборки". Вторая кнопка позволяет добавить все файлы pdf в выбранном каталоге и во вложенных каталогах. Просмотр подкаталогов управляется чекбоксом "С подкаталогами". При необходимости можно очистить список файлов кнопкой "Очистить список".

Последовательность обьединения файлов корректируется вручную при помощи группы "Выделенный файл". Кнопками "Вверх", "Вниз" сдвигается в соотвествующую сторону выделенный в списке файл, кнопкой "Удалить" удаляется из списка.

Для выбора файлов для объединения можно просто щелкать мышкой по чекбоксам в списке или воспользоваться группой "Выделение файла". Кнопки "Выделить все" и "Снять выделение всем" выделяют и снимают выделение (галочки) в списке для всех файлов.

Чекбокс "Удалить исходные файлы после объединения" позволяет удалить все pdf файлы из списка собранные в результирующий файл.

В поле "Результирующий файл" необходимо ввести вручную имя выходного файла. каталог где будет создан выходной файл можно выбрать кнопкой "...".

Объединение выполняется кнопкой "Объединить".

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Удаление/добавление файлов

Раздел «Утилиты всякие» ›› Утилита «Редактор PDF (простенький)» ››

I love Ukraine

Удаление/добавление файлов

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Утилита "Перенос клемм в красивый квадратик"

При разработке проекта часто появляются неиспользованные и резервные клеммы. Часто пустыми клеммами разделяют важные цепи, чтобы не коротнули между собой.

Казалось бы их не имеет смысла "оживлять", рисовать в проекте. Однако чтобы работал механизм АЭ они должны быть обозначены как-то в проекте. Если их не разместить про них АЭ просто не будет знать, а значит в отображаемом клеммнике будут "выбитые зубы". То есть, их все таки необходимо разместить где-то на листах проекта. Кто-то размещает за форматной рамкой, кто-то (как я) размещает их на листе и обозначает как "Резерв". И они там накапливаются по мере создания проекта. Но эту кучу клемм, на ходу сваленную в какое-то место чертежа, потом необходимо облагородить, расставить красиво.

Для их сортировки и расстановки я и создал этот механизм. Работает он в трех режимах:

  • ТОЛЬКО при считанном проекте и ТОЛЬКО с клеммами, которые принадлежат этому проекту.
  • с любыми блоками клемм на текущем листе.
  • с любыми блоками, но только с блоками.

Выбрать нужный режим можно с помощью переключателя:

Расстановка может быть выполнена по размерам блоков и по центрам вставки блоков.

В первом случае просто определяются размеры блоков и расставляются рядами с указанным зазором.

Во втором случае определяются точки вставки блоков (обычно это центр кружка обозначающего клемму). Вычисляются необходимые отступы между рядами клемм и расставляются заполняя заданную область. Наиболее оптимальный вариант.

Выполняем в несколько шагов:

1) На закладке "Утилиты всякие" тыцкаем в кнопку "Группировка клемм в красивый квадратик"

Откроется вот такая панелька:

Нажимаем кнопочку:

2) Говорим "Ок" приглашению:

Выбираем на чертеже клеммы для упаковки в квадратик:

3) Смотрим на командную строку автокада и указываем любой угол прямоугольника куда будут вписаны клеммы:

4) смотрим на командную строку и указываем любой противоположный угол прямоугольника:

5) наслаждаемся результатом

Примечание - желательно указывать область размещения с зазором на размер половины клеммы.

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Утилита "Группировка блоков обозначений кабелей"

Как запустить утилиту, где искать

Внешний вид утилиты и описание интерфейса

Пример упорядочивания блоков

Примечания

При расчете кабельного журнала создаются группы блоков обозначающих кабели проходящие на отдельных участках кабельных трасс. Это заготовки для создания плана кабельных трасс. Штука полезная. Но есть следующая проблема.

При изменении принципиальных схем и состава кабелей в принципиальных схемах, при повторном расчете кабельного журнала естественно меняется количество блоков в группах. Казалось бы ничего страшного. Однако размеры блока фиксированные и если появлялась марка кабеля большой длинны, то она вылазила за границы блока. Это некрасиво и требовало ручного изменения размеров, подгонки длины блока. Тогда было принято решение корректировать размеры блока по размерам наиболее длинной марки кабеля при расчете. Теперь размеры блоков формируются динамически. Но и тут засада.

Бывает так что с расчетного плана блоки нужно переносить на другой чертеж, где остались еще старые блоки. И по законам автокада при переносе блоков, если на целевом чертеже уже есть блоки с таким именем, то новые блоки не создаются, а просто прорисовываются по старым размерам. В общем может быть каша с наползающими друг на друга блоками.

Чтобы убрать рутинную работу по "причесыванию" блоков, и создана эта функция.

  • Как запустить утилиту, где искать

Утилиту можно найти и запустить из двух мест:

Первое - на закладке "Утилиты всякие" кнопкой

Второе - на закладке "Кабельный журнал" -> "Расчет длин кабелей..." -> "Нарисовать обозначение кабелей" -> кнопка "Упорядочить, собрать в группы"

  • Внешний вид утилиты и описание интерфейса

Внешний вид утилиты выглядит так:

Кнопка "Упаковать" - запускает на исполнение с выбранными настройками.

Кнопка "Close" - закрывает окно.

Описание настроек:

- Кнопки позволяют выбрать как упорядочивать прямоугольники. Кнопка "расставить по колонкам" выбирает расположение блоков по фиксированному количеству блоков в ряду или в колонке вне зависимости от размеров. Кнопка "Вписать в прямоугольник" выбирает режим "впихивания" в заданную область. Область задается двумя точками. Если количество блоков и их размеры не позволяют расположить блоки в заданной области, то они будут выходить за заданную область в заданном направлении.

- Кнопки дополняют вышеописанную пару кнопок и определяют направление в котором растет группа. То есть, если выбрано "по вертикали", то блоки будут располагаться рядами по горизонтали. КОличество в ряду определяется или количеством блоков в ряду или шириной заданной области.

- включает сортировку блоков по марке кабеля. Если переключатель включен, то в каждом блоке будет искаться атрибут с маркой кабеля. Далее блоки будут отсортированы по маркам кабеля.

- включает запрос выбора конкретного типа блока. Допустим имеется куча разных блоков. Выделив всю кучу и указав конкретный блок можно отфильтровать только указанные блоки. То есть, из кучи будут отобраны и расставлены только блоки с заданным именем.

- число блоков в ряд или в столбец при включенном режиме "расставить по колонкам". В режиме "вписать в прямоугольник" не имеет смысла - там подбор числа идет по размерам блоков.

- можно установить зазоры между блоками. Зачем - хз, просто бонус.

  • Пример упорядочивания блоков

Допустим размещение блоков выглядит так:

Запускаем утилиту сортировки блоков.

Настройки оставляем по умолчанию (ка на картинке выше): сортировка включена, пять блоков в ряд, направление по колонкам, расставлять по числу блоков в ряд, число блоков в ряду 5 штук.

Получаем запрос выбора блоков:

Выбираем ту кучу блоков. Далее получаем запрос куда вставлять, нужно указать начальную верхнюю левую точку.

Далее нажимаем "Упаковать". Выбранная точка вставки обозначена стрелочкой.

Теперь тоже самое но с направление по горизонтали:

Теперь выберем режим "Вписать в прямоугольник" и направление по вертикали:

Рамка задана фиолетовой пунктирной линией. Как видно блоков больше чем заданная область и они "вылезли" вниз за рамку.

Теперь тоже самое но с направление по горизонтали:

Теперь вылезли за край по горизонтали.

Укажем зазоры равные 1 мм. Парметры последнего "опыта" не меняем. Получим все тоже самое, но с зазором.

Выбор нужных блоков из кучи:

Делаем две группы блоков с разными именами блоков. Одни будут желтые, другие зеленые.Сделаем из них одну большую кучу, как на картинке.

Установим переключатель "Выбрать конкретный тип..." и запускаем процесс.

Получим в начале запрос на тип блока с которым работаем. Тыкаем в какой-нибудь блок, я выбрал желтый.

Далее получаем запрос на выбор блоков. Выбираю всю кучу.

Далее указываем точку вставки и получаем вот такой результат:

  • Примечания

- Вообще эта штука работает со всеми блоками, не разбираясь что и как. Тупо берет блоки и расставляет. То есть можно применить к любому блоку. Однако при сортировке она ищет атрибут "NameCab" с маркой кабеля. Если атрибута нет, то это считается за случайную ошибку и повторяется три раза с задержкой в 1 сек. То есть, если выбрать 1000 блоков без атрибута, то программа зависнет на 3000 сек пытаясь отсортировать что нашла.

Поэтому рекомендация - при сортировке иных блоков, без атрибута "NameCab", не включать сортировку.

Created with the Personal Edition of HelpNDoc: Upgrade Your Documentation Process with a Help Authoring Tool


Утилита "Создать каталоги под проектик РЗА"

При разработке проекта почти всегда всё начинается с создания структуры каталогов, где будет храниться весь проектный хлам, и проектов по разделам. И каждый раз я создаю один и те же папки... зае...ло. Автоматизировал.

Выглядит так:

Нажимаем кнопку "Создать каталоги..." на закладке "Утилиты всякие"

Открывается окно с запросом общего наименования проекта. Например "ПС 330-110-35 им Шухевича" или "ПС 110-10 35-летия казни Хуйла".

После идет запрос в куда собсно создавать каталоги. Обычный диалог выбора каталога. После в выбранном каталоге будет создана папка с именем проекта и в ней пять папок. В каждой папке заготовки проектов с двумя чертежами - общими данными и заготовкой под штамп. Заготовка под штамп в большинстве случаев может быть одна общая в корневой папке.

Файл bat в корне - удаление, чистка от промежуточных файлов. Мне не нравятся засраные каталоги.

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Утилита "Заготовки всякие"

Панелька с инструментами вызывается кнопкой "Заготовки всякие".

Тыцкаем в кнопку и откроется окно:

Created with the Personal Edition of HelpNDoc: How to Protect Your PDFs with Encryption and Passwords


Утилита "Заготовка кабеля"

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Утилита "Замена текста"

Утилита предназначена для замены текста в чертеже/чертежах и была создана исключительно для моего личного пользования, но, возможно, пригодится и кому-то ещё. Буду только рад, если она окажется полезной.

Она выполняет групповую замену фрагментов текста как в текущем чертеже, так и в чертежах проекта.

Казалось бы, существует штатная функция поиска и замены, но при необходимости заменить большое количество различных слов и фраз этот процесс превращается в настоящее испытание на терпение. Поэтому возникла необходимость автоматизировать его.

Утилита использует ваш словарь: находит в чертеже заданные слова или их комбинации и автоматически заменяет их.

Можно обработать либо только текущий чертеж, либо все чертежи текущего проекта.

Замена осуществляется по словарю последовательно сверху вниз — от первой (верхней) строки до последней (нижней).

Просматриваются следующие объекты: TEXT, MTEXT, атрибуты вхождения блока, а также текстовые объекты (TEXT, MTEXT) внутри самих блоков. Последнее — достаточно рискованная опция, использовать её следует с осторожностью и пониманием последствий: при замене в блоке будут изменены все его вхождения.

Есть три фиксированных наименования блоков, которые всегда игнорируются: WD_M, *Model_Space, *Paper_Space.

Чтобы игнорировать дополнительные блоки, справа от таблицы словаря предусмотрено текстовое поле, куда можно внести их названия. При обработке чертежа такие блоки будут пропущены.

Замена может выполняться с учётом регистра или без него. Также можно задать режим поиска: либо просто вхождение слова/фразы в предложение, либо совпадение целиком.

Рекомендуется простое правило: длинные строки, подлежащие замене, следует размещать в начале словаря, а одиночные слова — в конце. Это позволяет корректно обрабатывать фразы, состоящие из нескольких слов.

Внешний вид панели:

Словарь замен можно сохранить на диск с помощью соответствующих кнопок, а затем загрузить при необходимости. Количество таких словарей не ограничено.

Тем не менее, для удобного наполнения и редактирования словаря рекомендуется использовать Excel — это действительно гораздо удобнее.

При сохранении словаря строки, в которых ячейка "Old Text" пуста, автоматически пропускаются. Аналогично, при обработке текста пустые строки исходного текста также игнорируются.

Для удобства редактирования предусмотрено последовательное перемещение по ячейкам и строкам с помощью клавиши Enter.

Если выделена последняя ячейка строки, нажатие Enter перемещает курсор в начало следующей строки.

Если при этом удерживать клавишу Shift, будет добавлена новая строка после текущей.

Если нажать Enter в последней ячейке последней строки, будет автоматически добавлена новая пустая строка.

Created with the Personal Edition of HelpNDoc: Upgrade Your Documentation Process with a Help Authoring Tool


Утилита "Перенос маркировки клеммы"

Утилита для переноски на схеме обозначения схемы. Как неожиданно оказалась вельми полезная утила.

Идея в следующем: клемма на чертеже обозначается блоком со специальным именем в котором есть два атрибута определяющих номер клеммы и наименование клеммника (клеммного ряда). Давным давно для красоты я добавил еще один атрибут в котором хранится двоеточие которое разделяет наим клеммника и номер, получается приблизительно так:

Когда рисуешь схему иногда нужно подвинуть обозначение клеммы. И приходится по старинке удерживая контрол выбирать эти атрибуты, что иногда муторно и в насыщенной схеме достаточно сложно (особенно если зрение уже ахти). Теперь все происходит проще: тыцкаем в кнопку, на запрос выбираем кучку клемм, на запрос показываем куда перенести обозначение и машина сама сделает все остальное.

Внешний вид кнопки и переключателей настройки:

Сама кнопка запускает процесс. Переключатели имеют следующее значение:

"несколько" - меняет стиль выбора, с одного элемента на выбор группы элементов.

Если переключатель не установлен, то производится выбор клеммы и запрашивается точка нового положения обозначения. Далее можно выбрать следующую клемму и так далее повторяется процесс до тех пор, пока не будет отменен выбор или выбрана не клемма.

Если переключатель установлен, то выбирается группа клемм для обработки. Можно захватывать и другие элементы/блоки на чертеже - они будут отфильтрованы и никак не влияют на процесс. Далее для первой клеммы необходимо указать точку куда будет перемещено обозначение клеммы. Новое положение атрибутов относительно точки вставки блока клеммы будет запомнено и далее без запроса применено для всех выбранных клемм.

"по образцу" - выполняет настройку выбранных клемм по одной "образцовой" клемме, у которой уже настроено положение атрибутов. В начале идет запрос указать образцовую клемму. Если образцовая клемма не выбрана, то процесс прерывается. Далее в зависимости от переключателя "несколько" выполняется циклический выбор клеммы или разовый выбор группы клемм. Указанные клеммы настраиваются в соответствии с образцовой клеммой - вычисляется точка где должно быть обозначение клеммы и туда переносятся атрибуты блока.

Как это выглядит вживую можно увидеть в ролике на Ютубе

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Утилита "Рисование стрелок на чертеже"

При создании структурных схем часто появляется необходимость показать стрелку на чертеже. Нарисовать не сложно, где-то копирование заготовки, где-то создаю заново. Но иногда их количество может зашкаливать что реально грузит рутинной работой. Автоматизировать не сложно. Потому и создал эту утилитку. Ее цель проста - щелкаете мышкой по экрану и по этому набору точек строится полилиния с "носиком" стрелкой.

Внешний вид кнопки:

Запуск функции нажатием на кнопку "Нарисовать стрелку". Далее идет запрос указать точки. В ответ на это щелкаем по экрану. Если набрали две и более точек, то по этим точкам рисуется полилиния в соответствии с выбранными параметрами. Последовательность точек важна, программа запоминает какая точка какой была по счету.

Параметров не много, но их конфигурация сильно влияют на внешний вид стрелки.

Переключатель "Несколько точек" - Если переключатель не установлен , то программа ждет только две точки, начальную и конечную. Если переключатель установлен программа принимает все точки до тех пор пока не прервать операцию (нажать эскейп или энетер).

Переключатель "Стрелка смотрит в конец линии" - Если переключатель установлен, то стрелка рисуется в последнем сегменте полилинии, носиком в сторону последней вершины. Если переключатель не установлен, то наоборот, в сторону первой точки.

Переключатель "Линия ступеньками" - Если переключатель не установлен, то сегменты будут прямолинейными от точки к точке. Если переключатель установлен, то точки анализируются и если две соседние точки не находятся на одной прямой по вертикали или по горизонтали, то между этими точками строится "ступенька" - ломаная линия.

Результат работы утилиты такой:

- стрелка по двум точкам

- стрелка по многим точкам слева на право

- стрелка по многим точкам справа на лево

Created with the Personal Edition of HelpNDoc: Effortlessly bring your documentation online with HelpNDoc


Раздел «Форматки»

I love Ukraine

Раздел «Форматки»

Это страница с набором инструментов для рисования форматных рамок по ДСТУ/ГОСТ.

Преамбула. На сегодняшний день только ленивый не создаёт свои собственные форматные рамки так, как ему удобно. Для чего я сделал этот инструмент - от лени. Кнопку нажал и оп-па - получил одну или несколько форматных рамок с кучей настроек. Но самое главное - эти форматные рамки заточены так что бы легко обрабатываться АЭ.

По началу я создавал блоки универсальных рамок с выбором формата - типа выпадающий список меняет видимость в блоке и отображается нужная рамка. Однако такие рамки создают программные проблемы при выводе на печать. Плюс атрибуты для автоматического заполнения не могут переезжать с места на место при смене размеров рамки. Есть решение - сделать базовую точку блока справа внизу. Однако отсчёт ссылок производится в АЭ от левого верхнего угла. И поэтому после каждого изменения формата необходимо переносить блок снова левым верхним углом в точку (0,0). Неудобно.

В конце концов плюнул и стал делать обычные статические блоки. Если генерировать их программой, то получается быстро и не тормозит работу.

Идея такая - используется форматная рамка в виде блока с заранее заданным именем. Например для форматной рамки А3 имя блока по умолчанию: RamkaESKD_A3L_UkrFrm3. Самое главное что бы в имени блока, очень желательно с самого начала, присутствовала строка "RamkaESKD" - это такая сигнатура, по которой программа определяет что этот блок именно форматная рамка и по ней определяет размеры форматного листа при выводе не печать. Остальная часть имени блока произвольная. По умолчанию там программа кодирует формат листа: "A3L" - для А3 горизонтальный, язык рамки: "Ukr" - для украинского и "Rus" для русского, "Frm3" - тип рамки.

В этом блоке есть поле в правом верхнем углу - это счётчик листов в томе. Его роль выполняет атрибут "MyCountList". Это имя фиксированное.

Для заполнения штампа предназначен другой блок - "PageESKD". Этот блок - носитель атрибутов - полей штампа. Более подробно будет описано позже.

Внешний вид закладки:

На закладке расположены следующие группы инструментов:

Группа "Выбор формата" содержит:

- [image] кнопки выбора форматного листа

- группу "Настройка рамки"

- группу "Настройка вставки"

- группу "Настройка имени блока"

Группа "Действие" содержит:

- основная кнопка выполняющая создание рамки на текущем активном листе в автокаде (причём в любом автокаде, не обязательно АЭ)

- кнопка формирования файла - чертежа содержащего блок форматной рамки. Далее удобно воспользоваться штатными средствами автокада по замене/обновлению блоков и во всем проекте обновить/заменить все старые форматные рамки на эту новую рамку.

- кнопка обновления существующего блока форматной рамки. Например забыли что на рамке не должно быть нумерации для ссылок, или забыли что рамка должна быть с атрибутами автозаполнения даты создания и даты печати - нужно настроить параметры, указать имя блока рамки и нажать на волшебную кнопку. Программа сама на текущем листе найдет все форматные рамки и изменит их содержимое.

- кнопка позволяет создать блок основной надписи (штампа) и разместить в указанном месте. Работает аналогично кнопке рисования форматных рамок.

Created with the Personal Edition of HelpNDoc: Maximize Your Documentation Output with HelpNDoc's Advanced Project Analyzer


Создание форматной рамки

Раздел «Форматки» ››

I love Ukraine

Создание форматной рамки

Для создания блока форматной рамки необходимо просто выбрать основные параметры: формат рамки, перечень необходимых настроек (тип рамки, сетки для ссылок, счетчик страниц, метки даты создания и печати, точку вставки, количество рамок, название слоя и цвет слоя, имя блока рамки и имя блока штампа и т.д.) и нажать кнопку "Нарисовать блок форматной рамки". В результате на текущем чертеже будет создан блок форматной рамки и будет создано указанное количество вхождений начиная с выбранной точки.

Основная надпись (или проще - штамп) и дополнительные графы (у левой стенки, вертикальные)прорисовываются в блоке форматной рамки. Но по умолчанию ничем не заполняются.

Для того что бы автокад электрикал мог заполнить основную надпись в автоматическом режиме необходимо чтобы блок штампа содержал необходимые поля (поле шифра, поле счетчика страниц, поле названия чертежа, поле адреса и т.д.) в виде специально именованных атрибутов. Программа сама может создать эти поля. Что бы активизировать эту функцию необходимо установить "галочку" [image] . При этом на условном изображении штампа появятся поля для заполнения и параметры для каждого поля.

Штамп может быть как составной частью форматной рамки, так и в виде отдельного блока со своим специальным именем. Для этого нужно установить "галочку" [image] . Эта галочка не работает без установленной "галочки" "Заполнить штамп" ибо не имеет смысла.

Поля "Должность" и "Фамилия" - только однострочные. Они могут быть как фиксированными, в виде обычного текста (ТЕХТ), так и однострочными атрибутами. Если во всем проекте фамилии и должности исполнителей не меняются, то можно не заморачиваться с заполнением параметров проекта, а просто сразу заполнить нужные поля и снять галочку "Атр-т". При этом в блоке штампа будут вставлен текст с содержимым из этих полей. Если нужно заполнять главную надпись индивидуально для каждого листа, то нужно будет заполнить параметры проекта и поставить галочки "Атр-т". В этом случае будут созданы специальные атрибуты и заполнены по умолчанию тем, что набрано в тех полях. Далее при выполнении команды автокада по обновлению основной надписи, автокад сам найдет эти поля и обновит их содержимое в соответствии с настройками проекта.

Тоже самое касается и полей "Дата", "Стадия", "Лист", "Листов".

Поля "Шифр", "Адрес", "Название объекта", "Описание (Название) чертежа" могут быть разного типа. Конкретный тип выбирается при помощи панельки с настройками слева от поля. Рассмотрим возможности настройки на примере поля А3:

как видно поле в блоке штампа может быть как текстовым (читай фиксированным) полем, так и атрибутом. Если поставить галочку "Атрибуты", то поле будет в виде атрибута в блоке штампа. Выделенная позиция "МТЕХТ" создает или многострочный атрибут или многострочное текстовое поле МТЕХТ. Если выделить позиции "1 строка", "2 строки", "3 строки", то будут созданы однострочные атрибуты или однострочные текстовые надписи. После создания блока эти поля будут заполнены тем, что будет набрано в окошке.

Поле "Организация/фирма" может быть только многострочным атрибутом или многострочным текстовым полем. Работает аналогично вышеприведенным полям.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Создание файла для замены

Раздел «Форматки» ››

I love Ukraine

Создание файла для замены

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Обновление блоков форматок

Раздел «Форматки» ››

I love Ukraine

Обновление блоков форматок

Created with the Personal Edition of HelpNDoc: Don't Let Unauthorized Users View Your PDFs: Learn How to Set Passwords


Раздел «Подготовка для заказчика»

I love Ukraine

Раздел «Подготовка для заказчика»

Предыстория такая. У каждого проектировщика есть свои маленькие "хитрости", наработки и прочее, что значительно облегчает жизнь, и, главное, позволяет ускорить выполнение проектных работ. Это его инструментарий, накопленный за долгие годы и иногда за деньги. Делиться таким некомильфо. Но в договорах часто пишут фразу "...предоставить в электронном виде, в редактируемом формате...". Прозрачно намекая на необходимость предоставить чертежи DWG. Отказать нереально. Но убрать из чертежей всё нажитое непосильным трудом (блоки и всю автоматизацию), превратив в простой набор линий - можно. Эта картинка уже и есть то, что нужно заказчику.

Для выполнения этого и создан этот инструмент. Алгоритм прост. Сначала запрашивается каталог в который будет скопирован проект. Потом из активного проекта последовательно копируются туда все чертежи (dwg) и после все скопированные чертежи открываются в AutoCAD Electrical для очистки. Очистка представляет собой "взрывание" всех блоков, перенос на нулевой слой и "покраска" в белый цвет. При этом есть возможность выбрать какие атрибуты не будут сохранены при преобразовании блоков. Например можно выбрать TAG, описания DESC, перекрестные ссылки XREF, номера клемм TERM, номера проводов WIRENO.

Внешний вид закладки:

Кнопка [image] предназначена для обработки активного в данный момент чертежа в работающем автокаде.

Кнопка [image] предназначена для обработки всех чертежей в проекте.

Кнопка [image] предназначена для обработки всех чертежей в выбранном каталоге.

- переключатель удаляет наименование элемента (KL1, SG1 итд)

- переключатель удаляет точку подключения у элемента, т.е. не будет номера контакта/пина.

- переключатель удаляет все поля с описаниями

- переключатель удаляет перекрестные ссылки у элементов и стрелок

- переключатель удаляет номер провода

- переключатель выполняет окрашивание в белый цвет всех элементов. Включено по умолчанию

- переключатель выполняет перенос всех элементов на нулевой слой. Включено по умолчанию

- переключатель выполняет удаление элементов лежащих на слое Defpoint. Включено по умолчанию

- переключатель выполняет удаление маскировок. Пока не работает по техническим причинам

- переключатель выбирает метод взрыва и окраски - при помощи lisp программы (по умолчанию, галочка не установлена) или при помощи стандартных функций AutoCAD Electrical (медленно).

В случае когда создается взорванная копия всего проекта, есть возможность изменять названия файлов, и не копировать структуру каталогов в папке проекта:

- позволяет копировать файлы чертежей проекта просто последовательно в корень

- переключатель позволяет заменить указанные имена файлов чертежей на указанные в поле "префикс" с добавлением номера из штампа и порядкового номера (для обеспечения уникальности имен файлов).

При запуске на исполнение выполняется следующее:

  1. Запрашивается расположение базового каталога. Если каталог с указанным именем не существует, то он создается. Если каталог по каким-либо причинам не может быть создан, процесс прерывается с сообщением.
  2. По выбору в каталоге создаётся структура проекта.
  3. Все чертежи копируются в базовый каталог. По выбору можно скопировать их в корень или они могут быть расположены в соответствующих каталогах, соответственно как в каталоге проекта. Если файл расположен за пределами каталога проекта, вне этого каталога, то он просто копируется в корень базового каталога. Если при копировании в нужном каталоге уже будет другой файл с аналогичным именем, то новый файл будет переименован - к его текущему имени будет добавлено случайное число.
  4. Чертежи по выбору или оставляются со своими именами, или переименовываются в обезличенные с названиями типа: <префикс><номер п/п>. На примере видно что будут созданы чертежи: [Чертеж №1], [Чертеж №2]... и т.д.
  5. Каждый скопированный чертеж открывается в AutoCAD Electrical и обрабатывается:
    • взрываются все блоки
    • все элементы окрашиваются в белый цвет
    • слои не меняются (в перспективе будут переноситься на слой "0")
    • производится очистка чертежа стандартной функцией AutoCAD Electrical. Три раза.
    • файл закрывается с сохранением

Created with the Personal Edition of HelpNDoc: Effortlessly Create High-Quality Help Documentation with a Help Authoring Tool


Алгоритм обработки файлов

Алгоритм обработки чертежей проекта:

  • Для всего проекта делается копия всех задействованных файлов в выбранный пользователем каталог.
  • Все скопированные файлы последовательно открываются в Автокаде и выполняются следующие действия в указанной последовательности:
    • взрывается содержимое, уничтожаются вхождения блоков на чертеже.
    • если выбрано, то все элементы "маскировка" удаляются.
    • если выбрано, то все элементы на слое Defpoint удаляются.
    • если выбрано, то все элементы окрашиваются в белый цвет.
    • все элементы переносятся на нулевой слой.
    • производится очистка чертежа стандартной процедурой Purge. Три раза.

Created with the Personal Edition of HelpNDoc: Quickly and Easily Convert Your Word Document to an ePub or Kindle eBook


Описание различных алгоритмов программы

В подпунктах перечислены описания алгоритмов выполнения различных действий. Иногда полезно прочитать, что бы не задавать вопросы типа "Я нажал а оно лепит что-то, совсем не так как я себе придумал". )))

  • Описание алгоритма печати
  • Описание алгоритма разбивки файла на отдельные файлы
  • Описание алгоритма сортировки форматных рамок на чертеже
  • Описание алгоритма обновления текстового стиля
  • Описание всяких заморочек и глюков АЭ

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Описание алгоритма печати

Маленькое пояснение относительно того КАК программка узнает что и как ей печатать.

Печать вызывается из двух точек:

  • - из закладки "Файлы проекта" - "Вывод на печать"
  • - из окна "Утилиты всякие" - "Распечатка отдельных чертежей не подключенных в проект".

Для того чтобы что-то распечатать программе нужно узнать где (на каком чертеже) и что именно (какие рамки и как) распечатывать.

Первый вопрос решается просто - мы распечатываем или конкретные файлы (проекта или отдельные), или что-то из текущего открытого чертежа.

Теперь стоит вопрос КАК программа узнает что ей печатать. Решение тоже не особенно сложное - мы указываем особенное имя блока, который обычно и представляет собой форматную рамку. Но не обязательно. Программе наполнение блока графикой - глубоко пофик, хоть чёртиков нарисуйте. Главное - размеры этого блока. Блок просто указывает своими размерами область печати.

Во время печати программа ищет блоки (вообще-то правильнее "вхождения блоков", проекции блока на чертеж) с указанным именем на текущем чертеже, и если находит, то составляет список, сортирует список по расположению на листе, последовательно настраивает для каждого блока параметры печати и печатает.

Теперь вопрос с именем блока. Дело в том, что форматные рамки, и соответственно блоки, у всех разные и имена тоже могут быть разные. Ну у кого как сложилось, кто к чему привык. Потому везде перед печатью можно указать имя блока. Вернее это часть имени блока, этакая сигнатура - метка в виде набора символов в составе имени блока, по которым программа будет искать и находить блок. По умолчанию эта фраза "PageESKD" и располагается в начале имени блока. Это имя я придумал много лет назад и привык к нему.

Например это легальное имя блока: "FDSJDFBFPageESKD2837634959875". Вы же можете задавать свое имя блока, как вам нравится.

Однако есть пожелание. Желательно что бы в имени блока присутствовало определение формата. Это сильно облегчает жизнь программке и экономит время печати. Строки, которые нужно добавить в имя соответствующего формату блока следующие:

  • стандартные вертикальные размеры

"A4 portret" - "_A4P"

"A3 portret" - "_A3P"

"A2 portret" - "_A2P"

"A1 portret" - "_A1P"

"A0 portret" - "_A0P"

  • стандартные горизонтальные размеры

"A4 landscape (не ГОСТ!)" - "_A4L"

"A3 landscape" - "_A3L"

"A2 landscape" - "_A2L"

"A1 landscape" - "_A1L"

"A0 landscape" - "_A0L"

  • дополнительные размеры A4

"A4x9" - "_A4x9"

"A4x8" - "_A4x8"

"A4x7" - "_A4x7"

"A4x6" - "_A4x6"

"A4x5" - "_A4x5"

"A4x4" - "_A4x4"

"A4x3" - "_A4x3"

  • дополнительные размеры A3

"A3x7" - "_A3x7"

"A3x6" - "_A3x6"

"A3x5" - "_A3x5"

"A3x4" - "_A3x4"

"A3x3" - "_A3x3"

  • дополнительные размеры A2

"A2x5" - "_A2x5"

"A2x4" - "_A2x4"

"A2x3" - "_A2x3"

  • дополнительные размеры A1

"A1x4" - "_A1x4"

"A1x3" - "_A1x3"

  • дополнительные размеры A0

"A0x3" - "_A0x3"

"A0x2" - "_A0x2"

Когда создается блок форматной рамки средствами программки ( закладка "Форматки" ), то генерируется стандартное имя блока. Например "RamkaESKD_A3L_UkrFrm3" или "RamkaESKD_A2x5_UkrFrm3". Красным выделено часть в имени блока, которая определяет формат листа.

Если блок будет уникальным (не будет создан программкой, а изысканной ручной работы) и в имени блока не будет указан формат, то формат определяется во время печати по фактическим размерам блока.

Сначала делается попытка определить очень точно размер. Если по каким-то причинам не получилось, то предпринимается попытка "вписать" блок в любой подходящий формат, который размерами чуть больше чем блок, с минимальным зазором.

Если на этом этапе не удалось определить нужный формат листа, то процесс прекращается и выдается соответствующее предупреждение. Тут хз что печатать на каком листе и т.д.

Есть еще вариант когда была создана форматная рамка по всем правилам, но "растянута" на изображение, путем увеличения масштаба блока. Так любят поступать первичники, геологи, геодезисты и т.д. :-) Вместо того что бы использовать листы и настроить подшивку, они лепят рамки прямо на лист с масштабом 200:1 и более. Программа в таком случае четко знает какой формат нужен (по масштабу блока) и знает что нужно вписать рамку в нужный формат. Это делается автоматически в настройках. Но, есть нюанс! Блок должен быть создан в масштабе 1:1, по размерам листа, и после должен быть отмастшабирован в нужный размер. Иначе программа запутается.

Created with the Personal Edition of HelpNDoc: Easy Qt Help documentation editor


Описание разбивки чертежа на отдельные файлы

Необходимость этой "разбивки" обусловлена спецификой работыAutoCAD Electrical - для него всегда один файл чертежа представляет собой один бумажный лист проекта. То есть на одном чертеже нельзя нарисовать кучу форматных рамок со штампами и ожидать что АЭ сам разберется где какой лист и настроит штампы и ссылки. Он ожидает что в одном файле будет только одна рамка, так как это для него ОДИН бумажный лист.

Но разрабатывать проект нереально сложно постоянно переключаясь между листами. Проще нарисовать все схемы в форматных рамках на одном листе - когда всё перед глазами процесс идет быстрее и гораздо меньше ошибок. Однако в этом случае, когда все форматные рамки на одном листе, с автоматизацией заполнения штампов можно попрощаться. Необходимо разнести эти чертежи по отдельным файлам, по одной рамке на чертёж, что бы АЭ смог выполнять свои функции корректно.

Например имеем файл с таким содержимым:

Его нужно разделить. Да, конечно, можно делать всё вручную - нажимать последовательно "Копировать в ..." как показано на картинке

и потом вытирать ненужное. Но когда в проекте около 50 листов которые рассыпаются на 300-600 листов... Понятно что для ускорения этого нудного и рутинного процесса нужна автоматизация.

Вот что бы решить эту проблему (объединить ужа и ёжика) и был создан этот инструмент. Его задача - проанализировать и разделить текущий чертеж на отдельные файлы, каждый из которых содержит отдельную форматную рамку.

Теперь всё просто - вы по привычке рисуете схемы в одном файле/чертеже, настраиваете ссылки, разбиваете схемы по форматным рамкам. И так по всему проекту - он будет представлять из себя кучу файлов которые содержат по несколько форматных рамок.

Далее выбираете или обработку конкретного файла [image] или выбираете обработку группы файлов проекта [image] .

Алгоритм такой:

1) ищется на диске и открывается файл чертежа (или используется активный открытый - в зависимости откуда пришел запрос);

2) делается копия обрабатываемого файла - он сохраняется под именем <Исходное имя>_ALL.dwg; (по выбору - в зависимости откуда пришел запрос. Если файл копии уже есть, то к имени файла добавляется случайное число - абы не было совпадения с существующими);

3) открывается скопированный файл в режиме только для чтения (если используется активный открытый, то он используется в том режиме в котором есть);

4) в открытом файле ищутся все форматные рамки. Если рамки не найдены, то процесс прекращается и копия исходного файла удаляется;

5) для каждой форматной рамки выполняется следующий процесс:

5.1) создается новый чертеж и сохраняется под исходным именем с добавлением счётчика "_001", "_002" и т.д. ;

5.2) на новый чертеж переносится всё что находится внутри области форматной рамки, включая форматную рамку;

5.3) на новый чертеж переносится блок WDM;

5.4) в поле рамки ищется по имени блок штампа (это может быть и сама форматная рамка)

5.5) в найденном блоке ищутся атрибуты с именами OPIS, OPIS1,...OPIS3 (см. примечание)

5.6) если атрибуты найдены их содержимое сохраняется в памяти

6) по окончании разбивки производится замена в проекте исходного файла на группу вновь созданных.

6.1) открывается для редактирования файл проекта wdp и в него (в секцию переченя файлов) вносятся необходимые записи о каждом новом файле. Файл сохраняется и AutoCAD Electrical обновляет проект. Таким образом они подключаются в проект. Записи вносятся точно в позицию исходного файла.

6.2) из перечня файлов удаляется запись о исходном файле.

Примечание: OPIS - многострочный атрибут в блоке штампа в котором находится описание чертежа. Это фиксированное имя и изменению не подлежит. Если вы переименуете его по своему усмотрению - хана всему, автозаполнение работать не будет. Вы можете сделать иначе - создать до четырех однострочных атрибутов с именами OPIS1...OPIS4. Основное отличие в том, что автокад при заполнении штампов пропускает многострочные атрибуты. То есть необходимо ставить галочку "Активизировать каждый обрабатываемый чертеж" - тогда будет открыт каждый по отдельности чертеж и заполнены поля в блоке основной надписи.

Программа сначала ищет атрибут с именем OPIS. Если атрибут существует, то считывается ТОЛЬКО он один. Остальные атрибуты OPIS1...OPIS20 не учитываются вообще.

Если его не существует, то осуществляется поиск атрибутов OPIS1...OPIS20.

Атрибуты OPIS, OPIS1...OPIS20 с пустым содержимым просто не учитываются. То есть сделать "пустую строку", читай строку разрыва, пробел, не получится.

Если выбрать обработку только одного файла - будет обработан только выделенный файл. Если выбрать обработку всего проекта, то программа в полностью автоматическом режиме последовательно откроет каждый файл и проведет разбивку на файлы.

Важно: Все что находится МЕЖДУ форматными рамками, ВНЕ форматных рамок - не будет перенесено во вновь создаваемые чертежи. Эти элементы при необходимости можно перенести вручную на чертежи.

Created with the Personal Edition of HelpNDoc: Powerful and User-Friendly Help Authoring Tool for Markdown Documents


Описание сортировки форматных рамок на чертеже

Описание различных алгоритмов программы ››

I love Ukraine

Описание сортировки форматных рамок на чертеже

Если при обработке чертежа (нумерация, печать и т.д.) на нем находится больше одной форматной рамки, то становится вопрос в какой последовательности их обрабатывать. Для этого разработан простенький но эффективный механизм. Рамки сортируются сверху-слева по горизонтальным полосам сверху вниз.

Что бы программа могла найти рамку она должна представлять из себя блок и иметь определённое имя. Имя блока форматной рамки ОБЯЗАТЕЛЬНО должно содержать подстроку "RamkaESKD" (Это значение по умолчанию, во многих функциях можно задать свое уникальное имя). Например "RamkaESKD_A3L_UkrFrm3_вер321".

Сортировка рамок осуществляется так:

1. Собирается перечень всех форматных рамок

2. В перечне выбирается самая левая-верхняя рамка. По ней вычисляется горизонтальная полоса - то есть её верх и её низ определяют начальную зону отбора рамок, горизонтальную полосу.

3. Далее перебираются все остальные рамки и те кто попадают в эту полосу записываются в первый ряд. Каждая рамка "расширяет" её. Как только рамки по горизонтали заканчиваются они сортируются слева на право.

4. Процесс поиска и формирования полосы повторяется над оставшимися рамками (начиная с п2) до тех пор, пока не закончатся все рамки на чертеже.

На рисунке схематично показан алгоритм.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Описание обновления текстового стиля

Бывают ситуации когда в проекте появляются листы с различными стилями текста. Этакий зоопарк, который портит внешний вид и все, глядя на него, понимают что автор или пофигист или рукожоп.

И естественно нужно просто пройтись и поменять стиль текста ВСЕМ элементам на всех чертежах. Это нужно долго скушно итд.

Я давно искал инструмент, и как-то нашел на dwg.ru тему "LISP. Замена текстового стиля" . В ней автор предлагает использовать набор команд для замены текстовых стилей у всех объектов чертежа на выбранный. Опробовал - работает прекрасно. Сделал кнопки на панели быстрого доступа для самых полезных команд CTSU и TSUP. Но постоянно тыкать в них тоже не фонтан - если листов 200 в проекте, то опять же адская трата времени.

А посему выполнил модификацию скриптов, объединил CTSU и TSUP в один скрипт. Скрипт прилинковал к программе, благо он очень маленький. Далее добавил в программу кнопку "Файлы проекта" -> "Полезности" -> "Настроить текстовый стиль".

Алгоритм обновления простой: выбирается группа файлов (или все файлы в проекте) для которых нужно назначить текстовый стиль. Тыкается в кнопку "Настроить текстовый стиль" для запуска пакетной обработки файлов. Программа распаковывает возле программы лисп файл и начинает открывать по очереди в Автокаде выбранные файлы. После открытия файла программа передает в Автокад команды загрузки лиспа и настройки текста, а затем закрывает файл с сохранением.

Created with the Personal Edition of HelpNDoc: Experience the Power and Ease of Use of HelpNDoc for CHM Help File Generation


Описание всяких заморочек и глюков АЭ

Иногда натыкаюсь на странное поведение алгоритмов АЭ. Таких "артефактов" не много, но есть и знать про них желательно.

Created with the Personal Edition of HelpNDoc: Effortlessly Convert Your Word Doc to an eBook: A Step-by-Step Guide


Клеммы с пустыми номерами

Бывают ситуации когда на схеме появляются пустые клеммы без номера. Это я считаю недочётом при разработке. Но если они есть то благодаря АЭ их вычислить достаточно сложно.

Например: делаем в тестовом проектике два обычных шкафа с клеммами и с кабелем соединяющим их. Номера марки проводов даем "wire01, wire02, ...". Получится что-то вроде этого:

Как видно в красном шкафу "=TEST+TEST2" - клеммник Х01 с не перенумерованными клеммами. В программе если глянуть на предпросмотр кабеля, то видим что клеммы этого клеммника промаркированы марками проводов подходящих к клеммам

Расследование показало что программа не причем - так АЭ заполняет базу данных проекта. То есть в ней автоматом назначается пустой клемме марка проводника. Вот скрин из БД проекта:

Как видно колонка PIN2 заполнена значениями марок проводников. Колонка PIN1 заполнена правильно, номерами клемм.

Однако если удалить марки проводников - все становится хорошо, номера клемм обозначаются знаками вопроса.

В БД проекта все как положено:

Вот така хуйня малята.

Created with the Personal Edition of HelpNDoc: Converting Word Docs to eBooks Made Easy with HelpNDoc


Вопрос-Ответ

Мне иногда задают всякие вопрос про то как пользоваться и как работают отдельные функции. В общем я буду собирать сюда пары "Вопрос-Ответ". Тексты вопросов и ответов я буду немного корректировать. Всё без имен. Всё обезличено. Если кто захочет внести сюда имя и ссылку на автор, то я не против. Просто напишите и я откорректирую.

Вопрос

Ответ

Возникла сложность в определении типа кабеля. Импортный кабель OLFLEX CLASSIC 110 SY 3G1, где 2рабочих жилы «G» это защитный проводник.

При формировании кабельного журнала, записывается как (непонятный тип кабеля) при этом количество задействованных жил считает (непонятный тип кабеля Занято: 2 ).

Если в каталоге автокад переименовать кабель, OLFLEX CLASSIC 110 SY 3х1, в этом случаи данные воспринимаются, но это уже другой тип кабеля.

Возможно добавить принятие программой обозначение «G» дополнительный проводник.

. Да есть такая возможность. Я посмотрел как кодируется жильность и тип у Lapp Kabel - доработаю в ближайшее время.

Но пока что я бы предложил такой вариант: даем особенный тип кабеля (например OLFLEX CLASSIC 110 SY 3х1 - не плохое решение) который потом простым поиском и заменой по всему проекту, в том числе и по каб журналу переименовывается в то, что нужно. Да, решение некрасивое, но если есть срочная необходимость - как временный вариант вполне пойдет.

Разбор типа кабеля происходит так:

Тип кабеля представляет собой конструкцию из буквенной и цифровой частей. Пробелы игнорируются и при разборе удаляются. Отделяется тип и анализируется числовая часть. Например: КПСВЭВнг(А)-LS 10х2х0,5 будет разделен на "КПСВЭВнг(А)-LS" и "10х2х0,5", сечение кабеля "0,5" будет отброшено и последующие цифры перемножены. В результате число жил равно 20. Для кабеля АВВГнгд "4х6 + 1х2.5" будет получено число жил 5. Вообще общее название должно быть таким:

N x N x + N x N x .

При выводе файлов на печать (ПДФ) форматные рамки А3 получаются обрезанные до формата А3.

Интересный глюк. Есть подозрение что акад просто не настроен для печати. Поясню:

Печать осуществляется только на виртуальный принтер "DWG2PDF" который штатно идет в поставке Автокада.

Для каждого принтера существует свой файл с настройками, который описывает так называемые профили - настройки для каждого листа.

Для того что бы настроить "нестандартные форматы ЕСКД" пришлось корректировать файл с настройками. То есть для этого принтера были созданы и добавлены профили для каждого форматного листа начиная с А4 и до А0х3. Эти профили имеют свои уникальные имена.

Если выбирается этот принтер, то в меню листов подтягиваются из файла настроек этого принтера все доступные профили для печати. И новые профили соответственно.

Но естественно при установке с нуля автокада на комп, у этого принтера файла с этими дополнительными настройками нет. Нужно их добавить. Это делается просто - нужно заменить штатный файл настроек новым.

Что бы облегчить задачу я это дело автоматизировал. На закладке "файлы проекта"-"Настройка Автокада для печати" есть кнопка "Настроить принтер... ". Если ее нажать, то программа сама постарается найти папку с принтерами и сама добавит туда нужный файл. Но поиск производится по путям записанным в реестре при установке Автокада. Если там сбой (после клинера или просто реестр побит) и найти не получается, необходимо сделать это руками.

При программа не может найти путь, то рядом с программой всегда создается каталог со всеми необходимыми файлами настроек для принтера. Они будут лежать в соответствующих каталогах, имена которых совпадают с именами штатных каталогов .

Принтеры по умолчанию лежат тут:

C:\Users\UserLocal\AppData\Roaming\Autodesk\AutoCAD Electrical 2021\R24.0\rus\plotters

При печати, когда программа находит рамку по имени блока, она пытается определить формат рамки - А3 или еще какой. Делается это в три шага. Сначала ищется атрибут "MyNameFormatThisRamka" - он скрытый и создается по умолчанию. Я его добавил относительно недавно. В старых версиях программы его нет. В нем хранится кодовое имя рамки и ее параметры. Если атрибута нет, то декодируется имя блока рамки - а вдруг осталось по умолчанию. Если не получилось, то производится определение размеров блока и по нему определяется формат и поворот рамки.

Если и это не прокатило (многие любят масштабировать рамку под чертеж а не чертеж под рамку) то увы - берется А4...

UPD. Сейчас это учтено и масштабирование обрабатывается корректно.

где можно почитать, посмотреть про создание своих стилей для стрелок адресов?

Для сздания своей стрелки можно просто откорректировать под себя стандартный блок.

Более подробно на сайте "Мечта Электрика", там его ведет представитель из Автодеска.

И еще могу порекомендовать пару каналов на ютубе:

  • канал 1
  • канал 2

А вообще есть подробный мануал в хэлпе AutoCAD Electrical (локальный chm или онлайн) - там подробно описано как создавать свои типы стрелок ссылок.

Сама идея проста как веник: берется любой типовой блок стрелки поставляемой с AutoCAD Electrical и корректируется. Моно создать новый, а можно просто отредактировать существующий

При установке AutoCAD Electrical с нуля устанавливается 4 типа стрелок-ссылок. Каждый тип состоит из блоков для четырех направлений (влево, вправо, вверх, вниз). Блоки расположены в каталоге элементов УГО.

На картинке я показал свои УГО ссылок. Просто берем любой НА и переименовываем как нужно - там меняется цифра в наименовании. Все очевидно. Далее меняется графика внутри блоков в соответствии с новым стилем.

После новые стрелки можно выбирать вручную, а можно добавить в меню. Вот именно добавка и самое сложное. Там муторно, но вполне решаемо.

Я таким путем сделал ссылки "шина" и сделал более красивые стрелки.

А есть какой то способ быстро заполнять строки 1-3 описания для пачки из нескольких чертежей? Открывать свойства каждого чертежа муторно долго.

Да, есть. Но для этого нужно очень аккуратно сделать следующее:

  • Открываем файл WDP в текстовом редакторе и просматриваем сверху вниз.
    Файл проекта WDP это просто текстовый файл и его можно корректировать, хоть в обычном блокноте. При сохранении откорректированного АКАД отслеживает что были изменения в проекте и оперативно корректирует свою базу данных проекта.
  • В файле проекта сначала идут строчки которые начинаются со звездочки, например: *[1]23-РЗА. Потом будут аналогичные с "+" и "?". Их много и они несут всякие настройки - их ни в коем случае не трогаем.
  • Вот после них пойдут описания чертежей проекта.

Структура такая:

===Щит керування ПС. Загальний вигляд (строка №1)

===Щит управления (строка №2)

===Внеш вид (строка №3)

=====SUB=ОПУ/ЩУ (строка №4)

Щит управления Внешний вид_001.dwg (строка №5)

Строка №1 - всегда первая и начинается с трех знаков равно "===", это то что попадает в атрибут штампа OPIS, название чертежа.

Строки 2 и 3 - начинается с трех знаков равно "===", это описание чертежа в дереве чертежей в АКАДЕ (если включить их вывод в дерево).

Строка 4 - начинается с четырех знаков равно "====" и всегда расположена над именем файла чертежа, это каталог в дереве проекта.

Строки 1, 2,3,4 - необязательны, никак на работу AutoCAD Electrical не влияет.

Строка 5 - имя файла dwg, относительный путь относительно файла WDP - обязательная.

Первая строка - название чертежа в штампе, идет в однострочные атрибуты "OPIS1", "OPIS2", "OPIS3" или в многострочный атрибут "OPIS" в блоке штампа.

Если используется многострочный "OPIS", то просто вся строка загоняется в МТЕХТ.

Если используется несколько строк состоящих из однострочных атрибутов"OPIS1..3 ", то строки указываются через символ "|". Например для трех строк:

===строка1|строка2|строка3

количество строк/атрибутов насколько я знаю не ограничено. Единственно нужно проверить что бы в файле WDT была такая строчка:

OPIS1|OPIS2|OPIS3 = DWGDESC

Таким образом при необходимости можно быстро, простым копипастом, заполнить первую строку у всех нужных файлов откорректировав файл WDP.

По поводу атрибутов в штампе: Я стараюсь использовать все таки один атрибут МТЕХТ. Единственный минус - при обновлении штампов нужно делать с галочкой "открывать каждый чертеж", иначе он не заполняет атрибуты МТЕХТ.

Так же осталось непонятно как вручную удалить перемычку при одинаковой маркировке жил.

Столкнулся с таким при разрисовке шлейфа для RS-485. Все устройства навешиваются последовательно, а при наличии нескольких в одном шкафу выходит что есть 6 клемм (3 для витой пары что пришла - устройство 1 и 3 для отходящей от устройства N в следующий шкаф). И выходит что непосредственно связи между клеммами нет, но жилы сохраняют свою маркировку (TA,TB,GND), а программа распознает ее как перемычку.

Тут нужно принять такое правило, которое я принес из релейной защиты, но думаю оно должно быть повсеместным:

В проекте не может быть двух одинаковых маркировок.

Если есть две одинаковые маркировки, то они между собой электрически связаны.

Это немного нарушает "традиции ленивого проектирования", наследие прошлых лет. Я видел импортные проекты - там такое в принципе не допускается.

AutoCAD Electrical тоже выполнен с учетом этого правила. Однако он совсем по другому работает с клеммником. И в нем возможно создание в одном блоке двух клемм к которым подходят проводники с одинаковой маркой/сигналом, но при этом между ними нет перемычки.

Перемычка в понимании AutoCAD Electrical это деталь, со своим заказным номером. Однако она не имеет УГО, но в спецификацию попадает. Ее просто назначают в редакторе клеммных колодок.

Когда я начинал создавать программу, а создавалась она именно под клеммники, то я и заложил свое правило в прорисовку клеммника:

Если на клеммнике есть две две клеммы на которые приходит два провода с одинаковой маркой, то автоматом рисуется перемычка. Ее нет физически в проекте. Она создается на лету при прорисовке клеммника.

Поэтому ответ на вопрос- увы, никак. И это правильно.

Но в клинических ситуациях есть выход и достаточно красивый - нужно дать смысловые расширения к марке провода соответствующее функциональной группе/назначению и т.д.

Допустим приходит по кабелю W1 три жилы: TA-RS1, TB-RS1, GND-RS1 и отходит кабель W2 с жилами TA-RS2, TB-RS2, GND-RS2. Или по номеру порта дать марку, как угодно. Но обязательно нужно в марке обозначить что это разные сигнальные цепи (а в жизни так оно и есть). К стати, человеческий фактор еще никто не отменял и такая подробная маркировка будет уменьшать вероятность ошибки.

Как пример - на ОРУ 110 кВ стоят ОДИНАКОВЫЕ ящики ЯЗН и оттуда в кабеле уходят идентичные марки А601, В601,С601, N601. Они толпой приходят в шкаф ТН 110 кВ расположенный в ОПУ. Тут как бы сам черт ногу сломит. Поэтому и ящики и марки жил нумеруются по смыслу, по присоединению - ЯЗН-W1H или ЯЗН-TV1H, тогда жилы будут соответственно А601-TV1H, В601-TV1H,С601-TV1H, N601-TV1H. И никакой путаницы в клеммнике.

Отсюда к стати идет и еще одно правило:

В проекте нужно вырисовывать всё, что есть в жизни.

Поясню. Как быть если есть в цеху 120 ОДИНАКОВЫХ шкафов? :-) Создать и нарисовать один? Нет, тогда кабельные связи отсутствуют и автоматически кабельный журнал не собрать. Правильный путь - рисовать 120 идентичных шкафов! Однако кому нужна такая гора макулатуры? Выход достаточно простой: создается за форматной рамкой рядышком 120 шкафов, но в рамку вносится только ОДИН и только типовые цепи. То есть для АЭ есть все 120 шкафов с их детальками, а в проекте выдается только первый (типовой) шкаф на 10 листах с индивидуальным перечнем элементов. И на чертеж добавляется известная пометка: "Применимо ко всем остальным шкафам".

Как быть с монтажной панелью, элементы которой привязаны к базе компонентов?

Тут надо понимать и принимать как данность, что монтажная панель к схемам не имеет никакого отношения. То есть в начале идут схемы, в них есть базовые элементы, которые несут в атрибутах все параметры детали, ее производителя итд.

Однако разработчики AutoCAD Electrical придумали такой механизм как внешние виды деталей - собственно то, что и называют монтажной панелью. Вы можете создать внешний вид детали (или несколько) например внешний вид ключа, и разместить его на внешнем виде панели. Он будет наследовать от базового блока все настройки.

Однако я так сложно не заморачиваюсь. Делаю гораздо проще - создаю блок дочернего элемента с минимумом атрибутов, который наполняю графикой, изображением детали. И далее размещаю полученный элемент на изображении монтажной панели. Получается связь с элементом. И в случае если я что-то корректирую с элементом в схеме - меняется и описание/обозначение, и т.д. на внешнем виде. Однако не поменяется сам внешний вид и расположение.

Это сильно упрощает мне задачу но и накладывает ограничения. Если мне "приспичит" заменить тип реле с Relpol на Siemens - внешний вид придется менять в ручную. Теоретически привязка блока внешнего вида к базе данных деталей, к конкретному типу детали позволит "на лету" менять и внешний вид детали на монтажной панели. Однако я еще не сталкивался с такой необходимостью.

Нужно ли подготавливать шаблон чертежа, или прога сама все сделает?

По желанию. Шаблон чертежа можно создать свой собственный и сохранить где ни будь в своих папках. При создании нового чертежа всегда есть возможность указать файл шаблона который будет использован. После, при необходимости и если нет в шаблоне) в чертеж вставляется рамка (своя или из программы - не суть важно, из программы просто быстрее) нужного формата и далее идет разработка схем.

Рамка - это блок с определенным именем. Имя нужно ТОЛЬКО для печати проекта и контроля типов форматных рамок, если их несколько в проекте. В остальном все равно как и что нарисовано в рамке.

Я обычно делаю так: создаю листы сколько нужно, вкидываю туда рамки, разрабатываю схемы, а потом начинаю "причёсывать", наводить красоту в проекте:

- разбиваю "многорамочные" чертежи на отдельные чертежи с одной рамкой в файле;

- далее нумерую листы

- создаю общие данные (листы могут сдвинутся - общие данные могут занять до 4-5х листов),

- при необходимости снова нумерую и обновляю общие данные,

- только после всего выше обновляю ссылки в чертежах и номера листов в правом верхнем углу.

- после всего этого создаю/корректирую файл блока форматной рамки, делаю графику именно той формы и вида, который требует заказчик (были варианты когда требовали сделать поля дополнительные, изменить набор полей и форму итд)

- запускаю обновление блоков рамок по всему проекту указывая созданный файл с форматной рамкой. В результате все рамки становятся автоматически правильными.

Шаблон для нового чертежа в проекте несет только наборы слоев, заготовки каких-то блоков итд. Но это не обязательно. Все равно когда AutoCAD Electrical создает чертеж и включает его в проект он автоматом настраивает лист - настраивает набор слоев, типы проводов и т.д.

Нужны ли свои типы проводов, и работает ли прога с ними?

Программа не учитывает типы проводов. Тип провода определяется слоем на котором нарисован проводник.

За более 10 лет, что я пишу программу, еще никто не захотел и не предложил вариант использования пользовательских типов проводов. Наверное дело в специфике - я не разрабатываю конструктив шкафов, а просто делаю автоматику/релейку/електрику. Тут на 99% (в схемах) важна сама связь, но не то, каким именно проводом это выполнено. Вот наружные связи нужно указывать каким кабелем выполнить, а внутренности шкафа будет все равно "доводить" конструктор на заводе, где мы заказываем изготовление шкафов. И сделает это гораздо лучше чем я.

Created with the Personal Edition of HelpNDoc: Free help authoring environment